LMS 3.2 DFM Import of Devices Failed

Unanswered Question
Mar 14th, 2010
User Badges:

Hi,


My name is Ashley. I have recently installed LMS 3.2. Everything is working fine, CM, CS,HUM, RME,IPM. However, I am not able to import devices from DCR to DFM.


On Auto Allocation Window, I get the following error:


Error in getting instance of TreeGenerator class 
com.cisco.nm.trx.kdm.utils.DcrGroupSelectorTreeGenerator
Root Cause:com.cisco.nm.xms.ctm.common.CTMException: URN_NOT_FOUND : urn "ogs_server_urn" : Not found !!


On Manual Allocation, I cannot see any device in the DCR.



I have seen in a post how to reset the DFM database, but still does not work.


net stop crmdmgtd


cd CSCOpx\bin
del NMSROOT/objects/smarts/local/repos/icf/DFM.rps



del NMSROOT/objects/smarts/local/repos/icf/DFM1.rps


perl dbRestoreOrig.pl dsn=dfmEpm dmprefix=EPM


perl dbRestoreOrig.pl dsn=dfmInv dmprefix=INV


perl dbRestoreOrig.pl dsn=dfmFh dmprefix=FH


net start crmdmgtd
perl dbaccess.pl install



Could you please help, I am running out of ideas.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Joe Clarke Mon, 03/15/2010 - 11:13
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

Post the output of the pdshow command from this server.

Joe Clarke Wed, 03/17/2010 - 15:44
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

Post the output of the command:


NMSROOT/objects/smarts/bin/brcontrol
Joe Clarke Thu, 03/18/2010 - 00:44
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

It looks like you might be hitting a known bug.  Try rebooting the server, then see if this problem goes away,

ashley_dew Thu, 03/18/2010 - 01:02
User Badges:

Hi Joe,


The problem persists when rebooting. I have tried on several occasions.


Is there a patch for that bug available.

Joe Clarke Fri, 03/19/2010 - 10:30
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

If the problem persists after a full server reboot, then you are probably not seeing this bug.  Post the NMSROOT/objects/smarts/local/logs/DFM.log and DFM1.log as well as the brcontrol output after the full reboot.

Actions

This Discussion