No Internet for my L2TP VPN clients

Unanswered Question
Mar 15th, 2010
User Badges:

Hi,


I have setup a L2TPoverIPsec tunnel, for remote access but I have some trouble with it. Clients (pool 192.168.254.10 - 192.168.254.20) can access to local ressources (192.168.1.0/24), but can't goes on the Internet. What I have miss ?


For now, my ACL are :

inside

192.168.1.0 --ip--> any : permit

192.168.254.0 --ip--> any : permit


outside

any --icmp--> any : permit


My nat rules are :

Exempt 192.168.1.0 to 192.168.254.0

any are translated with outside ip adress interface


I would appreciate any feedback on how to get my clients access to Internet.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
calandos14 Mon, 03/15/2010 - 04:43
User Badges:

In my log, I had


flow is a loopback so I enable traffic between two interfaces with the same security levels. After this I was getting a timeout.


So I added a nat rule to my outside interface (i'm not sure of it) : my network 192.168.254.0 is now translated to my outside IP address, but now i have in my log "No translation Group found"


Running config


: Saved
:
ASA Version 7.2(4)
!
hostname fwasa
domain-name sten.local
enable password 2GSomNmOmBsH1L9h encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
names
!
interface Vlan1
nameif inside
security-level 100
ip address 192.168.1.1 255.255.255.0
!
interface Vlan11
nameif outside
security-level 0
ip address 1.2.3.4 255.255.255.252
!
interface Ethernet0/0
switchport access vlan 11
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
ftp mode passive
dns server-group DefaultDNS
domain-name sten.local
same-security-traffic permit inter-interface
same-security-traffic permit intra-interface
object-group protocol TCPUDP
protocol-object udp
protocol-object tcp
access-list inside_access_in extended permit ip any any
access-list outside_access_in extended permit ip any any
access-list outside_access_in extended permit icmp 192.168.254.0 255.255.255.0 any
access-list NONAT extended permit ip 192.168.1.0 255.255.255.0 192.168.254.0 255.255.255.0
pager lines 24
logging enable
logging monitor emergencies
logging asdm informational
mtu inside 1500
mtu outside 1500
ip local pool POOL_VPN 192.168.254.10-192.168.254.20 mask 255.255.255.0
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-524.bin
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list NONAT
nat (inside) 1 0.0.0.0 0.0.0.0
nat (outside) 1 192.168.254.0 255.255.255.0
access-group inside_access_in in interface inside
access-group outside_access_in in interface outside
route outside 0.0.0.0 0.0.0.0 1.2.3.5 1
1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
aaa authentication ssh console LOCAL
http server enable
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set TRANS_ESP_3DES_MD5 esp-3des esp-md5-hmac
crypto ipsec transform-set TRANS_ESP_3DES_MD5 mode transport
crypto dynamic-map outside_dyn_map 20 set transform-set TRANS_ESP_3DES_MD5
crypto map outside_map 20 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map interface outside
crypto isakmp enable outside
crypto isakmp policy 10
authentication pre-share
encryption 3des
hash md5
group 2
lifetime 86400
crypto isakmp nat-traversal  20
telnet timeout 5
ssh 192.168.1.0 255.255.255.0 inside
ssh timeout 5
ssh version 2
console timeout 0

group-policy DefaultRAGroup internal
group-policy DefaultRAGroup attributes
dns-server value 1.2.3.6
vpn-tunnel-protocol IPSec l2tp-ipsec
default-domain value sten.local
intercept-dhcp enable
username jc password qIuqP9yPWB7g+wXXBU1D5A== nt-encrypted privilege 15
tunnel-group DefaultRAGroup general-attributes
address-pool POOL_VPN
default-group-policy DefaultRAGroup
tunnel-group DefaultRAGroup ipsec-attributes
pre-shared-key *
tunnel-group DefaultRAGroup ppp-attributes
no authentication chap
authentication ms-chap-v2
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
  message-length maximum 512
policy-map global_policy
class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect netbios
  inspect rsh
  inspect rtsp
  inspect skinny
  inspect esmtp
  inspect sqlnet
  inspect sunrpc
  inspect tftp
  inspect sip
  inspect xdmcp
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:d8d9876a2fa0351182244a60e99f3ada
: end
asdm image disk0:/asdm-524.bin
no asdm history enable

Actions

This Discussion