PPP

Answered Question
Mar 15th, 2010
User Badges:

Hello,


I have a cisco router 18XX series with 2 fastethernet ports,1 console,1 AUX. ISP has dropped 1 ethernet cable to branch office for internet connection, I want to configure a PPPOE on ethernet interface to connect to internet.


Can anybody link me to proper explanation doc's or book, for better troubleshooting and configuration.


Thanks.

Correct Answer by paolo bevilacqua about 7 years 1 month ago

You may need to configure speed and duplex on the interface.


Also


interface FastEthernet0/0
ip nat outside



is not needed. The actual interface is Dialer.


ip route 0.0.0.0 0.0.0.0 Dialer1


Also not needed. Done with ppp command.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
thomasandy32 Mon, 03/15/2010 - 13:32
User Badges:

Hello bevila,


I have been to this doc before, I had configured according to the above document instead of atm interface i have 2 Ethernet interface,1 is connecting to internal network and the other I m connecting the ISP link, i want to confirm instead of ATM i have fastethernet Interface connected to ISP link,Will it work ??????


interface FastEthernet0/0
description Connected to ISP Link
no ip address
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
pppoe enable group global
pppoe-client dial-pool-number 1
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
!
interface FastEthernet0/1.25

description connected to internal network
encapsulation dot1Q 25
ip address 192.168.25.1 255.255.255.0
ip nat inside
ip virtual-reassembly
!
interface Dialer1
ip address negotiated
ip mtu 1492
ip nat outside
ip virtual-reassembly
encapsulation ppp
ip tcp adjust-mss 1455
dialer pool 1
dialer idle-timeout 0
dialer persistent
dialer-group 1
ppp authentication chap callin
ppp chap hostname XXXXXX
ppp chap password  XXXXXXX
ppp pap sent-username XXXXX password 0 XXXXX
ppp ipcp dns request accept
ppp ipcp route default
ppp ipcp address accept


no ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Dialer1
!
ip http server
no ip http secure-server
ip nat inside source list 110 interface Dialer1 overload


/* Style Definitions */ table.MsoNormalTable {mso-style-name:"Table Normal"; mso-tstyle-rowband-size:0; mso-tstyle-colband-size:0; mso-style-noshow:yes; mso-style-priority:99; mso-style-qformat:yes; mso-style-parent:""; mso-padding-alt:0in 5.4pt 0in 5.4pt; mso-para-margin-top:0in; mso-para-margin-right:0in; mso-para-margin-bottom:10.0pt; mso-para-margin-left:0in; line-height:115%; mso-pagination:widow-orphan; font-size:11.0pt; font-family:"Calibri","sans-serif"; mso-ascii-font-family:Calibri; mso-ascii-theme-font:minor-latin; mso-fareast-font-family:"Times New Roman"; mso-fareast-theme-font:minor-fareast; mso-hansi-font-family:Calibri; mso-hansi-theme-font:minor-latin; mso-bidi-font-family:"Times New Roman"; mso-bidi-theme-font:minor-bidi;} access-list 110 permit ip any any
!

dialer-list 1 protocol ip permit

paolo bevilacqua Mon, 03/15/2010 - 13:56
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

That is what the document is all about.


Use:

mtu 1492
ip tcp adjust-mss 1452


not needed:

ip mtp 1492

dialer idle-timeout 0
dialer persistent
dialer-group 1


Please remember to rate useful posts clicking on the stars below.

thomasandy32 Mon, 03/15/2010 - 14:15
User Badges:

Thanks for ur reply,appreciate


1 more query,


When i connect ISP link to my router the link is up but the protocol is down no LED is blinking on router interface. But when i connect to my laptop  LAN Card the LED glows and the physical connection is UP,


Is i m missing anything in the config's.???


Thanks

Correct Answer
paolo bevilacqua Mon, 03/15/2010 - 14:52
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

You may need to configure speed and duplex on the interface.


Also


interface FastEthernet0/0
ip nat outside



is not needed. The actual interface is Dialer.


ip route 0.0.0.0 0.0.0.0 Dialer1


Also not needed. Done with ppp command.

Actions

This Discussion