can't pass SLP across vlans

Unanswered Question
Mar 15th, 2010

Hi, I have 3560 switches for some reason I cannot login to NDS while crossing vlans because I cannot browse the tree. I think it has to do something with SLP multicast address not being able to cross the vlans. I am able to browse and log in while I am on the same vlan as the Netware servers. I have no acl configured that would deny this traffic.  I am using flash:c3560-ipbase-mz.122-25.SEB4/c3560-ipbase-mz.122-25.SEB4.bin"

Any help would be appriciated, thanks in advance.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
darek Mon, 03/15/2010 - 13:54

OK, I guess I can do that but I had the switches working properly before without the mlticast turned on. I only added etherchannel between 2 switches that was all I did before this problem occured. What would be the command to enable to multicast?

Reza Sharifi Mon, 03/15/2010 - 14:03

if you rnable ip igmp snooping in global config, it will enable it for all existing vlans or ip igmp snooping vlan 10 enables it only for vlan 10

HTH

reza

darek Mon, 03/15/2010 - 14:10

OK thanks again, do you think this will decrease performance of the network by turining this on? We have a lot of Apple's and they seem to use multicast a lot.

Pronoy Dasgupta Sun, 03/21/2010 - 09:15

Bart,

Couple of things, upgrade the IOS on the switch, and enable "ip pim dense-mode" on the vlan the servers and clients are in (if not already done). Also disable "ip directed-broadcast".

Was this working before by any chance?

Thanks

Pronoy

bsudol79p Mon, 03/22/2010 - 07:05

The SLP worked before on the old IOS, then I had changed to do some changes on the trunk links between the switches. Once I updated the switches to the new IOS and put in the commands you have mentioned it worked. I just don't understand why it was working with the old IOS before the trunking link changes. Thanks for your help!!!!

Actions

This Discussion