Error Upgrading to Device Pack 60 on Subscriber

Answered Question
Mar 15th, 2010

Hi,

We're running a cluster of two 7845's which are supposed to be identical, yet when I try and apply the 4.2.3 Device Pack 60 Update for Version 4.2(3) that we are running I get this error on the subscriber:

Critical Error, Replication Initialization FAILED

Please made sure all nodes in the cluster are online (which they are!) and on the same version before upgrading to this patch.

It worked on the Publisher and Pub rebooted and they are both running the same version to the best of my knowledge.

The strange thing is that now after trying this update the publisher is now saying (when trying to use Service Activation from CM Serviceability on the primary publisher)

Status: Connection to the server could not be established

Network connectivity is ok and I can log in remotely the subscriber. Also seeing Error Not CDR Primary in the Subscriber App Event log if that's related at all? And the below which looks like more of an issue.

Event Type: Error
Event Source: Cisco Database Layer Monitor
Event Category: None
Event ID: 3
Date:  3/15/2010
Time:  11:45:13 PM
User:  N/A
Computer: HO-CM-02
Description:
Error: UNKNOWN_ALARM:kDbConnectionFailed
  AdditionalInfo: Could not open connection. ReturnCode= [0x00004814]

Any help/guidance would be appreciated.

Thanks.

I have this problem too.
0 votes
Correct Answer by Aaron Harrison about 6 years 8 months ago

Hi

I'm reasonably sure the default is for the local Administrator account password not to expire.

You certainly would not want them to be out of sync within a Windows CCM cluster...

Aaron

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (3 ratings)
Loading.
David Hailey Mon, 03/15/2010 - 16:38

What is the CCM replication status of the cluster?  Use DB Helper or SQL to look and see what's going there first.

Hailey

Please rate helpful posts!

nickpalmermorewood Tue, 03/16/2010 - 00:51

Hi Hailey,

Looking at SQL Enterprise Manager on the Subscriber:

Replication Publications - No Items

Subscribtions - Connected, Type "Pull", Status "Running", Last Action "No Replication Transactions are available", Replication Type "Transactional",

However this morning I appeared to now have communication back with the subscriber as it was available via the CM administrator.

Still not sure why the device pack update failed?

Thanks.

nickpalmermorewood Tue, 03/16/2010 - 03:06

Did some reading up about possible password mis-match issues and it seems that my credentials

which are part of the Administrators group could have been an issue. Seems that due to password expire policies my passwords were not the same on both servers.....could this have been the issue.

I tried the update with the Administrator account where the passwords match and it was done in a couple of minutes. Strange as I couldn't see anything documented relating to this and the release notes in the software download area for Device Pack 60 don't work as they throw back a missing page error.

Correct Answer
Aaron Harrison Tue, 03/16/2010 - 04:07

Hi

I'm reasonably sure the default is for the local Administrator account password not to expire.

You certainly would not want them to be out of sync within a Windows CCM cluster...

Aaron

nickpalmermorewood Tue, 03/16/2010 - 04:20

Hi Aaron,

I double checked and the Administrator default account is set to never expire.

But as system managers we have our own logins which form part of the Administrators group.......I think that's where I went wrong as I was using my own login account and the two passwords were not synchronized - I have now rectified this though.

nickpalmermorewood Tue, 03/16/2010 - 04:34

Hi Aaaron,

Yes everything seems to be hunky dory now! Device pack installed correctly using the Administrator credentials

Actions

This Discussion