How to connect remote offices using EoMPLS?

Unanswered Question
Mar 16th, 2010
User Badges:

Hi All,


Network Topology:


pc-1 -> switch-1 ->7606-1 <---> 7606-2 <-- switch-2 <-- pc-2


- All the "1' devices are geographically separated from all the "2" devices.

- There is a /30 linking 7606-1 and 7606-2 core routers with each other.

- MPLS is already running between the 7606's.

- pc-1 is in vlan 12 with ip 172.16.70.x/24

- switch-1 and switch-2 are in different mst regions.


Issue:


I want to put pc-2 on the same ethernet segment (ip subnet) as pc-1. How do I accomplish this? I've had a look at EoMPLS but can't find anything to help me out. Should I be creating SVI's on the 7606?


7606-1:


interface Loopback99
description LPD ID and BGP source-update address
ip address 172.16.99.1 255.255.255.255
!
interface GigabitEthernet5/6
description Connection to 7606-1
ip address 203.17.96.x 255.255.255.252
tag-switching ip
!
interface Vlan100
no ip address
no ip mroute-cache
mpls l2transport route 172.16.99.2 100
no shut


7606-2:


interface Loopback99
description LPD ID and BGP source-update address
ip address 172.16.99.2 255.255.255.255
!
interface GigabitEthernet4/0/2
description Connect to 7606-1
ip address 203.17.96.x 255.255.255.252
negotiation auto
mpls ip
!
interface Vlan100
no ip address
no ip mroute-cache
mpls l2transport route 172.16.99.1 100
no shut


If I am to use SVI on the 7606's, how do I get this working with the switches? We primarily use WS-C3560G switches (12.2(40)SE) but I can't issue any xconnect commands on the switch ports.


Thanks.


Andy

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
asaykao73 Tue, 03/16/2010 - 22:51
User Badges:

Thanks shivl.


I'll give it a try.


I came across some of your EoMPLS examples a few weeks ago but forgot the url to your web site. Thanks for the link.


Cheers.


Andy

shivlu jain Tue, 03/16/2010 - 23:09
User Badges:
  • Silver, 250 points or more

No Problem. Please update with your latest testing results.


regards

shivlu jain

asaykao73 Wed, 03/17/2010 - 01:00
User Badges:

I guess it's easy enough to create SVI on the 7606's and then add in the xconnect configuration but how do I then get the switches to particpate in EoMPLS so that the devices connected to the switch ports on switch-1 and switch-2 appear as if they are in the same ethernet segment???

shivlu jain Wed, 03/17/2010 - 01:14
User Badges:
  • Silver, 250 points or more

PC(192.168.1.10)----Vlan 10-----Switch-----Vlan10-----(Intiate xconnect from this interface-Router(PE))--------------------------Router(PE)Xconnect Termination-------Vlan 10-------Switch-----------PC(192.168.1.11)


Hope this will help.


regards

shivlu jain

ww.mpslvpn.info

judebryant Wed, 03/17/2010 - 08:18
User Badges:

shivlu,


there is a 3750 metro switch that can use the xconnect command.  They have two ES ports on them.  Copper GigE I believe.


Otherwise you are correct.


Regards

Jude Bryant

Pioneer Telephone

shivlu jain Thu, 03/18/2010 - 03:24
User Badges:
  • Silver, 250 points or more

3750 Supports only vrf lite not MPLS.


http://www.cisco.com/en/US/docs/solutions/Enterprise/Network_Virtualization/PathIsol.html


But in case of 3750 ME with ES it supports both l2 and l3 mpls.


Please refer to the below document for understanding the EoMPLS in 2750ME


http://www.cisco.com/en/US/docs/solutions/Enterprise/Data_Center/HA_Clusters/HA_IAF_5.html#wp1081849


Please refr to the below post for configuring E0MPLS on 7600 because it should be same as both the products are using ES ports.


http://ccie-in-3-months.blogspot.com/2009/06/eompls-on-7600-pfc-based-svi-based.html



regards

shivlu jain

www.mplsvpn.info

Actions

This Discussion