Trying to access my 851w from outside my lan, but can access inside fine

Answered Question
Mar 17th, 2010


I purchased a 851w to use as my home router and to learn more about the cisco IOS. I have been spending some time studying for CCENT/CCNA and so far I have enjoyed learning as I go. However, I am having problems accessing this router from a remote location via ssh. I can access it just fine from my lan, but not outside it from another location. Currently, I am not using this router for internet access or anything else other than learning about the IOS, and it is connected to a basic dlink wireless router dir-615. I have port forwarding setup on the dlink that any traffic coming in on port 22 is directed to the 851w at I also have the 851w connected with a crossover cable to a switch that is connected to the dlink router.

Like I said, I can connect just fine from my lan, but can't connect from outside. I have tried a few different things but nothing works. I also use Teraterm to connect, but have tried Putty too. I also use ddns to access it, but I have also tried the wan ip address of the dlink with no luck.

Could someone please take a look at my very basic running config and explain what I might need to do different?

Thanks in advance.


I have this problem too.
0 votes
Correct Answer by martinbuffleo about 6 years 7 months ago

In answer to the first question have a read of this that I found:

Not used this router before, so sorry havn't got a config

Correct Answer by martinbuffleo about 6 years 7 months ago

try adding my ip route command then see if your router can ping.

then do:

show ip route

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
martinbuffleo Wed, 03/17/2010 - 09:38

My first thought is routing.

Can your router ping the outside world say

I normally put my default gateways in like this:

ip route

What ports have you got connected to what hardware?

I assume your internal PC is on the subnet?

sclawrenc Wed, 03/17/2010 - 09:50

Hi and thanks a bunch for your quick response.

No, I can't ping anything other than my main router which I have setup as the gateway so why is that? For example,

ip default-gateway

Wouldn't it automatically send anything it doesn't know about to the router?

I have one of the switch ports, Fast Ethernet 0, connected to another switch connected to the dlink router. I have tried different ports but it didn't change anything. I don't have anything connected to the wan port of the 851w. I was trying to simulate remote access of a switch on an internal network. My next step would be to make the 851w my default router and then try to access it from the outside, but I wanted to succeed this way first.

optimus#show ip int br

Interface IP-Address OK? Method Status Protocol

Dot11Radio0 unassigned YES unset administratively down down

FastEthernet0 unassigned YES unset up up

FastEthernet1 unassigned YES unset down down

FastEthernet2 unassigned YES unset down down

FastEthernet3 unassigned YES unset up down

FastEthernet4 unassigned YES unset administratively down down

Vlan1 YES manual up up

Yes, my internal pc is on the subnet.

Best Regards,


Correct Answer
martinbuffleo Wed, 03/17/2010 - 10:01

try adding my ip route command then see if your router can ping.

then do:

show ip route

sclawrenc Wed, 03/17/2010 - 10:04

Well, when i put the ip route command in like you suggested, I was able to connect going through my ddns address. So my default gateway was what needed to be setup differently. I wonder why the command that I had of default-gateway didn't work?

Thanks for your help... weeks of thinking of possible solutions could have been eliminated if I had asked for help earlier.

On another note, do you know of a link to a good running config for this router that will provide good security?

Best Regards,



This Discussion