Unanswered Question
Mar 17th, 2010

I've been trying to get the 7916 working properly with a 7965 phone. I've referenced here http://https://www.myciscocommunity.com/thread/7470 and followed the link given within. I've tried to remove the phoneload from flash and then reload it. However at this time the zipped file only creates the directory of flash:/phone/7916, no file is actually loaded. I don't know where else I can come up with the file that is needed and am hoping someone can help me get a hold of it. I'm not certain that is the underlying issue, as the buttons have previously been configured and operate as expected. The problem is I haven't for the life of me been able to get the labels to come up for the buttons. It just sits there with a blue screen. I've previously checked everything in the doc before removing the file. I removed it without realizing it would be difficult to find a loadable copy. The only thing I could find left to do was see if it was corrupted somehow by installing a fresh one. Also I was going to give a go of the last command referenced here http://www.myciscocommunity.com/thread/2706. the telephony service command. Any help on all of this is greatly appreciated.



I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
SHeidemann Wed, 03/17/2010 - 11:40

So I found the load. I tried that command more specifically I entered


load 7916-24 PHONES/7916/B016-1-0-4.SBN

The file I thought wasn't being uploaded actually was it just ended up at the bottom of the Flash file list. i overwrote it with the different file anyway.

Still nothing.

Any clue as to why the labels wouldn't be showing up on the module. Yes the buttons have been configured via CCA. It defaults the label to the ephone-dn label, good. However once the voice>userextensions page is refreshed the labels are faded out, I assume this is due to them already having the label configured for the dn's. I'm at a loss here. Any thoughts?


SHeidemann Wed, 03/17/2010 - 11:57

Could the problem be something here?

dir flash:/phone/7916

     165 -rw-     166179     Mar 17 2010 13:10:24 -05:00     B016-1-0-4.SBN

I noticed this isn't looking the same as what Steve Di Stefano shows his as and I too am running 8.0.0

SHeidemann Wed, 03/17/2010 - 12:28

I also just tried

UC540#cd 7916

%Error in getting status for flash:/7916 (File not found)

Steven DiStefano Wed, 03/17/2010 - 13:30


You know what....I no longer have tftp server statements or flash files for my system either????

I think I am going crazy :-(

But we should since they are in the default config:

7914, 7915 and 7916's tftp statement and telephone-service load
     CLIS are there in default config

tftp-server flash:/phones/7914/S00105000400.sbn alias S00105000400.sbn

tftp-server flash:/phones/7915/B015-1-0-4.SBN alias B015-1-0-4.SBN

tftp-server flash:/phones/7916/B016-1-0-4.SBN alias B016-1-0-4.SBN

  load 7914 S00105000400
  load 7915-12 B015-1-0-4
  load 7915-24 B015-1-0-4
  load 7916-12 B016-1-0-4
  load 7916-24 B016-1-0-4

BTW, the sidecar Power must be applied (same as phone brick) and connect sidecard to phone and enter ephone type CLI as well:

   type 7961 addon 1 7914

This help?

Steven DiStefano Wed, 03/17/2010 - 13:51

Well, I launched Phone Load manager and saw whaty I didnt have them :-)

I am adding them now.....  try this too....  this way there is no CLI hacking required...


SHeidemann Wed, 03/17/2010 - 14:42

I had originally tried that. I didn't realize they made it there all the way because it added the directory of 7916 in the area with the rest of the phones directory, but stuck the actual file at the bottom of the flash file list. So yes CCA works... I've gone ahead and deleted and readded it through CCA,

You stated type 7961 addon 1 7916... the module is on a 7965. Would this be my problem? It's set for type 7965, otherwise my case is the same.

Thanks for your help


Steven DiStefano Wed, 03/17/2010 - 14:56

I use a 7914 on a 7961 so my ephone command is different than yours on purpose.  I just dont have a 7916.   7916 is compatible with your phone model per http://www.ciscosystems.lt/en/US/prod/collateral/voicesw/ps6788/phones/ps379/data_sheet_c78-468673.html, so good there...

You know what I think?   I think the phone load needs to be in the sub directory and I saw the error you had pointing to the flat flash directory a few posts above...

If you let CCA add the phone load, it should tuck it away into the sub directory flash:/phones/7916 and then the tftp server statements should state the same, and the load statement in telephony -service should use the alias....

You doing all that so i

Doe it look like this?

UC540#sh run | inc 7916
tftp-server flash:/phones/7916/B016-1-0-4.SBN alias B016-1-0-4.SBN
load 7916-12 B016-1-0-4
load 7916-24 B016-1-0-4
UC540#dir flash:/phones/7916
Directory of flash:/phones/7916/

  203  -rw-      166179  Mar 17 2010 16:03:00 -05:00  B016-1-0-4.SBN

And you do have the power cord, right?


SHeidemann Wed, 03/17/2010 - 15:03

That's exactly what I show. And yes pwr cube 3 is plugged in.

Stephanie Heidemann

Steven DiStefano Wed, 03/17/2010 - 15:08

Then why isnt yours working?   :-)

OK, Here is my ephone CLI.

ephone  12
device-security-mode none
mac-address 001A.A136.CF24
ephone-template 16
username "SevenSixtyone" password 12345
type 7961 addon 1 7914
button  1:18 2m13 12w12 14m15
button  16m14

Show us yours, and your debug tftp events please....

SHeidemann Wed, 03/17/2010 - 15:19

Well mine shows

ephon 6

device-security-mode none


mac-addres ***

ephone-template 16

but then that's what they all say, however under

show ephone 7965, where I can see what's going on I don't see * 52508 7965... nothing about the module 7916.I did add the statement type 7965 addon 1 7916-24. Also the buttons like I said are configured, and working. They just won't label, only a blue screen.


Steven DiStefano Wed, 03/17/2010 - 15:27

I dont see the "type 7965 addon 1 7916-24"?

Its getting well past yabba dabba dooo time here in RTP, so if you leave me 'debug tftp events' i can look tomorrow or someone can help, but I am seeing a missing type in your ephone and it wont work for sure without that first....

Happy St. Patrick's Day,


David Trad Thu, 03/18/2010 - 02:44

Hi SHeidemann,

If you used CCA then it would have placed in there all the appropriate lines of codes such as the following:

tftp-server codes for both the phones and the side cart

directory structure on the Flash and the files to suit in their respective folders

telephony-service entries

You will then need to specify the type in the ephone section and also add the addon command as well.

Its getting well past yabba dabba dooo time here in RTP,

I need to find this yabba dabba dooooooo time, it sounds like an interesting place to be :)

I found the most unusual thing the other day, a flash card that would not allow files to be loaded up on it, if you used a card reader, placed the files in their folders and then put the card in the UC it would need see those files, this is the first time i have ever seen such as thing.

If i do not use CCA i then take the card out, and i do a complete file dump, i always have a flash card directory on my system with up-too-date files on it so i can easily do a quick file dump, i also make sure the corrosponding tftp-server and telephony-service commands are in a txt file so i can quickly do a txt dump as well.

We all have to learn some of the more nifty tricks, but the key is to make sure that all your commands originate from a CCA install, this way they are the same and consitant all the time.



SHeidemann Thu, 03/18/2010 - 08:05

Thanks for the reply,

I'm afraid that I've been keeping in line with the CCA and it is not resolving my issue. I've watched the debug tftp and can see the 7916 file request and sent then completed successfully. I'm not quite sure how to capture the debug as I've been working remotely. I'm going back on site today. I figure I will grab the expansion module and see how it tests out else where. I've made the statement type 7965 addon 1 7916-24. Is there any other way of applying a label to a button. The label is configured on the dn that is mapped to the buttons. The buttons are monitor buttons, and they light up when the monitored line is in use, but there is no label. What would prevent the label from displaying?



Steven DiStefano Thu, 03/18/2010 - 14:29

Buttons are created and assigned using CCA's COnfiguration drawer:  Telephony:VOice:User extensions.   You select the phone.  It appears at the bottom (it auto detects just the phone), you click the arrow to open the drop down.  You select the phone with the side car.   Then the buttons appear to label and assign.

Apply and save.

SHeidemann Fri, 03/19/2010 - 09:47

A quick correction. I'm using 8.0.1 on a UC540. I know how to assign the buttons from CCA. I configured them with monitoring from CCA, and they were monitoring. Lighting full red when one of the lines are in use, no label. I dedided to take it off the phone and try it on a 7975. Well that blew everything to pot. I unconfigured the expansion module, had to do it a couple of times as it just wasn't taking, or it moved some of the 65s config to the 7975, since I added the expansion there. That caused the entire box to not see any type 7975 phones. So I tried factory resetting the phones and removing the users that have become corrupt. Now I am working on trying to make sure the flash files for the phones are o'kay. I uninstalled the 7975 and added the loads back via CCA. I think they're good but the phone won't move past the Cisco logo screen after installing the 7975 default file, this was the same behavior of the 7965 before I started messing with the files on flash. Remember this is the 8.0.1 pack that I'm trying to use. At this point I've been able to uninstall the 7965, but the flash can't come up with anymore then the 7965 directory, with no other files in the directory. Every time I try I have to wait something like 7 minutes. Wasting hours away trying to use the CCA just to copy flash files over. Seems that there is something wrong with the file from 8.0.1, so now what? Command line seems the only way to even begin getting the files back onto flash


Steven DiStefano Fri, 03/19/2010 - 12:50

Actually now I would recommend opening a case, since there are too many variables and you are confident in all the easy things I suggested to look at, so you might have a problem, perhaps with all the CLI intervention.  They can also help you debug, which you mentioned earlier you needed help with.

I am sure you entered the 'type' command to match the phone, but I got confused between you using 7965 and 7975, and remember not all sidecars are compatible with all phones.  I gave you a link to your sidecar and it has the phone compatibiity in there.  I hope thats not the problem....

SHeidemann Sun, 03/21/2010 - 08:12

Hey Steve

Gotta gotta share. I've been up through the night. Finally, I had time enough to stick this through. I took the phones and module to my office to troubleshoot due to the uncomfortable conditions I was working in. Comfy chair, and a bit of searching, ultimately you did give me my answer, just in someone elses thread. Turned out the phone loads needed downgraded or rather upgraded just slower, so that they could pick up the compatible loads for the module. I've been seeing the auth failed message and thought I'll deal with that when it gives me fits. Well this was the fit. I don't know how one is to stay out of CLI if the CCA cannot take a phone through the motions. Drag and drop is a no go when you need to load up older files then what come prepackaged. Anywho you set up some beautiful instructions via this link. https://www.myciscocommunity.com/thread/10799 Due to the phones always having said that and I never actually have seen one authorize I thought it was good old crazy box under construction. Not so much, if only I'de known. Also no need to add the addon 1 command.  However... I still don't see it in the show run. Want a peek?

Ta Ta for now




This Discussion