RFC1493 Port Mapping on SRW248G4?

Unanswered Question
Mar 17th, 2010
User Badges:

Hello, I have searched the forums but I have not found anything specific to what I am looking for.

I am trying to figure out how to query an SRW switch for the full RFC1493 table. If I walk the table, the only MAC addresses and ports that are returned to my query are those on gigabit ports. According to the RFC1493 standard this table should list all learned MAC addresses and their associated ports. Again when I walk this table, it does return valid information, but the information is isolated to the gigabit ports on the switch. Nothing for the10/100 ports are ever returned. If I take a known active MAC address on a 10/100 port (shows active in mac-addr table, and is passing traffic) and I do port specific query for the decimal form of the MAC address (<decimal.mac.address.here>; nothing is returned. If I do the exact same query for MAC addresses learned on the uplink (gigabit) ports; it returns the proper port number as expected. I have a number of switches I am testing with and they are behaving identical to what I described above.

I am not sure if this has something to with the snmp "views" configuration. We are using the default view and iso is the only option showing enabled (in the CLI) I am not able to access the GUI on this switch. I have tried creating other views and enabling various other options in addition to iso however this same issue persists.

Any help or experience with this issue would be greatly appreciated. Thanks.


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
alissitz Fri, 03/19/2010 - 08:29
User Badges:
  • Silver, 250 points or more


I am not sure about the CLI.  Can you get any access to the webui?  Here is a link to the admin guide and it shows the different views, sub options, starting on page 51 / chapter 5:


If you want to open a case, the link to find the right support numbers is located here:


See the right hand menu for "small business support contacts"



dcubedllc Fri, 03/19/2010 - 11:15
User Badges:

I have previously read the manual you linked and while it does explain how to configure SNMP, it does nothing to explain what the different SNMP views actually mean or what they enable or disable. I have multiple machines and I have tried accessing the GUIs of multiple switches using Firefox, Chrome, Safari, Iceweasel, and IE8 (with the reg fix) and all of them behave identically in that all I see is a solid blue screen after logging in. I do not have any older machines with an older version of IE. I will likely to have to contact technical support in order to obtain the proper information. Thank you.

alissitz Fri, 03/19/2010 - 20:41
User Badges:
  • Silver, 250 points or more

I remember seeing this login problem on an older firmware of a SRW2008MP.  I cannot remember if it worked with https and not http / vice-versa, or if it was intermittent.  I upgraded and the problem went away, although I have to admit I learned to use the CLI as a work around ...

Do you know the version of code you are running?  Any chance you can upgrade from the CLI?  We do not have a lot of help or documentation for users of the CLI, hummm ... you might have to 'muddle' your way through this.

As I understand it, the configs for this SNMP screen enable and disable the suboptions.  I do not know what the defaults are ... and the additional info you seek may already be enabled in which case you would have found a bug.  I do not know, and we definitely need to see the configs to know for sure.

Unfortunately we do not support the CLI on these switches, although a tech might be able to help you some.

A bummer I have not been much help to you, although I hope this has been helpful.  Best wishes for a great weekend,


dcubedllc Tue, 03/23/2010 - 10:10
User Badges:

Andrew, I appreciate your feedback. My main issue is that in no documentation do I see what specific OIDs the various SNMP views enable or disable.

If it is the case this is a firmware issue it will be a real challenge for us as we are talking hundreds of switches in live production environments. Looking at the current version though, it is very dated, so this could be a real possibility/.

SW version    1.2.2b ( date  20-Mar-2007 time  11:44:49 )

Boot version    1.0.2 ( date  17-Aug-2006 time  14:55:46 )

HW version    00.03.00

I am working to set this up in a lab so that we can play with firmware and other options that are not possible in a production environment. It seems odd though that RFC1493 is functionally there but just providing port mapping information for the gigabit ports and not the 10/100 ports.

Thanks again for your time and input on this matter.


alissitz Thu, 03/25/2010 - 08:04
User Badges:
  • Silver, 250 points or more

Yes I agree ... 

Good to hear you will also be upgrading.

Afterwards, it might be best to call the support center if it still does not work as you desire.  Our support center has access to additional resources.  With this said however, the priority of this case would likely be lower than another who is having network outages so you lab efforts might be a bit more quicker.

If you find the time, please consider posting an update here.  Many thanks



This Discussion

Related Content