rp-address clarification needed

Unanswered Question
Mar 18th, 2010

All,

I'm trying to do a basic config for multicast.  I'm configuring this on a Catalyst 4507.  I'm going with a shared tree, sparse-dense on the vlan interfaces, and configuring a single static RP.  There will be other layer 3 switches involved at some point, all on the same physical network, just with different vlans.

I'm looking at the software config guide for 12.2(44)SG and there is a command for setting a static rp-address(ip pim rp-address xxx.xxx.xxx.xxx).  My question is, I have no idea what that RP address is.  Since that core switch is the RP, do I config it as:

ip pim rp-address 127.0.0.1

If so, what about the other layer 3 switches that are routing traffic?  Do I point the RP command towards the management vlan ip for the main core switch?  The documentation isn't very clear about this.

Thanks in advance!

-Ian

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (2 ratings)
Loading.
John Blakley Thu, 03/18/2010 - 10:17

Ian,

The RP address has to be configured (if I remember correctly) on the RP itself as the address that the other devices are using for the RP. So, if your VLAN's SVI is 192.168.16.1, then your RP will be configured as:

ip pim rp 192.168.16.1 (not the loopback of 127.0.0.1)

Then all of the other devices will also point to 192.168.16.1.

You can have multiple rp's also, so you *might* (although I've never configured this) look into creating an RP for each of the vlans that you have so you won't have so much multicasting traffic crossing your vlan......

HTH,

John

iancarder Thu, 03/18/2010 - 10:54

John,

Thanks for the response.  If I understand correctly, I can make the RP a gateway address for any vlan?  Or in other words, I have vlan 12 which is our server vlan.  That vlan has an ip-address of 192.168.12.1(the gateway).  I make the rp-address 192.168.12.1 assuming that's the vlan I want it in?

John Blakley Thu, 03/18/2010 - 11:18

Ian,

You should configure you rp address on whatever interface your traffic will be coming in on....

HTH,

John

iancarder Thu, 03/18/2010 - 11:24

And by traffic, you mean the traffic from the source, correct?

Giuseppe Larosa Thu, 03/18/2010 - 11:30

Hello Ian,

best practice is to use a loopback address as RP address.

This address has to be advertised in unicast routing protocol.

Multiple RPs can exist at a given time but only one can act as RP for a given group (with only execption of anycast RP)

To be noted that an RP can act as RP for a subset of multicast address ranges with another device that acts as RP for a different multicast address group.

For redundancy the so called anycast RP can be implemented using MSDP and one between autoRP and bootstrap protocol.

In your case if the network is small you can use static RP address configured on all devices.

So you choice one device as primary RP and you can configure all devices with that IP address

see

http://www.cisco.com/en/US/docs/ios/ipmulti/configuration/guide/imc_basic_cfg_ps6441_TSD_Products_Configuration_Guide_Chapter.html#wp1054581

Hope to help

Giuseppe

iancarder Mon, 03/22/2010 - 07:19

I'm really struggling to get a basic config going.  I feel like I'm probabloy missing a really simple but major concept.  Here's the pertinent  multicast pieces from my config(4507):

<br/>ip multicast-routing<br/><br/>....<br/><br/>interface Vlan10<br/> description Legecy_Network<br/> ip address 10.0.0.1 255.0.0.0<br/> ip pim sparse-dense-mode<br/>!<br/>interface Vlan11<br/> description Admin_Data<br/> ip address 192.168.2.1 255.255.255.0<br/> ip helper-address 10.1.1.36<br/> ip pim sparse-dense-mode<br/>!<br/>interface Vlan12<br/> description Admin_Servers<br/> ip address 192.168.12.1 255.255.255.0<br/> ip pim sparse-dense-mode<br/><br/>....<br/><br/>ip pim rp-address 192.168.2.1<br/>ip pim send-rp-discovery scope 16<br/>

It's pretty vanilla.  I tried to do a multicast using  quicktime's broadcast server on OSX server and it didn't seem to work.   Unicast worked fine enough.  I also tried testing using tools from this  site.  I'm at a loss because I don't  know if I've got the initial config screwed up so I can't test anything.   Thoughts?

iancarder Thu, 03/25/2010 - 11:49

I've redone my config a bit:

Core/RP multicast relevent snippets:


ip multicast-routing

interface Loopback100

description multicast rp address

ip address 192.168.199.1 255.255.255.255

ip pim sparse-mode

interface Vlan11
description Admin_Data
ip address 192.168.2.1 255.255.255.0
ip helper-address 10.1.1.36
ip pim sparse-mode
ip mrm test-sender

ip pim rp-address 192.168.199.1

ip mrm manager imc1
manager Vlan11 group 239.255.255.250
senders 1
receivers 2 sender-list 1

access-list 1 permit 192.168.2.1

access-list 2 permit 192.168.96.1

Remote L3 Switch multicast relevent snippets:

ip multicast-routing

interface Vlan96
description MDF_Data_Vlan
ip address 192.168.96.1 255.255.255.0
ip helper-address 10.1.1.36
ip pim sparse-mode
ip mrm test-receiver

ip pim rp-address 192.168.199.1


I used the following doc for the mrm test.  http://www.cisco.com/en/US/docs/ios/12_2/ip/configuration/guide/1cftools.html

Running "ip mrm status-report" from the rp shows what I'm guessing is 100% percent packet loss although the column is not clear and the documentation doesn't even bother explaining how to interpret the test results.  I have no idea if the Group Address(239.255.255.250) I used is correct.  I pulled it from the list generated from the "sh ip igmp groups" command.

I'm extremely frustrated by this.  There seem to be tons of multicast documentation from Cisco, but nothing I have read seems to put the whole structure together.

John Blakley Thu, 03/25/2010 - 11:54

Make sure that you can see the loopback from the other switch. You need to be able to route to it (you probably already know this though).

John

iancarder Thu, 03/25/2010 - 12:16

John,

Thanks.  I was able to ping 192.168.199.1 from the remote L3 switch.  I did a traceroute and it used the default route to find it rather than using EIGRP, but as long as I can ping the RP from it, I guess it doesn't really matter how the traffic gets there for my simple setup.

As an aside, running the "sh ip igmp groups" command shows 224.0.1.111 reported by 192.168.2.1(the test-sender from the mrm test) and I can even ping that group address from the RP.  I changed the "ip mrm manager imc1" group address from 239.255.255.250 to 224.0.1.111 with no change in the mrm status report.  I'm just shooting blind here now.<br/>

Actions

This Discussion