What is a Service Instance?

Unanswered Question
Mar 18th, 2010
User Badges:
  • Blue, 1500 points or more

Hi:


What is a service instance? Can someone give me a good description of when you would configure one, what it does, etc.


What does this configuration do?


!
service instance 1110 ethernet
  encapsulation dot1q 421
  rewrite ingress tag pop 1 symmetric
  service-policy output samsung-downlink-10M        <---obviously, a locally-configured sp is refercned on this line...
  bridge-domain 421


This configuration was taken off a 7600 router that is playing the role of backhaul aggregator in a mobile broadband environment.


I tried searching for an explanation of service instances, but it seems that the only thing I can find is how to configure one - not what it is or when you would deploy one.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4.5 (9 ratings)
Loading.
Laurent Aubert Fri, 03/19/2010 - 18:06
User Badges:
  • Cisco Employee,

Hi,


service-instance is the way to configure the IOS Carrier Ethernet infrastructure which has been developed to address the Carrier Ethernet services requirement. The framework is called EVC (Ethernet Virtual Connection). The idea behind is able to bind some traffic based to their tag(s) or VLAN(s) to a service (L2 or L3).


Each service will be instanciated with a different service-instance. The VLAN becomes locally significant so you can better scale.


Finally, this implemantation is only supported on EVC LC for the 7600 and any Ethernet LC for the ASR9k.


HTH


Laurent.

lamav Fri, 03/19/2010 - 20:42
User Badges:
  • Blue, 1500 points or more

Thanks for that information. I have found some documents that discuss service instances in an indirect manner. I guess I understand that the service instance will match traffic based on its VLAN tag and it will either pop it, push it or swap it....but then I lose it....


What I need is a practical example of when a service instance would be used...an exmple of a type of traffic that would be mapped to a specific L2 or L3 service...


Just a simple practical example that I could relate to...


Thanks

Laurent Aubert Mon, 03/22/2010 - 20:26
User Badges:
  • Cisco Employee,

Here is an example:



interface GigabitEthernet1/1/1

service instance 100 ethernet

  encapsulation dot1q 10

  rewrite ingress tag pop 1 symmetric

  bridge-domain 100

service instance 200 ethernet

  encapsulation dot1q 20 second-dot1q 10-100

  rewrite ingress tag pop 1 symmetric

  bridge-domain 200

!

interface Vlan100

ip address 1.1.1.1 255.255.255.0

!

interface VLAN200

xconnect vfi VPLS

!


HTH


Laurent.

miqbal Mon, 07/18/2016 - 13:38
User Badges:
  • Cisco Employee,

Hi Laurent,

Are ASR903/901 service compatible with ASR9k sub-interfaces. I am in a situation, where I have ASR903 Port Channel connected over MC-LAG to Bundle-Ether involving two ASR9k. The port-channel Bundle-Ether as well as underlying ICCP seem to work. I need to carry a VLAN over the Port Channel to the other side and am not able make it work.


Ruchir Jain Wed, 03/09/2011 - 11:29
User Badges:
  • Cisco Employee,

Hi Lamav,


Service instance could be considered as a way through which you can use a single port as a combination of layer 2 and layer 3 ports. To give you a similarit: Just like we create sub interfaces to separate data into different logical interfaces using dot1q tag simillarly we can use service instances to separate data into different logical interfaces but we have much more options availaable to us like now with in a single interface we can create 3 service instances:


one matching a single dot1q tag (let us 10)

second matching two tags (QinQ config) (let us say top tag 20 and inner tag 30)

third matching untagged packets (packets in the native vlan)


This is just an idea but you can do much more.


Also, few other advantages:


- With subinterfaces each dot1q tag would go to a separte logical sub interface and you cannot bridge traffic between two subinterfaces but with service instance you can. You can also put data from two different service intances into a single vlan as well. Please refer attached image for a sample config.


- The major adantage is that when you use subinterfaces with 7600 and you specify a vlan in the encapsulation, that vlan is assigned as the internal vlan for that subinterface. So you have actually used 1 vlan out of 4094 availble vlans when you create a sub-interface. Thus you cannot use this vlan anywhere else on that 7600 switch. You cannot create SVI for that vlan. Thus the vlans used for subinterfaces are globally significant wrt that 7600 however when you match a vlan in a service instance that vlan is not assigned as an internal vlan for that service instance thus you save upon internal vlans and vlans for service instances are thus locally significant.


I hope this helps you.


Cheers,

Ruchir

Attachment: 
sudjacob Fri, 03/11/2011 - 00:55
User Badges:

An Ethernet Virtual connection is defined as an instance of an asscociation of two or more UNI where the UNI is the standard ethernet interrface that is the point of demarcation between customer equipment and service provider MEN.Basically this technology was grown in the past decade as the customer wants to extend there LAN from one geographical localtion to another. Customer will be having there own VLAN the want it to route through the service provider network for that an outer VLAN is required otherwise the customer VLAN will clash with others more over one benifit for the service provider the service provider they act like a transparent medium for transporting data from one side to other. For customer it is like one fat pipe going from geographical location to other. This is the logic behind EVC, comming to the point EVC as Ruchir pointed a lot advantages over conventional sub interfaces  the main benfit is cost factor port density is high over here it saves cost to the service provider and reduce the cumbersome  configuration of push and pop tags.

The main benefit is that bridging facility. It can  have a lot of flexiblity.


bridge domain

A set of logical ports that share the same flooding or broadcast

characteristics. As in a virtual LAN, a bridge domain spans one or more ports of

multiple devices. By default, each bridge domain maintains its own forwarding

database of MAC .

HUBERT RESCH Tue, 04/26/2011 - 23:21
User Badges:

Hi Ruchir, the attached jpg seems to be part of a good explanation for EVC, do

you have the preso available ?


thx in Advance

Hubert

Flanger23 Sun, 06/02/2013 - 05:19
User Badges:

Thank you Ruchir for the detailed explanation and an informative config example!


One quick question: So for L3 termination when QinQ is used, under service instance you would need to use "rewrite ingress tag pop 2 symmetric" poppoing 2 tags right?

Vivek Ruhil Mon, 06/03/2013 - 03:49
User Badges:
  • Cisco Employee,
  • Events Top Contributors,

    Cisco, 2014

Hi


you are right. For L3 termination there are two options,


1. Using Service Instance and VLAN Interface


conf t

!

interface Gi0/0

service instance 10 ethernet

encapsulation dot1q 10 second-dot1q 20

rewrite ingress tag pop 2 symmetric

bridge-domain 10

!

int vlan 10

ip add x.x.x.x y.y.y.y


2. Using Sub-interface


conf t

!

int gi0/0.10

encapsulation dot1q 10 second-dot1q 20

ip address x.x.x.x y.y.y.y

!


I would prefer the second option as that option is more logical and requires less configuration.

Petar Bajovic Wed, 04/30/2014 - 02:11
User Badges:

I see that you are familiar with service instances, so I hope that I will get straight answer from you :) . I would like to know is there a "show" command (or any other command) that I can use to see traffic throughput over service instance. 

Thank you in advance.

Greeting,

Petar

spoofneted Fri, 10/11/2013 - 04:06
User Badges:

On the ASR903 platform, is it still true that Service Instances are locally significant to the Ethernet interface?


That is, for the sample configuration below - on an ASR903 running IOS-XE - is each Service Instance 1 unique (i.e. creating two seperate pseudowire xconnects, using two seperate VC IDs to two seperate destinations) or do both Service Instance 1's "bridge together"?


In other words, is this like a "switchport access vlan " tag - so because both Gig 0/4/0 and Gig 0/4/1 below are both a member of Service Instance 1, does this effectively "bridge" Gig 0/4/0 ServInstance 1 to Gig0/4/1 ServInstance 1 - or are these just two seperate ServInstance 1's?


interface GigabitEthernet0/4/0

service instance 1 ethernet

desc * PIPE 1 *

encapsulation default

l2protocol tunnel

xconnect 1.2.3.4 10 encapsulation mpls

interface GigabitEthernet0/4/1


service instance 1 ethernet

desc * PIPE 2 *

encapsulation default

l2protocol tunnel

xconnect 5.6.7.8 20 encapsulation mpls

end

Eduard Gheorghiu Fri, 01/29/2016 - 05:12
User Badges:

It may be too late, but the answer is YES - the EFP (service instance) are independent per interface. 

Actions

This Discussion