MSCB still in init state

Unanswered Question
Mar 19th, 2010

I have 2 WLAN SSID, one's working the other isn't! Recently one of our Controllers rebooted, and then one of of WLAN's stopped working. I've checked the configs and code and they are the same on both controllers. The WLAN that is not working I see the following log message:

Mar 19 09:40:31.464 apf_foreignap.c:1281 APF-4-REGISTER_IPADD_ON_MSCB_FAILED: Could not Register IP Add on MSCB. MSCB still in init state. Address:00:40:96:a7:50:c6

My laptop is connected and has authenticated to the WLAN but gets a default windows IP 169.254.36.162 same result with my IPhone. I know its not my laptops driver as the other WLAN on the same controller works fine. For some reason the client ARP cannot be added to the controller for this WLAN SSID. I found the following from Cisco, but just wondering if anyone has any other suggestions (fyi - controller software 4.2.207.0)

A. This is the error message:
APF−1−REGISTER_IPADD_ON_MSCB_FAILED: Could not RegisterIP Add on MSCB. MSCB still in init state.


The Mobile Station Control Block (MSCB) represents the clients. This error message means that a client tries to pass traffic, but the controller is not yet ready to accept the client traffic. These messages are generated when the controller gets an ARP request from a client but it has not added the IP address of the client to its client list. Once the controller adds the client IPaddress to its client list, everything should be fine. As a workaround, try to reboot the controller to see if it helps. Also, make sure you run the latest drivers for the wireless cards of the client because there have been several connectivity issues with older card drivers specifically with some third party wireless cards.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
Bel Marsad Mon, 08/22/2011 - 02:07

Hello,

Have you had a solution for this issue, I have exactly the same issue with the same error messages, could you please let me know if you resolved this issue.

Thanks for your help

Belmar

darin.marais Tue, 04/17/2012 - 22:31

I have also seen this error when implementing a guest WLC and the anchor controller does not have a mobility anchor on the SSID pointing local

darin.marais Mon, 04/08/2013 - 18:10

Hello Teliskyj

thats good that it has resolved your problem - thank you for the vote

best regards

Darin

timoruohomaki Wed, 09/12/2012 - 04:35

I noticed such errors after getting reports from the users that certain SSIDs wouldn't work while others do work. I'm not sure if there has been any major changes that would affect on this one, but we did upgrade our WLC's to version 7.0.230.0. Could that be a version-specific issue since rebooting WLC didn't help?

Actions

This Discussion