Fax fails when transfer starts on 2921 FXS

Unanswered Question
Mar 20th, 2010

Hi,

I'm having a weird problem with faxing using the 2921 series router with a 4 port FXS card. This is a new site install in South Africa .You can succesfully make the outbound call from the FXS port and the other end will answer and the intial conenction works, as soon as the transfer starts the call drops:

Here is the config from the router:

interface Serial0/0/0:15
no ip address
encapsulation hdlc
isdn switch-type primary-net5
isdn incoming-voice voice
isdn send-alerting
isdn sending-complete
no cdp enable

voice-port 0/0/0:15
no comfort-noise
cptone ZA
!
voice-port 0/1/0
cptone ZA
!
dial-peer voice 210 pots
service default
destination-pattern 674699
port 0/1/0
!
dial-peer voice 201 pots
destination-pattern 9T
direct-inward-dial
port 0/0/0:15
!

Any suggestions as to why it is dropping?

Thanks in advance

David

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (1 ratings)
Loading.
Aaron Harrison Sat, 03/20/2010 - 02:42

Hi

First, do a show controller e1

If there are any slips or errors on the line, these are usually unnoticed until you start faxing.. faxes are very sensitive to any errors.

Since you are running across a router to an E1 directly there's ony a couple of places where problems can originate.

If there are slips etc; check/post back your clocking setup.

Aside from that, it's usually a good idea to disable ECM on your fax, and if possible switch back the speed to 33600 Max (higher rates = more errors, and ECM causes retransmissions, which if retransmitted cause it to drop). These settings are done via the fax front panel, but can't always be changed on all machines..

Regards

Aaron

Please rate helpful posts...

chalmersdc Sat, 03/20/2010 - 02:50

Hi Aaron

You are right there are slips on the controller:

E1 0/0/0 is up.
  Applique type is Channelized E1 - balanced
  Description: UPLINK to Local ISDN30
  No alarms detected.
  alarm-trigger is not set
  Version info Firmware: 20090408, FPGA: 13, spm_count = 0
  Framing is CRC4, Line Code is HDB3, Clock Source is Line.
  Data in current interval (261 seconds elapsed):
     0 Line Code Violations, 0 Path Code Violations
     6 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins
     6 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs
  Total Data (last 24 hours)
     2 Line Code Violations, 227 Path Code Violations,
     1893 Slip Secs, 0 Fr Loss Secs, 1 Line Err Secs, 0 Degraded Mins,
     1894 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs

clock timezone GMT 0
clock summer-time BST recurring 2 Sun Mar 2:00 1 Sun Nov 1:00
network-clock-participate wic 0

I have a habit of setting all the timezones to the UK as that's where I run everything from. If you need anymore info just let me kow.

Thanks

David

Aaron Harrison Sat, 03/20/2010 - 03:08

Ah - I meant E1 clocking, not time clock

You need some commands like so (never done a 2900 yet, but presume not much has changed):

network-clock-participate wic 0

network-clock-select 1 E1 0/0/0

Then do a:

Clear controller e1 0/0/0

Then wait 10 minutes and see if the errors are still accumulating..

Regards

Aaron

Please rate helpful posts...

chalmersdc Sat, 03/20/2010 - 03:39

Hi Aaron

Ok that has stopped the slips:

E1 0/0/0 is up.
  Applique type is Channelized E1 - balanced
  Description: UPLINK to Local ISDN30
  No alarms detected.
  alarm-trigger is not set
  Version info Firmware: 20090408, FPGA: 13, spm_count = 0
  Framing is CRC4, Line Code is HDB3, Clock Source is Line.
  Data in current interval (645 seconds elapsed):
     0 Line Code Violations, 0 Path Code Violations
     0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins
     0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs

Unfortunately still no further with the fax, here is a debug from the call:

EU-SA-JHB-BRY-MPLS#
003890: Mar 20 12:34:32.805 gmt: htsp_process_event: [0/1/1, FXSLS_ONHOOK, E_DSP
_SIG_1100]fxsls_onhook_offhook htsp_setup_ind
003891: Mar 20 12:34:32.805 gmt: [0/1/1] get_local_station_id calling num= calli
ng name= calling time=03/20 12:34  orig called=
003892: Mar 20 12:34:32.809 gmt: htsp_process_event: [0/1/1, FXSLS_WAIT_SETUP_AC
K, E_HTSP_SETUP_ACK]fxsls_check_auto_call
EU-SA-JHB-BRY-MPLS#
003893: Mar 20 12:34:36.949 gmt: htsp_digit_ready(0/1/1): digit = 9
003894: Mar 20 12:34:37.121 gmt: htsp_digit_ready(0/1/1): digit = 0
003895: Mar 20 12:34:37.289 gmt: htsp_digit_ready(0/1/1): digit = 0
003896: Mar 20 12:34:37.469 gmt: htsp_digit_ready(0/1/1): digit = 4
003897: Mar 20 12:34:37.641 gmt: htsp_digit_ready(0/1/1): digit = 4
003898: Mar 20 12:34:37.809 gmt: htsp_digit_ready(0/1/1): digit = 1
EU-SA-JHB-BRY-MPLS#
003899: Mar 20 12:34:37.981 gmt: htsp_digit_ready(0/1/1): digit = 2
003900: Mar 20 12:34:38.157 gmt: htsp_digit_ready(0/1/1): digit = 2
003901: Mar 20 12:34:38.329 gmt: htsp_digit_ready(0/1/1): digit = 4
003902: Mar 20 12:34:38.497 gmt: htsp_digit_ready(0/1/1): digit = 3
003903: Mar 20 12:34:38.681 gmt: htsp_digit_ready(0/1/1): digit = 8
003904: Mar 20 12:34:38.849 gmt: htsp_digit_ready(0/1/1): digit = 0
EU-SA-JHB-BRY-MPLS#
003905: Mar 20 12:34:39.021 gmt: htsp_digit_ready(0/1/1): digit = 3
003906: Mar 20 12:34:39.189 gmt: htsp_digit_ready(0/1/1): digit = 3
003907: Mar 20 12:34:39.373 gmt: htsp_digit_ready(0/1/1): digit = 9
EU-SA-JHB-BRY-MPLS#
003908: Mar 20 12:34:49.373 gmt: htsp_process_event: [0/1/1, FXSLS_OFFHOOK, E_HT
SP_PROCEEDING]
003909: Mar 20 12:34:49.373 gmt: ISDN Se0/0/0:15 Q931: Applying typeplan for sw-
type 0x12 is 0x0 0x1, Calling num 674698
003910: Mar 20 12:34:49.373 gmt: ISDN Se0/0/0:15 Q931: Sending SETUP  callref =
0x0130 callID = 0x80B3 switch = primary-net5 interface = User
EU-SA-JHB-BRY-MPLS#
003911: Mar 20 12:34:49.373 gmt: ISDN Se0/0/0:15 Q931: TX -> SETUP pd = 8  callr
ef = 0x0130
        Sending Complete
        Bearer Capability i = 0x9090A3
                Standard = CCITT
                Transfer Capability = 3.1kHz Audio
                Transfer Mode = Circuit
                Transfer Rate = 64 kbit/s
        Channel ID i = 0xA9839F
                Exclusive, Channel 31
        Progress Ind i = 0x8183 - Origination address is non-ISDN
        Calling Party Number i = 0x0180, '674698'
                Plan:ISDN, Type:Unknown
        Called Party Number i = 0x81, '00441224380339'
                Plan:ISDN, Type:Unknown
003912: Mar 20 12:34:49.417 gmt: ISDN Se0/0/0:15 Q931: RX <- CALL_PROC pd = 8  c
allref = 0x8130
        Channel ID i = 0xA9839F
                Exclusive, Channel 31
EU-SA-JHB-BRY-MPLS#
003913: Mar 20 12:34:51.813 gmt: ISDN Se0/0/0:15 Q931: RX <- ALERTING pd = 8  ca
llref = 0x8130
        Progress Ind i = 0x8A81 - Call not end-to-end ISDN, may have in-band inf
o
003914: Mar 20 12:34:51.813 gmt: htsp_call_bridged invokedhtsp_alert_notify
003915: Mar 20 12:34:51.817 gmt: htsp_process_event: [0/1/1, FXSLS_OFFHOOK, E_HT
SP_VOICE_CUT_THROUGH]fxsls_voice_cut_thru
EU-SA-JHB-BRY-MPLS#
003916: Mar 20 12:34:57.077 gmt: ISDN Se0/0/0:15 Q931: RX <- CONNECT pd = 8  cal
lref = 0x8130
        Date/Time i = 0x0A03140C22
                Date (dd-mm-yr)   = 10-03-20
                Time (hr:mnt:sec) = 12:34:10
003917: Mar 20 12:34:57.081 gmt: %ISDN-6-CONNECT: Interface Serial0/0/0:30 is no
w connected to 00441224380339 N/A
EU-SA-JHB-BRY-MPLS#
003918: Mar 20 12:34:57.081 gmt: ISDN Se0/0/0:15 Q931: TX -> CONNECT_ACK pd = 8
callref = 0x0130
003919: Mar 20 12:34:57.081 gmt: htsp_process_event: [0/1/1, FXSLS_OFFHOOK, E_HT
SP_CONNECT]fxsls_offhook_connect
003920: Mar 20 12:34:57.081 gmt: [0/1/1] set signal state = 0x6 timestamp = 0
EU-SA-JHB-BRY-MPLS#htsp_call_feature:feature 2

EU-SA-JHB-BRY-MPLS#
003921: Mar 20 12:35:03.517 gmt: %FLEXDSPRM-5-OUT_OF_RESOURCES: No dsps found ei
ther locally or globally.htsp_call_feature:feature 1

003922: Mar 20 12:35:03.521 gmt: htsp_process_event: [0/1/1, FXSLS_CONNECT, E_HT
SP_RELEASE_REQ]fxsls_connect_disc
003923: Mar 20 12:35:03.521 gmt: htsp_timer_stop
003924: Mar 20 12:35:03.521 gmt: [0/1/1] set signal state = 0xC timestamp = 0
003925: Mar 20 12:35:03.521 gmt: [0/1/1] set signal state = 0x4 timestamp = 750
003926: Mar 20 12:35:03.521 gmt: htsp_timer - 950 msec
003927: Mar 20 12:35:03.521 gmt: %ISDN-6-DISCONNECT: Interface Serial0/0/0:30  d
isconnected from 00441224380339 , call lasted 6 seconds
EU-SA-JHB-BRY-MPLS#
003928: Mar 20 12:35:03.521 gmt: ISDN Se0/0/0:15 Q931: TX -> DISCONNECT pd = 8
callref = 0x0130
        Cause i = 0x80AC - Requested circuit/channel not available
003929: Mar 20 12:35:03.573 gmt: ISDN Se0/0/0:15 Q931: RX <- RELEASE pd = 8  cal
lref = 0x8130
003930: Mar 20 12:35:03.573 gmt: ISDN Se0/0/0:15 Q931: TX -> RELEASE_COMP pd = 8
  callref = 0x0130
003931: Mar 20 12:35:04.473 gmt: htsp_process_event: [0/1/1, FXSLS_CPC, E_HTSP_E
VENT_TIMER]fxsls_cpc_timer
003932: Mar 20 12:35:04.473 gmt: htsp_timer - 60000 msec
003933: Mar 20 12:35:04.473 gmt: htsp_process_event: [0/1/1, FXSLS_WAIT_ONHOOK,
E_DSP_SIG_1100]fxsls_waitonhook_offhook
EU-SA-JHB-BRY-MPLS#

As you can see the call connects then dies. We can make normal voice calls through the line without any problems.

chalmersdc Sat, 03/20/2010 - 03:41

Sorry forgot to add ECM has been switched off on the fax but i can't configure the speed on this model.

Aaron Harrison Sat, 03/20/2010 - 03:46

Hi

Also maybe post back your config - are you using any other DSP features, e.g. transcoding etc?

How many channels on your E1/T1?

Aaron

Aaron Harrison Sat, 03/20/2010 - 03:44

Hi

Can you confirm your hardware spec?

Show diag

It looks like you have a DSP resource allocation problem:

003921: Mar 20 12:35:03.517 gmt: %FLEXDSPRM-5-OUT_OF_RESOURCES: No dsps found ei

ther locally or globally.htsp_call_feature:feature 1

Regards

Aaron

chalmersdc Sat, 03/20/2010 - 03:51

Hi Aaron

Here you go:

Slot 0:
        C2921 Mother board 3GE, integrated VPN and 4W Port adapter, 14 ports
        Port adapter is analyzed
        Port adapter insertion time 1d17h ago
        EEPROM contents at hardware discovery:
        PCB Serial Number        : FOC14073J9U
        Hardware Revision        : 1.0
        Part Number              : 73-11835-03
        Top Assy. Part Number    : 800-30794-01
        Board Revision           : A0
        Deviation Number         : 0
        Fab Version              : 03
        Product (FRU) Number     : CISCO2921/K9
        Version Identifier       : V01
        CLEI Code                : COMGL00ARA
        Processor type           : C2
        Chassis Serial Number    : FHK1409F2P3
        Chassis MAC Address      : 68ef.bd6c.28e0
        MAC Address block size   : 80
        Manufacturing Test Data  : 00 00 00 00 00 00 00 00
        EEPROM format version 4
        EEPROM contents (hex):
          0x00: 04 FF C1 8B 46 4F 43 31 34 30 37 33 4A 39 55 40
          0x10: 06 16 41 01 00 82 49 2E 3B 03 C0 46 03 20 00 78
          0x20: 4A 01 42 41 30 88 00 00 00 00 02 03 CB 8C 43 49
          0x30: 53 43 4F 32 39 32 31 2F 4B 39 89 56 30 31 20 D9
          0x40: 04 40 C1 CB C2 C6 8A 43 4F 4D 47 4C 30 30 41 52
          0x50: 41 09 C2 C2 8B 46 48 4B 31 34 30 39 46 32 50 33
          0x60: C3 06 68 EF BD 6C 28 E0 43 00 50 C4 08 00 00 00
          0x70: 00 00 00 00 00 F3 00 03 40 01 63 FF FF FF FF FF
          0x80: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
          0x90: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
          0xA0: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
          0xB0: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
          0xC0: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
          0xD0: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
          0xE0: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
          0xF0: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
        Internal power Supply information
        Top Assy. Part Number    : 341-0226-01
        Deviation Number         : 0
        PCB Serial Number        : DCA1347K1PU
        RMA Test History         : 00
        RMA Number               : 0-0-0-0
        RMA History              : 00
        Version Identifier       : V01
        Product (FRU) Number     : PWR-2921-51-AC
        CLEI Code                : 0000000000
        Board Revision           : B0
        EEPROM format version 4
        EEPROM contents (hex):
          0x00: 04 FF 40 05 E2 DF 45 01 55 00 E2 01 88 00 00 00
          0x10: 00 C1 8B 44 43 41 31 33 34 37 4B 31 50 55 03 00
          0x20: 81 00 00 00 00 04 00 89 56 30 31 20 CB 8E 50 57
          0x30: 52 2D 32 39 32 31 2D 35 31 2D 41 43 C6 8A 30 30
          0x40: 30 30 30 30 30 30 30 30 F3 00 59 41 01 22 42 00
          0x50: 05 F8 00 50 01 F3 18 3B 02 F0 19 D9 03 E8 1B 76
          0x60: 04 E2 1C 49 05 D9 1D 1B 06 D8 1D ED 07 CF 1E BF
          0x70: 08 CE 1F 40 09 C2 1F B8 0A B8 20 34 0B B7 20 B0
          0x80: 0D AF 21 0C 0F 9F 21 67 11 91 21 94 13 87 21 C0
          0x90: 17 6E 21 DB 1B 57 21 EA 1F 3F 21 E2 23 28 21 D4
          0xA0: 27 0A 21 CD 42 42 30 FF FF FF FF FF FF FF FF FF
          0xB0: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
          0xC0: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
          0xD0: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
          0xE0: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
          0xF0: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF

        PVDM Slot 0:
        32-channel (G.711) Voice/Fax PVDM3 DSP DIMM PVDM daughter card
        Hardware Revision        : 1.0
        Part Number              : 73-11577-03
        Board Revision           : B0
        Deviation Number         : 0
        Fab Version              : 03
        PCB Serial Number        : FOC14070Z1C
        RMA Test History         : 00
        RMA Number               : 0-0-0-0
        RMA History              : 00
        Processor type           : 00
        Product (FRU) Number     : PVDM3-32
        Version Identifier       : V01
        EEPROM format version 4
        EEPROM contents (hex):
          0x00: 04 FF 40 05 D9 41 01 00 82 49 2D 39 03 42 42 30
          0x10: 88 00 00 00 00 02 03 C1 8B 46 4F 43 31 34 30 37
          0x20: 30 5A 31 43 03 00 81 00 00 00 00 04 00 09 00 CB
          0x30: 8F 50 56 44 4D 33 2D 33 32 20 20 20 20 20 20 20
          0x40: 89 56 30 31 20 D9 02 40 C1 FF FF FF FF FF FF FF
          0x50: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
          0x60: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
          0x70: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF

        PVDM Slot 1:
        32-channel (G.711) Voice/Fax PVDM3 DSP DIMM PVDM daughter card
        Hardware Revision        : 1.0
        Part Number              : 73-11577-03
        Board Revision           : B0
        Deviation Number         : 0
        Fab Version              : 03
        PCB Serial Number        : FOC14070Z9Z
        RMA Test History         : 00
        RMA Number               : 0-0-0-0
        RMA History              : 00
        Processor type           : 00
        Product (FRU) Number     : PVDM3-32
        Version Identifier       : V01
        EEPROM format version 4
        EEPROM contents (hex):
          0x00: 04 FF 40 05 D9 41 01 00 82 49 2D 39 03 42 42 30
          0x10: 88 00 00 00 00 02 03 C1 8B 46 4F 43 31 34 30 37
          0x20: 30 5A 39 5A 03 00 81 00 00 00 00 04 00 09 00 CB
          0x30: 8F 50 56 44 4D 33 2D 33 32 20 20 20 20 20 20 20
          0x40: 89 56 30 31 20 D9 02 40 C1 FF FF FF FF FF FF FF
          0x50: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
          0x60: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
          0x70: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF

        WIC Slot 0:
        VWIC2-1MFT-T1/E1 - 1-Port RJ-48 Multiflex Trunk - T1/E1
        Hardware Revision        : 0.0
        Top Assy. Part Number    : 800-22628-05
        Board Revision           : C0
        Deviation Number         : 0
        Fab Version              : 04
        PCB Serial Number        : FOC140603LN
        RMA Test History         : 00
        RMA Number               : 0-0-0-0
        RMA History              : 00
        Product (FRU) Number     : VWIC2-1MFT-T1/E1
        Version Identifier       : V01
        EEPROM format version 4
        EEPROM contents (hex):
          0x00: 04 FF 40 03 FD 41 00 00 C0 46 03 20 00 58 64 05
          0x10: 42 43 30 88 00 00 00 00 02 04 C1 8B 46 4F 43 31
          0x20: 34 30 36 30 33 4C 4E 03 00 81 00 00 00 00 04 00
          0x30: CB 90 56 57 49 43 32 2D 31 4D 46 54 2D 54 31 2F
          0x40: 45 31 89 56 30 31 20 D9 02 40 C1 FF FF FF FF FF
          0x50: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
          0x60: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
          0x70: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF

        WIC Slot 1:
        3rd generation - FXS DID Voice daughter card (4 port)
        Hardware Revision        : 1.0
        Top Assy. Part Number    : 800-27473-03
        Board Revision           : A0
        Deviation Number         : 0
        Fab Version              : 07
        PCB Serial Number        : FOC14063QPN
        RMA Test History         : 00
        RMA Number               : 0-0-0-0
        RMA History              : 00
        Product (FRU) Number     : VIC3-4FXS/DID
        Version Identifier       : V02
        CLEI Code                : IPUIA6JRAB
        Longitudinal Calibration : 01 10 10 97 8F 10 10 6E
                                   7A 10 10 79 C3 10 10 72
                                   91
        EEPROM format version 4
        EEPROM contents (hex):
          0x00: 04 FF 40 05 1B 41 01 00 C0 46 03 20 00 6B 51 03
          0x10: 42 41 30 88 00 00 00 00 02 07 C1 8B 46 4F 43 31
          0x20: 34 30 36 33 51 50 4E 03 00 81 00 00 00 00 04 00
          0x30: CB 8D 56 49 43 33 2D 34 46 58 53 2F 44 49 44 89
          0x40: 56 30 32 20 D9 02 40 C1 C6 8A 49 50 55 49 41 36
          0x50: 4A 52 41 42 D3 11 01 10 10 97 8F 10 10 6E 7A 10
          0x60: 10 79 C3 10 10 72 91 FF FF FF FF FF FF FF FF FF
          0x70: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF

        WIC Slot 2:
        3rd generation - FXS DID Voice daughter card (4 port)
        Hardware Revision        : 1.0
        Top Assy. Part Number    : 800-27473-03
        Board Revision           : A0
        Deviation Number         : 0
        Fab Version              : 07
        PCB Serial Number        : FOC14063QTM
        RMA Test History         : 00
        RMA Number               : 0-0-0-0
        RMA History              : 00
        Product (FRU) Number     : VIC3-4FXS/DID
        Version Identifier       : V02
        CLEI Code                : IPUIA6JRAB
        Longitudinal Calibration : 01 10 10 86 A3 10 10 BC
                                   7C 10 10 76 87 10 10 98
                                   6C
        EEPROM format version 4
        EEPROM contents (hex):
          0x00: 04 FF 40 05 1B 41 01 00 C0 46 03 20 00 6B 51 03
          0x10: 42 41 30 88 00 00 00 00 02 07 C1 8B 46 4F 43 31
          0x20: 34 30 36 33 51 54 4D 03 00 81 00 00 00 00 04 00
          0x30: CB 8D 56 49 43 33 2D 34 46 58 53 2F 44 49 44 89
          0x40: 56 30 32 20 D9 02 40 C1 C6 8A 49 50 55 49 41 36
          0x50: 4A 52 41 42 D3 11 01 10 10 86 A3 10 10 BC 7C 10
          0x60: 10 76 87 10 10 98 6C FF FF FF FF FF FF FF FF FF
          0x70: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF

        WIC Slot 3:
        HWIC Serial 2T WAN daughter card
        Hardware Revision        : 1.0
        Top Assy. Part Number    : 800-28803-02
        Board Revision           : A0
        Deviation Number         : 0
        Fab Version              : 01
        PCB Serial Number        : FOC14081FBF
        RMA Test History         : 00
        RMA Number               : 0-0-0-0
        RMA History              : 00
        Fab Part Number          : 28-8141-01
        Product (FRU) Number     : HWIC-2T
        Version Identifier       : V02
        CLEI Code                : COUIA1RCAA
        EEPROM format version 4
        EEPROM contents (hex):
          0x00: 04 FF 40 05 89 41 01 00 C0 46 03 20 00 70 83 02
          0x10: 42 41 30 88 00 00 00 00 02 01 C1 8B 46 4F 43 31
          0x20: 34 30 38 31 46 42 46 03 00 81 00 00 00 00 04 00
          0x30: 85 1C 1F CD 01 CB 87 48 57 49 43 2D 32 54 89 56
          0x40: 30 32 20 D9 02 40 C1 C6 8A 43 4F 55 49 41 31 52
          0x50: 43 41 41 FF FF FF FF FF FF FF FF FF FF FF FF FF
          0x60: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
          0x70: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF

version 15.0
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service password-encryption
service sequence-numbers
!
hostname EU-SA-JHB-BRY-MPLS
!
boot-start-marker
boot-end-marker
!
card type e1 0 0
logging buffered notifications
logging console notifications
!
aaa new-model
!
!
aaa authentication login default group tacacs+ local
aaa authorization exec default group tacacs+ local
!
!
!
!
!
aaa session-id common
clock timezone gmt 2
network-clock-participate wic 0
network-clock-select 1 E1 0/0/0
!
no ipv6 cef
no ip source-route
ip cef
!
!
!
!
multilink bundle-name authenticated
!
!
!
!
isdn switch-type primary-net5
!
!
!
voice-card 0
dsp services dspfarm
!
!
!
voice service voip
allow-connections h323 to h323
h323
!
voice class codec 1
codec preference 1 g711alaw
codec preference 2 g711ulaw
codec preference 3 g729r8
!
voice class h323 1
!
!
!
!
license udi pid CISCO2921/K9 sn FHK1409F2P3
!
!
!
redundancy
!
!
controller E1 0/0/0
pri-group timeslots 1-31
!
!
!
!
!
interface Multilink1
ip flow ingress
load-interval 30
no peer neighbor-route
ppp multilink
ppp multilink links minimum 1
ppp multilink group 1
ppp multilink fragment disable
!
interface GigabitEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface GigabitEthernet0/1
description EU-SA-JHB-MPLS
ip address X.X.X.X 255.255.255.0
ip flow ingress
load-interval 30
duplex auto
speed auto
h323-gateway voip interface
h323-gateway voip bind srcaddr X.X.X.X
!
interface GigabitEthernet0/2
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0/0:15
no ip address
encapsulation hdlc
isdn switch-type primary-net5
isdn incoming-voice voice
isdn send-alerting
isdn sending-complete
no cdp enable
!
interface Serial0/3/0
bandwidth 1952
no ip address
encapsulation ppp
load-interval 30
ppp multilink
ppp multilink group 1
no clock rate 2000000
!
interface Serial0/3/1
bandwidth 1952
no ip address
encapsulation ppp
load-interval 30
ppp multilink
ppp multilink group 1
no clock rate 2000000
!
!

!
control-plane
!
!
voice-port 0/0/0:15
no comfort-noise
cptone ZA
!
voice-port 0/1/0
cptone ZA
!
voice-port 0/1/1
cptone ZA
!
voice-port 0/1/2
cptone ZA
!
voice-port 0/1/3
cptone ZA
!
voice-port 0/2/0
cptone ZA
!
voice-port 0/2/1
cptone ZA
!
voice-port 0/2/2
cptone ZA
!
voice-port 0/2/3
cptone ZA
!
!
!
sccp local GigabitEthernet0/1
sccp ccm X.X.X.X identifier 1 version 6.0
sccp ccm X.X.X.X identifier 2 version 6.0
sccp ip precedence 3
sccp
!
sccp ccm group 1
associate ccm 1 priority 1
associate ccm 2 priority 2
associate profile 1 register CFBXXXXXXXXXXXX
!
dspfarm profile 2 transcode
codec g711ulaw
codec g711alaw
codec g729ar8
codec g729abr8
codec g722-64
codec g729r8
maximum sessions 1
associate application SCCP
!
dspfarm profile 1 conference
codec g711ulaw
codec g711alaw
codec g729ar8
codec g729abr8
codec g729r8
codec g729br8
maximum sessions 2
associate application SCCP
!
dial-peer voice 100 voip
preference 1
destination-pattern 4...
session target ipv4:X.X.X.X
voice-class codec 1
dtmf-relay h245-alphanumeric
!
dial-peer voice 200 pots
shutdown
destination-pattern .T
direct-inward-dial
port 0/0/0:15
!
dial-peer voice 101 voip
preference 2
destination-pattern 4...
session target ipv4:X.X.X.X
voice-class codec 1
dtmf-relay h245-alphanumeric
!
dial-peer voice 210 pots
service default
destination-pattern 674699
port 0/1/0
!
dial-peer voice 211 pots
service default
destination-pattern 674698
port 0/1/1
!
dial-peer voice 212 pots
service default
destination-pattern 674697
port 0/1/2
!
dial-peer voice 213 pots
service default
destination-pattern 674696
port 0/1/3
!
dial-peer voice 201 pots
destination-pattern 9T
direct-inward-dial
port 0/0/0:15
!
dial-peer voice 219 pots
!
dial-peer voice 214 pots
service default
destination-pattern 4699
port 0/1/0
!
!
!
!
gatekeeper
shutdown
!
!
call-manager-fallback
secondary-dialtone 9
max-conferences 4 gain -6
transfer-system full-consult
timeouts interdigit 5
timeouts ringing 25
ip source-address X.X.X.X port 2000
max-ephones 75
max-dn 300 dual-line
system message primary Phone system in failover mode
transfer-pattern 9T
!

Aaron Harrison Sat, 03/20/2010 - 04:18

Hi

I think the problem is with your DSP allocation...

Ok - so you have transcoding configured - do you need it? If all you have on this site is IP phones and the gateway (i.e. No CUE, no G711 only servers) then you don't need transcoders...

You also have a bunch of codecs on there that you don't need - try removing the high complexity ones, and unused ones from the config... just leave in G711u/g711a/g729ar8/g729abr8 (g729r8 is high complexity). s

If that fails try removing the conf/transcode config and see if it works.

Regards

Aaron

chalmersdc Sat, 03/20/2010 - 04:43

Hi Aaron

I've removed the transcoders and disabled the conference bridge but still seeing the same error.

sccp ccm group 1
associate ccm 1 priority 1
associate ccm 2 priority 2
!
dspfarm profile 1 conference
codec g711ulaw
codec g711alaw
codec g729ar8
codec g729abr8
codec g729br8
maximum sessions 2
associate application SCCP
shutdown
!

I can't understand why it is claiming there are no DSP's available, nothing else is using them.

The only thing i can think of is that you need to something different with PVDM3 but so far i've found no information on it.

David

filiberto.aguirre Fri, 08/06/2010 - 21:31

Hi,

I have a similar problem with with my 2921 router and  FXS card VIC3  when I try to send or receive a FAX

did you resolved this problem?

if it is so, could you tell me how

regards,

Christopher Graham Sat, 08/07/2010 - 07:17

This is likely due to CSCtc98074

You need to disable cisco fax relay:

voice service pots

fax rate disable

voice service voip

fax protocol none

modem passthrough nse codec g711u

voice-card 0

no local-bypass

give that a try

Paolo Bevilacqua Sat, 08/07/2010 - 07:58

This is likely due to CSCtc98074

You need to disable cisco fax relay:

Better would be to indicate the fixed version rather than workaround.

Christopher Graham Sat, 08/07/2010 - 08:06

It's easier to test the configuration workaround than to upgrade.  Especially since the user likely does not need Cisco Fax Relay to begin with.  But, as you wish:

fixed in:

15.0(1)M2
15.1(1)T
15.1(1)XB1

jcompiano Wed, 02/23/2011 - 12:33

I've got a 3925 with 151-2.T2 and had the same issue. Couldn;t do a bug lookup on that ID but the work around resolved my issue. I also had out of DSP resources but had plenty on the router.

thanks

etmarcof Sun, 03/13/2011 - 14:37

Hi,

I think I'm having same issue one router 2921 but with BRI's connected to PSTN instead of E1. Some of the BRI's are one the EVM module  where FXS ports are and others BRI's  are in VIC2-2BRI -NT/TE.

No local-bypass  command is realy necessary?

with  these  router commands i will have to config fax  machine speed to 14400 ?

Thanks

Best Regards

MC

Actions

This Discussion

Related Content