Problem with 7942G and ringtones

Unanswered Question
Mar 21st, 2010
User Badges:

Good day to all,

recently I discovered a problem that I cannot resolve on my own.


I have a UC520 with the latest software (not the newest 8.x).

Everything is set up and running fine. I have a 7921G and a 7942G attached and registered to that UC520.

The 7921G is configured to have two lines (button 1:1 2:2), the 7942G is configured with an overlay

(button  1:1 2o5,3)

I recently tried to change ringtones on all of these phones. On the 7921G it worked as expected, I could change ringtones as described in the manual.

But, on the 7942G I only had the default "Chirp1" configured on the phone.

During my search for that cause I found that this phone never loads RingTones.xml from the tftp-server. It just does not request it. The 7921 does, however

I have no clue how that happenes and I did not find any help on how to configure that phone to load ringtones.xml.

I do not have any specific cnf-file for both phones, the defaults are loaded through tftp.


Can anyone give me a hint on how to make the 7942G to read ringtones.xml?


Mathias

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
gaertnerm Sun, 03/21/2010 - 09:34
User Badges:

Hi,

unfortunately not...


I can see that during the boot process the phone does not even attempt to read ringtones.xml (debug tftp event) or any other xml from the ringtones directory. And yes, the other phone does do that so the tftp-server settings are correct.


That's what makes me scratch my head...


Mathias

Marcos Hernandez Sun, 03/21/2010 - 09:51
User Badges:
  • Blue, 1500 points or more

Please provide a "show run", a "show ephone", a "show ephone phone-load" and a "show telephony-service tftp-bindings". Remove passwords and confidential info before posting.


Marcos

gaertnerm Sun, 03/21/2010 - 10:11
User Badges:

Ok,

here's the output of all three commands.

It seems there's a problem with the phone-load, but I do not have any idea what...


Mathias

Attachment: 
Marcos Hernandez Sun, 03/21/2010 - 10:16
User Badges:
  • Blue, 1500 points or more

I am suspecting that your 7942 did not upgrade to the latest load in that Software Pack you loaded. Can you check that phone load on the phone itself (from the settings menu)?


Marcos

gaertnerm Sun, 03/21/2010 - 10:22
User Badges:

You mean

software version sccp42.8-3-2S

software id tnp-42.9-2-1-21a.bin

cuu 42.8-3-1-22

I found one log entry on the phone "software authentication failure"...


Mathias

gaertnerm Sun, 03/21/2010 - 14:10
User Badges:

Hi,

I found the proper upgrade procedure for that phone and was able to uprade it to

sccp42.8-5-3S.


But this changed nothing. "show ephone phone-loads" shows the same and the phone is not attempting to load ringtones.xml


Mathias

Marcos Hernandez Sun, 03/21/2010 - 14:36
User Badges:
  • Blue, 1500 points or more

The name of the file the phone requests is RingList.xml when you request the ring tones from the phone "User Preferences" menu. Enable the "debug tftp events" then and you will see.


Marcos

Marcos Hernandez Sun, 03/21/2010 - 14:40
User Badges:
  • Blue, 1500 points or more

Also, verify that the files are there:


dir flash:/ringtones


Marcos

gaertnerm Mon, 03/22/2010 - 00:21
User Badges:

Yes, you're right, I wrote the wrong names in this posting. But however, when using debug tftp event that exactly what I *do not* see in case of the 7942.

It does not request ANY file of that type: Here's the output:

PBX-SVBuero#s deb
TFTP:
  TFTP Event debugging is on


PBX-SVBuero#conf term
Enter configuration commands, one per line.  End with CNTL/Z.
PBX-SVBuero(config)#ephone 2
PBX-SVBuero(config-ephone)#reset
resetting 0026.CB3C.5191
PBX-SVBuero(config-ephone)#
Mar 22 07:05:56.730: %IPPHONE-6-UNREGISTER_NORMAL: ephone-2:SEP0026CB3C5191 IP:1                                                                              0.0.9.4 Socket:2 DeviceType:Phone has unregistered normally.
Mar 22 07:06:38.238: TFTP: Looking for CTLSEP0026CB3C5191.tlv
Mar 22 07:06:38.366: TFTP: Looking for SEP0026CB3C5191.cnf.xml
Mar 22 07:06:38.370: TFTP: Opened flash:/its/XMLDefault7942.cnf.xml, fd 14, size 1359 for process 213
Mar 22 07:06:38.378: TFTP: Finished flash:/its/XMLDefault7942.cnf.xml, time 00:00:00 for process 213
Mar 22 07:06:41.234: %IPPHONE-6-REGISTER: ephone-2:SEP0026CB3C5191 IP:10.0.9.4 Socket:6 DeviceType:Phone has registered.
PBX-SVBuero(config-ephone)#


Not an attempt at all to load anything about RingTones, RingLists or whatever.

The files are there and are utilized by the 7921, as I mentioned before.



Mathias

Marcos Hernandez Mon, 03/22/2010 - 05:38
User Badges:
  • Blue, 1500 points or more

If you read my post again, you will notice that I said that the phone requests this file not upon reboot, but when you try to access the ringtones from the settings, user preference menu. Please provide the tftp debugs for that.


Thanks,


Marcos

gaertnerm Mon, 03/22/2010 - 08:27
User Badges:

Oh, sorry...

From all the documents I've read I gained the impression that the phones load the list at boot (as does the 7921, in my case).

Anyway. I now checked again and now it works!

It seems that the wrong software version was the culprit.

Thanks for the tips


Mathias

Actions

This Discussion