Backup issue on Call Manager

Unanswered Question
Mar 21st, 2010

Hi,


I have Call Manager 7.1.3 and I am using FreeFTPD to backup by CCM's. The issue is I have installed FreeFTPD on our backup server. When I log off the server my backup fails as CCM backup cannot reach SFTP. I even tried installing the client as a service, but no luck. The only work around is I have to lock the server instead of logging off. This option is not feasible to the client.


If any one has used any other client free/paid, please let me know. I want a client that is stable. I appreciate all the help.


Thanks...

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 3 (1 ratings)
Loading.
Aaron Harrison Sun, 03/21/2010 - 14:37

Hi


FreeFTPD is a good product... check that it is actually started under the services control panel in Windows. It will fail to grab port 22 on the server if you are already running it as an application, so make sure you exited it before starting it as a service


Regards


Aaron

rohanpatel Sun, 03/21/2010 - 16:36

Aaron,


I have tried your suggestion, but it does not work. I had the same issue at another client and eventually we decided that the server where we install SFTP will never be logged off, but instead will be locked.


Any other suggestions..


Thanks....

David Hailey Mon, 03/22/2010 - 08:01

Load CopSSH on your server.  It installs as a true service with and creates services accounts to ensure it is running.  You would then configure a backup user that CCM uses to initiate the SFTP transfer and that user account would simply be associated to CopSSH for filesystem rights.  We do this with every client that needs SFTP and have no issues.


Hailey


Please rate helpful posts!

Hi


I have the cop ssh installed on windows xp client. I have created another user with admin priveledges to access the ssh service and activated same.


However aftter when I try to create the backup device I am getting the error that the SFTP server cannot be contacted.


Can you advise what I am doing wrong?


backup device- computer name


SFTP server 172.21.1.98

path- /

username- Ciscotac

Password- ***********

David Hailey Tue, 05/04/2010 - 11:24

Do you have Windows XP firewall turned on? If so, you'll need to permit port 22 in an exception list or it will be blocked. For path, I would use this:


/home/ciscotac/


Hailey


Please rate helpful posts!

David Hailey Tue, 05/04/2010 - 11:39

OK, that's straightforward. The password for the user is incorrect. Have you verified your settings there?

David Hailey Tue, 05/04/2010 - 11:49

Can you ping your XP machine from the CUCM:


From CLI - utils network ping x.x.x.x

David Hailey Tue, 05/04/2010 - 11:59

This is a pretty simple process so let's knock this out.


1) Turn off XP firewall or add an exception for Port 22


2) Create a folder for backups as follows /home/ciscotac/backups in the directory where CopSSH is loaded on WinXP


3) Send me a screen shot of your configuration.


Hailey

David Hailey Tue, 05/04/2010 - 12:29

Ok.  That all looks good, assuming the IP address of the Win XP machine is correct (I would assume, yes).  So, next troubleshooting step is to download an SFTP like Putty's psftp.exe.  Use that tool and attempt to connect to CopSSH directly from the WinXP box.  Run psftp.exe then type open and enter the same credentials.  See if it accepts a connection locally.  If not, you may need to restart the service, reboot, or simply have something that is awry with the CopSSH install.


Hailey

Hi


I got through i tried the putty sftp and it worked locally. The problem was that the machine was in a subnet that was flitered by access lists. Once the ip address was changed I was able to add the backup device and the run the backup successfully. Thanks for all the help this software recommended was very easy to use.


Thanks much

Actions

This Discussion