Internet Exception list for IP Phone

Unanswered Question
Mar 21st, 2010

Dears,

Once I configure the proxy server for the IP Phones, I can not access the local resourses, like corporate directory and the services.

Is there is a way to configure exception list for the phones.

Thanks..

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
David Hailey Mon, 03/22/2010 - 07:59

This would be done on via the proxy server, I believe.  What are you using?

Hailey

Please rate helpful posts!

amarmn1975 Mon, 03/22/2010 - 23:14

Please, can you tell me how I have to configure the proxy server for the IP Phone to allow it to access the internet>> or I can only put the ip of the proxy server in the blank of phone configuration

amarmn1975 Mon, 03/22/2010 - 23:31

Dear,

My question is not in ISA . my question is how can I configure the proxy server in Call manger for the ip phone to allow it to access the internet.

In the proxy server what should I put the proxy IP or the url or what coz I tried to put the ip and the url but it cannot access the internet.

Thanks

David Hailey Mon, 03/22/2010 - 23:40

Ah, I misunderstood the nature of your question.  In the Enterprise Parameters (I'm running 7.1.3), you'll see the following:

IP Phone Proxy Address: This parameter specifies a proxy server name or address and port (for  example, proxy.cisco.com:8080). If the proxy server is specified, the  Cisco IP Phones use it to request all URLs. Leave this setting blank for  the phones to attempt to connect directly to all URLs. If a name is  used instead of an IP address, configure phones with valid DNS servers  to allow name to IP resolution. Confirm that the proxy server is  listening at the destination that is specified.
Maximum length:                255
Allowed values:                Proxy server name or address and port (for example,  proxy.cisco.com:8080)

Is this the setting that you've already tried to specify the value of and had issues or no?

Hailey

Please rate helpful posts!

amarmn1975 Mon, 03/22/2010 - 23:44

I need to configure it in the ip phone kevel for testing first. Shoul it work or no?

Thanks..

David Hailey Tue, 03/23/2010 - 00:22

Personally, unless there is a specific need for it I always block internet access to/from voice networks including IP phones.  Nonetheless, I realize there are reasons to want to do this and leverage a proxy.  With that said, I have not personally tested this configuration BUT technically speaking you should be able to enter the proxy URL at the IP phone device level and it will override the system default (which is blank unless configured otherwise).  You need to enter the host and port of the proxy server (e.g., proxy.company.com:80).  In looking at the Enterprise Parameter description vs. the device level description of this field, there may be a difference in behavior or simply an old description at the phone level because it states that the proxy configuration is used for http requests from the phone to external (non-local) addresses.  However, the Enteprise Parameter states that, if populated, the proxy is used for ALL URL requests.  Also - based on the device level description of when the proxy is used, I can also see where this may cause an issue with accessing internal services (i.e., states that proxy is used if URL contains a dot or an IP address in any form).  Depending on how you set up your URL parameters, you may be referencing IP's (to avoid issues with DNS) and technically they all contain a ".jsp" as well to reference the particular function being called.  Give it a shot and see what happens.  If you have issues, it would be worth running a packet capture off the back of the phone to see the traffic to/from the proxy.  Based on that, it may be easier to determine where the problem (if there is one) lies and how to possibly work around it.

Hailey

Please rate helpful posts!

Actions

This Discussion