Unity 5.0(1) WebSA fails unless Domain Admin (DCOM event 10016)

Unanswered Question
Mar 22nd, 2010

Unless I make a user a member of Domain Admins, when trying to run the WebSA from a client machine, the user sees :

<p><span style="font-family: arial,helvetica,sans-serif;"><em>Server.CreateObject(AvSaLocalization.AvSaLocalization.1)</em></span></p>

This is most likely an error with a DLL, probably AvSaLocalizationSvr.dll or perhaps AvSaLocaleInfoSvr.dll.
Check that these files are present, and registered with REGSVR32.
Also be sure that the appropriate MsgStoreRes.dll file is present.
Cannot continue.
(From: Global.asa: hr=0x80070005)

There is an entry in eventviewer from DCOM EventID 10016

The machine-default permission settings do not grant Local Activation permission for the COM Server application with CLSID


to the user xxxxxx. This security permission can be modified using the Component Services administrative tool.

I am trying to delegate some basic admin functions to helpdesk and do not want these AD accounts to be in Domain Admins. I have seen a post that mentions another possible workaround :


However, I notice the dates on this post are quite old although I am running W2003 SP1 as mentioned in the post. I cannot find any mention on this issue using bug toolkit. I cannot test this change in the production enviroment at this time, does anyone have any newer/further info on this subject (regarding patches/ES etc.) ?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
David Hailey Mon, 03/22/2010 - 11:02

When you installed Unity and ran Permissions Wizard, did you grant DCOM rights and enable the Media Master control?  If you did not, you can experience issues trying to logon to WebSA from other computers.  Definitely worth taking a look at to see if you enabled (desired/checked) or disabled (unchecked) this box.


Please rate helpful posts!


This Discussion