CDAUI1000 Error while trying to load data. Ensure that the system path includes the location of the WebAdminLib.dll.

Unanswered Question
Mar 22nd, 2010

Hello, been receiving this error in Desktop Admistrator Web admin. I have tried the fix where you change the environment variable path and delete the Team Admin folders, but still receive the error. Any ideas??



I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
walshliam Wed, 03/24/2010 - 06:07

yeah, that's what I have already tried, and TAC also recommended those steps. They did not work.

Jeff Patton Sun, 04/22/2012 - 10:53

Did You ever get this fixed? I am having the same issue and the path/teamadmin fix didn't work.

Jeff Patton Sun, 04/22/2012 - 17:02

Thanks for the response, I have tried that several times I was at 7.0(1) sr5 and upgraded to 7.0(2). Still no luck. The only thing I see is workflow admin and still I get the error with everything on the web admin.

Abhiram Kramadhati Sun, 04/22/2012 - 17:47

Hi All,

So to recap, these are the steps to be followed:

On the Unified CCX server, add the location of the WebAdminLib.dll

(C:\Program Files\Cisco\Desktop\bin) to the Path environment variable.

1. In Control panel, launch the System utility.

2. On the Advanced tab, click Environment Variables.

3. From the list of system variables, select Path and click Edit.

4. In the Variable value field, locate the string C:\Program

Files\Cisco\Desktop\bin; and, using cut/paste, move it to the beginning of

the variable value string. This results in the DLL being accessed from the

correct location.

5. Click OK and close the System utility.

6. Stop the Cisco Unified Node Manager.

7. On the Unified CCX server, delete the teamadmin folder from these


C:\Program Files\wfavvid\tomcat_appadmin\webapps

C:\Program Files\wfavvid\tomcat_appadmin\work\catalina\localhost

8. Restart the Unified Node Manager, and wait two minutes.

9. Access Cisco Desktop Administrator and verify that you can navigate to

the Services Configuration


reference/guide/cad66ecd.pdf (pg 29)

In case this does not solve the issue, please verify if you are hitting the defect: CSCtr07664

Sometimes, the dll itself might be corrupted and thus the options in front of you are:

1) OS repair using the software disk

2) Rebuild the node


Abhiram Kramadhati


This Discussion