ISDN stays up after Primary link comes back up

Unanswered Question
Mar 22nd, 2010
User Badges:

I also tried placing a test call and disconnect it. However that ISND still keeps coming back up. THe only for me to keep it down is to shut the BRI interface for a min or two. What am I missing in my configs that tells ISND to stop once the primary link goes up. Below is the configs of the remote site.


Configs:


interface BRI0/0
no ip address
no ip redirects
encapsulation ppp
no ip route-cache cef
ip route-cache flow
no ip mroute-cache
dialer rotary-group 100
dialer-group 1
isdn switch-type basic-ni
isdn point-to-point-setup
isdn spid1 90xxxxxxxx1 2xxxxxx6
isdn spid2 90xxxxxxxx1 2xxxxxx8
isdn fast-rollover-delay 5
no cdp enable
ppp authentication chap
ppp multilink
end


interface Dialer100
ip unnumbered Loopback0
ip access-group wan out
no ip redirects
encapsulation ppp
no ip route-cache cef
ip route-cache flow
no ip mroute-cache
ip ospf message-digest-key 1 md5 7 xxxxxxxxxxxxx
ip ospf network point-to-point
dialer in-band
dialer string 1xxxxxxxxx7
dialer string 1xxxxxxxxx8
dialer load-threshold 128 outbound
dialer-group 1
no cdp enable
ppp authentication chap
ppp multilink



dialer-list 1 protocol ip list 101

access-list 101 deny   ospf any any
access-list 101 deny   ip any host 255.255.255.255
access-list 101 permit ip any any



Some troubleshooting outputs



spokertr#isdn test disconnect interface brI 0/0 all
spokertr#show isdn active (shows down for a sec or two)
--------------------------------------------------------------------------------
                                ISDN ACTIVE CALLS
--------------------------------------------------------------------------------
Call    Calling      Called       Remote  Seconds Seconds Seconds Charges
Type    Number       Number       Name    Used    Left    Idle    Units/Currency
--------------------------------------------------------------------------------
--------------------------------------------------------------------------------


33017rt001#show isdn active (then dials back in)
--------------------------------------------------------------------------------
                                ISDN ACTIVE CALLS
--------------------------------------------------------------------------------
Call    Calling      Called       Remote  Seconds Seconds Seconds Charges
Type    Number       Number       Name    Used    Left    Idle    Units/Currency
--------------------------------------------------------------------------------
Out   ---N/A--- +6XXXXXXX7     hubroutername        0     119       0      0
--------------------------------------------------------------------------------


Any input is appreciated. Thanks in advance

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Richard Burts Sun, 03/28/2010 - 15:43
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

If the ISDN stays up after the primary link comes back up my first thought would be that there might be some flaw in the way that you are triggering the ISDN as a backup link. Are you using floating static routes or some other mechanism? Can you provide details on how you are triggering the ISDN to come up when the primary fails?


My second thought is the possibility that OSPF is learning some route over ISDN that it is preferring to routes learned over the primary and therefore continuing to route traffic over the ISDN link. Is there some route learned over ISDN with a metric that is better than the route learned over the primary? Or possibly is there a route learned via intra area advertisement from ISDN and via inter area advertisement over the primary? Or possibly is there some route learned over the ISDN that is not learned over the primary? Probably the easiest way to investigate this would be to examine the output of show ip route when you are experiencing the problem and to look for any entries still in the routing table that point over the ISDN. Look into those routes and figure out why they are still in the routing table when the primary comes back up.


HTH


Rick

Actions

This Discussion