Allow DDI number to be shown to called party

Unanswered Question
Mar 22nd, 2010

Hi

Normally when we call out on a DDI it shows to the person being called as "private caller"

I want to allow the DDI number to be shown to the caller.

Thanks

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
David Hailey Mon, 03/22/2010 - 18:47

There are configurations within CUCM to restrict calling party number on outbound calls.  If you haven't done that, then you would need to speak with your PSTN provider.  Your trunks may not be properly configured for passing CLID on numbers associated with your trunk group(s).

Hailey

Please rate helpful posts!

jenny_flannigan Mon, 03/22/2010 - 18:55

The PSTN provider tells me it needs to be done with callmanager

see below what I have done - is this correct

Connected Party Transformations
Connected  Line ID PresentationRequired FieldDefault Allowed Restricted
Connected  Name PresentationRequired FieldDefault Allowed Restricted
David Hailey Mon, 03/22/2010 - 19:14

Ok, if I understand you correctly - you want your DID's to be displayed on OUTBOUND calls but they are currently showing to external parties as "Private Number" (or "Unknown Number").

The Connected Party transformation settings you pasted in control what is displayed on the IP phones when they receive an INBOUND call.

Calling Line ID Presentation and Calling Name Presentation

Calling Party presentation information controls whether to display the  phone number and name information that CUCM sends in setup for OUTBOUND calls. The 2 key parameters should be:

Here is a link to guide you thru what you need to know:  http://www.cisco.com/en/US/docs/voice_ip_comm/cucm/admin/7_1_2/ccmsys/a03rp.html#wp1051056

You can search for the guide for your particular version of CUCM if that makes you more comfortable but there shouldn't be too much in this settings across Linux versions.

Hailey

Please rate helpful posts!


a.gooding Mon, 03/22/2010 - 19:24

What about the router? H323 or MGCP? if everything is fine and they confirm that it should be passing the info then id check

or at least verify that the gateway is configured (H323 im assuming).

Actions

This Discussion