CS-MARS & data archiving.

Unanswered Question

I'm using CS-MARS model 20 with software version 6.0.6.

I'm unable to restart data archiving after a SFTP server crash.

I can connect successfully to server from appliance using CLI with SSH client, but archiving reports an error timeout.

From my pc, with the same credentials, I'm able to transfer file, delete and so on.

Any ideas?

Thanks.

Regards.

Andrea

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
JSvanberg Wed, 03/24/2010 - 07:39
User Badges:

Hi!


I have had the same issue twice when reinstalling a sftp-server and a new ssh key was generated, first time i did a discover on the sftp-server and it accepted the new ssh key and it started working again, second time this didn't work and no matter what i tried i couldn't get it to work and what i did was to setup the sftp-server with a new alias ip and then connect the mars sftp archive to the new ip, then it worked.


But i got a tips about an "expert" account and as root go to /root/.ssh and with vi edit known_hosts and delete the row with the sftp host, but i never got it to work, i thougt that the pnadmin was able to su to root but not.


If someone has some info how to get the expert account to work i would be glad, thanks!

JSvanberg Wed, 03/24/2010 - 08:17
User Badges:

What sftp-server are you running?


I read before that with the pnadmin account you could change the password for the expert account with passwd, but that didn't work for me when i tried.

JSvanberg Mon, 03/29/2010 - 11:14
User Badges:

Did you try a discover on the device, set ssh and run discover towards the old ip?


Otherwise I think you need to go with the expert mode to be able to edit known_hosts, but i read this when searching some.


Prior to CS-MARS version 4.1.3, users do not have a method to modify the root password. CS-MARS versions 4.1.3 and later provide the command passwd expert, which allows users to modify a portion of the root password providing additional security. The selected user password is combined with a Cisco controlled component to form a new root password. After performing this step, neither Cisco personnel or the user can access the root account without knowledge of both components used to create the root password. When authorized Cisco development engineers need access to the root account for advanced debugging, both Cisco and the user will need to enter their portion of the configured root password to enable access. Please refer to the Workarounds section of this advisory for more information.


A TAC case for this maybe?

JSvanberg Mon, 03/29/2010 - 15:56
User Badges:

Remembered one thing, there is a setting on how the MARS will behave when there is a new ssh key, under Admin -> System Parameters and SSL/SSH Settings, this did not work for me but you could check it, but it really feels like a bug.

Actions

This Discussion