A/N radios not working on WLC2106

Unanswered Question
Mar 23rd, 2010

I am using WLC2106 on which I've tried some different versions but none allows me to anable A/N radios although they are shown in the GUI and able to be selected they just don't activate.

I wonder if I am missing a configuration step?

This is my current version AIR-WLC2100-K9-4-2-207-0 altough I have even tried the latest one.


P.S. I have also seen the same issue with a customer's WLC4402

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Leo Laohoo Thu, 03/25/2010 - 22:11

For the firmware version you are using, only the 1250 is supported.  "n" is supported when WMM is enabled and you use Open authentication of WPA2/AES.  1140 is supported starting from 6.0.X.  Only the 1140 and 1250 support 802.11n.

Scott Fella Fri, 03/26/2010 - 06:21

Are you having issues enabling 802.11a radio or trying to enable 'N'?  On the CLI, enter config 802.11a enable network and see if the WLC takes that command.  This should enable 802.11a radio...  To enable 'N' support on the 5ghz radio, enter this command in the CLI config 802.11a 11nSupport enable.  You should be able to enable 802.11a/n radio even with no AP's as long as the country code allows 5ghz.

rguzman.plannet Thu, 04/08/2010 - 10:33

Hi an apology for the delay but I had issues with my lap, anyways...

I tried what you suggested, first I checked the country code and it is set to MX in both WLC and APs.

Then I tried the command in CLI and it said 802.11a is already enabled but when I saw in the GUI it says 802.11a/n Admin Status: enabled, Oper Status: DOWN, Regulatory Domain: not supported.

I tried to change country code to US but it said that I need to disable 802.11b to set country code.

Is it something that may affect the operation of my WLAN?


weterry Thu, 04/08/2010 - 21:32

If it says country code not supported, then that is why the radio won't enable.

In order to change country code, you have to disable both b/g and a networks (wireless > 802.11 > unCheck box for "enable network...."

this of course will take down both networks on all aps, so it is client impacting.  Be sure to go back and enable the networks again after you've changed country code.

rguzman.plannet Fri, 04/09/2010 - 09:40

But I don't understand why this happens under WLC esqueme and under IOS I can enable both radios at any time.

weterry Fri, 04/09/2010 - 10:13

An Autonomous AP has no mechanism know what Country it is in. For example, you are not supposed to operate a non-FCC AP in the US, but it doesn't know you are in the US so it will work (potentially Illegally, outside the scope defined by the FCC).

However, the controller knows what country and can therefor enforce (check) to make sure you are operating the correct APs.

The bottom line is that if you have an AP for a different regulatory domain, then that AP should only be used in that regulatory domain for which it was intended....


This Discussion



Trending Topics: Other Wireless Mobility

client could not be authenticated
Network Analysis Module (NAM) Products
Cisco 6500 nam
reason 440 driver failure
Cisco password cracker
Cisco Wireless mode