Problems with tunnel

Unanswered Question
Mar 23rd, 2010
User Badges:

Hi


I have a tunnel betwen a Cisco 3640 and linux gentoo, the internet acces for the Cisco is from a Riverstone Backbone, so i want migrate that Riverstone backbone to a cisco Backbone (CAT 4507) but the tunnel is presenting problems, i dont have web acces, email, etc, i read and found that the problems is MTU, i tried to change the MTU in the tunnel but present the next error.


IPGW4-VPN(config-if)#mtu 1436
% Interface Tunnel9 does not support adjustable maximum datagram size


so i fix the ip mtu and ip tcp adjust-mss and got the same problem


interface Tunnel9
  bandwidth 2048
ip address x.x.x.x
ip mtu 1436
ip tcp adjust-mss 1436
tunnel source x.x.x.x
tunnel destination x.x.x.x
tunnel mode ipip


when i do a sh interface got


Tunnel9 is up, line protocol is up
  Hardware is Tunnel
  Description: x.x.x
  Internet address is x.x.x.x
  MTU 1514 bytes, BW 2048 Kbit, DLY 500000 usec,
     reliability 255/255, txload 1/255, rxload 1/255


i dont know what else do, i tried to fix the MTU in the tunnel and in the inteface Fasth but got the same problem, please your help how i can fix this, any help is welcome.


thanks in advance.


regards

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Jennifer Halim Tue, 03/23/2010 - 23:27
User Badges:
  • Cisco Employee,

"ip tcp adjust-mss 1436" needs to be smaller than the MTU on the tunnel interface.


I would try "ip tcp adjust-mss 1300" and see if that works.

Actions

This Discussion