Cannot upgrade uc520 to 7.0.4 - Should I move to 8.0.2?

Unanswered Question
Mar 23rd, 2010
User Badges:

I have a new UC520 that I am loading for a customer site. Goal is to have 7.0.4 loaded on it. I am running CCA 2.2(2).


The system consists of a UC520-24U, ESW-540-24 and SPA525G phones.


Out of the box, I could not upgrade to 7.0.4 but I was able to upgrade to 7.0.2. I figured I had to do the upgrade in two steps.


When I go to upgrade to 7.0.4 - I go to Software Upgrade, Upgrade Settings and then choose browse. I browse to the uc520-7.0.4 zip file. When I select this I get the following error message:


Software pack is not valid for this device. Please provide correct software pack


I have tried multiple copies of the 7.0.4 image to make sure it wasn't corrupt and I tested the same file on another demo system we have running and it worked fine.


Please suggest a course of action.


I have considered moving to 8.0.2 but I really don't want to put 8.0.2 in production for a client until we have had a chance to run it on our internal systems and our demo unit. The last time I tried installed 8 on my demo unit it blew up so I went back for now.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Steven DiStefano Wed, 03/24/2010 - 01:46
User Badges:
  • Blue, 1500 points or more

Hi,

If I were in your shoes, I would move to the UC 500 bundle zip 8-0-1.  This is production code and in fact has the newest phone load for the SPA525G.  This works for UC520, UC540, and UC560, but make sure you select the correct SKU, because there are three.  Maybe thats what happened to you?

With this pack and CCA 2.2.2, you will be able to make the SPA525G dance (Video Monitoring and Remote SSL VPN mode to name two).


Get the bundle here:

https://supportforums.cisco.com/docs/DOC-9829


Glad you asked.   Get the latest.


Steve D

Systems Engineer

Partner Sales, U.S.

Actions

This Discussion

Related Content