SA 520 IP Alias / Configuration page issue

Unanswered Question
Mar 24th, 2010

I am trying to do a proof of concept for a project that I am working on. One of the requirements is that all printers will be configured with an external IP address so no matter where the users are they can have access to the printers via that external IP address. What I did was place the printer on the internal LAN and create an alias with a public IP on the dedicated WAN. Then I allowed traffic from the WAN to the printers internal IP address. This works great for the people outside of the SA but not for the people inside of the SA where the printer resides.

Now I know you are thinking point these people to the internal IP of the printer. Short answer, I can't. This is a requirement that they also print to the public IP of this printer. If I http to the public IP of the printer from outside of the SA I get the printers configuration screen. If I http from inside the SA to the public IP of the printer I get the SAs configuration screen (even with remote management disabled) on the alias. I need to be able to disable this somehow or get an answer immediately if this is not an option so I can move on.


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
biraja Wed, 03/24/2010 - 12:35

Hi Dan,

IP addresses are aliased to the interface and only redirect the connections coming from WAN interface.

So, as of now internal hosts can't access the printer using the aliased public ip-address.

Thanks and Regards,


cciedan9277 Wed, 03/24/2010 - 12:38

There should really be a work around for this issue. I can do this with a linksys router.

Steven Smith Wed, 03/24/2010 - 12:41

This is currently a bug in the system.  It is documented in the release notes that hairpinning is broken.  I don't have a timeframe for when this will be fixed, but this is a bug.

cciedan9277 Wed, 03/24/2010 - 12:45

Well so much for the proof of concept... I'm ashamed as a ccie that I have to recommend a different product to accomplish something so simple.

biraja Wed, 03/24/2010 - 12:48

hi Dan,

I'll get back to you more on when this would be fixed.

Give me one or two days on this.




This Discussion