cisco vpn client and error 422

Unanswered Question
Mar 24th, 2010

When I try to connect to the cisco vpn client, I get this error:

secure  vpn: connection terminated locally by the client
reason:422 failed  to enable virtual adapter

I googled this error, and several sites  suggested uninstalling/reinstalling cisco vpn client. That didn't help. 
Btw, I see the Cisco VPN Adapter under my network connections.  

Couple  other sites suggest disabling internet connection sharing on vista.  This is a windows xp machine with sp3. In my LAN properties, the  "internet connection sharing" checkbox is unchecked. 

There are  couple firewalls, which I disabled. Still no luck.

I had a pc  problem couple weeks ago, and I had to reinstall everything from  scratch. I didn't receive this error before.
How can I resolve this  issue?

Thanks in advance.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 0 (0 ratings)
FALCONSEYE Wed, 03/24/2010 - 11:25

thanks, i will have to try this when i get home. is there any "side effects" of resetting tcp/ip ?

slmansfield Wed, 03/24/2010 - 11:48

I just ran it on both of my PC's, including this PC that has a VPN connection.  No disruptions occurred on either PC.  That said, I was not having any trouble with either PC prior to running that utility.

hcastillo5 Wed, 03/24/2010 - 14:17

For what is it's worth, this is the same error message you get when the client software isn't

installed with the administrator account in Vista.

I would disable any connectors that aren't being used (wireless, etc) and reinstall the client under an admin account.

FALCONSEYE Thu, 03/25/2010 - 07:00

Correction: The error code is actually 442.

Tried :

netsh int ip reset c:\resetlog.txt

this didn't help either.

The pc is hooked up to a DLink DAP-1522, access point. The access point is wirelessly connecting to DLink DIR-655. I will try to reinstall the cisco vpn client without the access point attached.

Forget one more thing, there is only one account on the pc which is the admin account.

thanks

slmansfield Thu, 03/25/2010 - 09:21

Sorry that did not work.  In searching the Internet I found a few things that impact the VPN adaptor in WIN XP.

Someone found that in the wireless adapter properties for Internet Connection Sharing that you uncheck the box to (not) allow sharing of the wireless Internet connection.

This is this URL that says to try running the repair utility against the wireless adapter.

http://computerproblemsolutions.blogspot.com/2009/11/cisco-vpn-client-error-message-reason.html

I would also check to make sure your wireless adapter does not have a firewall enabled on it.

HTH

slmansfield Thu, 03/25/2010 - 11:52

One more thing I found in my own notes on the subject.  I found that wireless VPN clients have to have the box checked in the properties for the wireless NIC called "Deterministic Network Enhancer".

FALCONSEYE Sun, 03/28/2010 - 07:27

grrr. I still get this lousy reason 442: failed to enable virtual adapter. The windows firewall and mcafee firewall are disabled. I uninstalled / reinstalled the vpn client. The "Internet Connection Sharing" is not allowed. I cannot find "Deterministic Network Enhancer" in my router setup. Not sure what else to try.

slmansfield Mon, 03/29/2010 - 06:07

The settings I mentioned were properties of the wireless NIC.

Did you or can you try a wired connection?

novistafreek Tue, 03/30/2010 - 11:41

Hi, I have the same problem.

Like you, I am using XP with servicepack 3. Used a hole day searching for a solution. Found a lot for Win Vista, tried them all, but nothing worked.

My problems started 3 weeks ago. I reinstalled my wireless networks card. At the same time I upgraded my antivirus program (mcAfee). After that VPN did not work. I even "lost" the TCP/IP protocoll, resulting in av reinstallation of XP.

Hope anyone out ther have a solution, because this is frustrating.....

novistafreek Wed, 03/31/2010 - 01:16

Hi again.

Thought i should tell you i fixed the problem. I had an old USB wireless network card lying aroud and after installing that, everything worked.

In other words, the problem might be your networkcard.

FALCONSEYE Sun, 04/04/2010 - 10:20

I hooked up the cable modem right to the computer. I still get this error  reason:442 failed to enable virtual adapter.

I don't have an extra network card. I am using the one that's on the motherboard.

slmansfield Mon, 04/05/2010 - 06:41

Your last test is using a wired connection to the cable modem and you are able to access the Internet outside of the VPN client? 

If you are using a separate firewall product, you may want to try uninstalling that just to rule out any conflict with the VPN client.  I have had some quirky problems with my Trend Micro software working with other applications.  I would uninstall and reinstall the VPN client after I uninstalled the firewall.

You may also want to try a newer version of the VPN client if you are not already using the newest version, just to rule out a problem in an older version of code.  I don't see any bugs related to virtual adapter problems in XP, but maybe someone using the combination of SP3 with an older version of the VPN client has not reported this problem.

If this is a laptop, have you tried connecting with VPN at another location, just to rule out a problem with your Internet connection?

Here is a URL dscribing how to manually uninstall the VPN client.  Sometimes there are vestiges of an old client or registry settings that the current client does not like.  http://www.cisco.com/en/US/customer/products/sw/secursw/ps2308/products_tech_note09186a0080094b7f.shtml

Once the manual uninstall is completed, I'd run through the steps to re-create the TCP stack and repair the wired NIC, assuming that is what you are currently using.  Make sure there is no firewall or filtering associated with that NIC.

HTH

FALCONSEYE Mon, 04/05/2010 - 08:16

I really appreciate you keeping up with this problem.


     Your last test is using a wired connection to the cable modem and you  are able to access the Internet outside of the VPN client?

Yes, the cable modem was hooked up right to the pc without any wireless equipment that I am using (dLink dir-655 and dLink dap-1522). I can browse the internet without any problems.

I have mcAfee and windows firewall turned on at the moment. However, I did turned them off to try if this thing worked. I will uninstall mcAfee and uninstall/install cisco vpn.

      You may also want to try a newer version of the VPN client if you are  not already using the newest version, just to rule out a problem in an  older version of code.  I don't see any bugs related to virtual adapter  problems in XP, but maybe someone using the combination of SP3 with an  older version of the VPN client has not reported this problem.

The cisco vpn software comes from work. They don't have an updated version of this thing. I know my version is 4.8.xxxx and there is 5.0.xxx versions out there.

       If this is a laptop, have you tried connecting with VPN at another  location, just to rule out a problem with your Internet connection?


This is not a laptop. I will take my work laptop to home and try with that instea and see what happens.

Thanks for the url. One thing I realized is every single time I uninstalled/reinstalled the vpn client, it somehow remembered my connection settings. Not sure if it's saved somewhere in the windows registry keys.

slmansfield Mon, 04/05/2010 - 08:28

We skipped 4.8 because we had problems with it (going to the VPN concentrator).  We had much better luck with 5.0.  I understand and appreciate that your company has to standardize on one version.  If you can try 5.0 I think it is a lot better code.  The only thing we noticed is that it seemed more sensitive to a bad Internet connection than the older versions we used.

Have others at your company upgraded to SP3 and successfully used the 4.8 VPN client?  Is this your home PC?

FALCONSEYE Mon, 04/05/2010 - 09:17

I have to ask around and see if anybody else is using windows xp pro with sp3. This is a home/work pc.

slmansfield Mon, 04/05/2010 - 11:50

If/when you reinitialize your TCP/IP stack on your NIC, please use the following procedure.

Reset TCP/IP stack to installation defaults, type: netsh int ip reset reset.log

Reset WINSOCK entries to installation defaults, type: netsh winsock reset catalog

Reboot the machine.

brian.duncan Tue, 10/26/2010 - 07:10

I too was having this problem, XP SP3, Mcaffee Virus...I tried everything listed here without any result, however I found that uninstalling the Mcafee virus software fixed the problem.  This computer was a Dell netbook so we will be rolling out the corporate virus software anyway. .

drh916 Wed, 12/22/2010 - 19:59

I had the very same problem.  I performed a fresh install of XP Pro due to a hard drive crash. I installed McAfee internet security and then the Cisco VPN client. VPN client could not get pass "Securing communications channel". Errored out with 442 code. failed to enable virtual adapter. Tried different versions of VPN Client with no luck. Did a complete uninstall of McAfee and VPN now works.

Actions

Login or Register to take actions

This Discussion

Posted March 24, 2010 at 9:20 AM
Stats:
Replies:20 Avg. Rating:
Views:29083 Votes:0
Shares:0
Tags: No tags.

Discussions Leaderboard