Last run of CAR Loader is unsuccessful

Answered Question
Mar 24th, 2010
User Badges:

Platform - CUCM 7.1.3


After logging into Serviceability and clicking on CDR Analysis and Reporting I get the popup page that shows the number of records in the CAR database and I also see this error message: "Last run of CAR Loader is unsuccessful, please check the CAR Scheduler Logs for  more information."


I'm not sure where to find the CAR scheduler logs to debug this error. Can someone be of assistance?



One other thing that I have noticed when running Route and Line Group Utilization reports....in the previous version of CCM I was running (4.2.3), I could run a trunk utilization report for an entire week based on hour of day and the report would show me the busy hour for each day of the week. Now when I run that same report in 7.1, it averages the daily busy hour. To get the actual busy hour for each day, I now have to run a separate report for each day of the week which takes a lot more time. The only thing that is different configuration wise is that in the new version I am doing 24/7 loading of CDRs instead of once every 24 hours as in my previous version. Could this cause the change in reporting? Thanks!


Brett

Correct Answer by Jason Wiatr about 6 years 5 months ago

It looks like you are hitting the following defect.


CSCsy90529    CDR Load status shows Unsuccessful if it is interrupted by DRS backup


http://tools.cisco.com/Support/BugToolKit/search/getBugDetails.do?method=fetchBugDetails&bugId=CSCsy90529

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
bsugamele1 Wed, 08/25/2010 - 13:12
User Badges:

No the issue cleared itself when I changed the loading of CAR records from constant to every 24 hours. I have since changed it back and the problem appeared again. If you open a TAC case and they resolve the issue, please post the solution. Thanks!


Brett

bsugamele1 Wed, 02/09/2011 - 11:23
User Badges:

Yep that's it. Excellent detective work Jason - 5 stars. I confirmed the errors in the trace logs collected from RTMT. I figured it was cosmetic as all of my CAR data appears to be consistent, but it's good to have it confirmed. Thanks!


Brett

m4953921353 Mon, 09/26/2011 - 00:35
User Badges:

Guys,


so what I have to do to run CAR Loader successfully? I restarted all services but still got this erros.

I can`t open Jason`s link due to low priviledge rights.


@ bsugamele1 Have You resolved this issue ? Please, help


CUCM 7.1.5

kusatija Mon, 09/26/2011 - 00:55
User Badges:
  • Silver, 250 points or more

Hello!


Currently is CDR giving you the correct data?are you able to run the reports?


If the question is how to get rid of the error mentionted in the hread earlier, then the error occurs because the CAR services get restarted during the backup, causing the warning, this does not effect your CDR processing/production..


Its more like an expected error, if i understand your question correctly!


Hope this makes sense

Kunal

m4953921353 Mon, 09/26/2011 - 02:22
User Badges:

Yes, I am able to run reports (users, gateways...) Seems like it is working fine even if we have this error.


I used to think that this "expected error" somehow influences on system production \ reports....


thanks for answer

m4953921353 Mon, 09/26/2011 - 02:50
User Badges:

One more question about e-mail reports


I get this error when trying to mail report

Error Code

10011

Error Description

System Error. Contact System Administrator.


there is no authentication on our SMTP mail server.


Mail Id - any (example YourName)


pass - no


domain - name  - (example abc.com)


Mail Server Name - here I give IP address of Mail server


What is wrong ? Do your use e-mail reports ?


This advise did not help - http://www.cisco.com/en/US/products/sw/voicesw/ps556/products_tech_note09186a0080933fcf.shtml



Thanks

bsugamele1 Mon, 09/26/2011 - 07:12
User Badges:

I do not get this error message anymore, but I also did not do anything to resolve it. One day it magically quit displaying that error. Sorry I couldn't be of more help there.


As far as the mail configuration goes....make sure CARAdmin is a valid user account on your exchange server and make sure the password is correctly configured in CUCM servicability. I have the FQDN of my exchange server set in the mail server name field.


HTH


-Brett

Hi,


I have the same problem at our CUCM 8.6.2 ->

After logging into Serviceability and clicking on CDR Analysis and  Reporting I get the popup page that shows the number of records in the  CAR database and I also see this error message: "Last run of CAR Loader  is unsuccessful, please check the CAR Scheduler Logs for  more  information."


When I try to open the links to the bug toolkit I get the message -> "Your Cisco Guest Login is not entitled to use Bug Toolkit. "


Can anybody help me to solve this problem? Thanks.


By the way: Could it be because of this error that CDR data out of RTMT are different to data from SQL to tbl_billing_data?


BR

Michael

Rob Huffman Tue, 06/11/2013 - 07:00
User Badges:
  • Super Red, 40000 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 IP Telephony, Unified Communications

Hi Michael,


Here are the bug notes;


CDR Load status shows Unsuccessful if it is interrupted by DRS backup

CSCsy90529


Description


Symptom:
CDRs are inserted  into the CAR database properly (i.e. you can search the CDRs and run  reports), but the CDR Load status shows "Unsuccessful" status in the  Event Log output (obtained from System -> Log Screens -> Event  Log).
Error seen when logging into CDR Analysis and Reporting
------------------WARNING-----------------------
* Last run of CAR Loader is unsuccessful, please check the CAR Scheduler Logs for more information.
Conditions:
This condition can occur if a DRS backup starts while CDR Loading is in progress.
When  DRS backup begins, it sends an interrupt to the CAR Scheduler process  to stop the CDR Loading process. When the CDR Loader begins at it  scheduled time subsequently, it updates all unfinished jobs to reflect  the 'Unsuccessful' (-2) status, because these jobs couldn't finish due  to previous interrupt (that was triggered by the backup operation).
To verify whether you are encountering this situation, look for the following information in the CAR Scheduler traces:
(1)
An interrupt which stops the CDR loading. This interrupt will be observed whenever the DRS backup operation initiates:
INFO  [ShutdownHandlerThread]
services.SchedulerShutdownHandler - run(): -->
-- and --
(2)
The following snippet which will indicate that the CDR Load job status is set to Unsuccessful:
INFO  [main] services.Scheduler - sendAlarm():
CARSchedulerJobError alarm for 2 VARIOUS JOBS job: [JobName->2 VARIOUS
JOBS,FailureCause->Update unfinished (InProgress / Scheduled) jobs from
tbl_event_log.,FailureDetail->CAR Scheduler restarted, update ALL 2 job(s)
with status: '-1','-3' to status: '-2'.]
Note::
In  most instances, the CDRs are actually inserted correctly into the CAR  database. In this case, the "Unsuccessful" status is cosmetic.
However,  if the CDRs are not being inserted into the CAR database and you see  "Unsuccessful" status, then the problem might be different (i.e.  unrelated to the behavior described by this bug).



Details



Last Modified:


Apr 18,2013


Status:


Assigned (A)


Severity:


4 Minor


Product:


Cisco Unified Communications Manager (CallManager)


Support Cases:


82


Known Affected Releases:

(1





Cheers!
Rob

"go easy...step lightly...stay free " 

- The Clash

Hi Rob,


many thanks. Then I will have a look at the daily backup of CUCM that runs at 0:05 am and change this to another time.


Is it possible to schedule saving CDR from -> Serviceability -> CDR Analysis and Reporting so that CDR automatically will be saved to a specified path every day?


Another question is why I see in CDR from -> Serviceability -> CDR Analysis and Reporting a lot of entries with duration "0"? Such entries I don`t have when I make SQL query to CAR from CLI.


What does it mean a entry with duration "0"?


BR

Michael

Hi Rob,


I still have the error "Last run of CAR Loader is unsuccessful, please check the CAR Scheduler Logs for  more information."


The CDR Load schedule is set to "Countinous Loading 24/7".


In system -> Log screens -> event log -> CDR Load I only see status "unsuccessful".


Where can I find the mentioned "CAR Scheduler Logs" to see what the problem is?


BR

Michael

Actions

This Discussion