Cisco 7942G Registration Rejected : Security Error

Unanswered Question
Mar 24th, 2010

Hi guys,

I desperately need a solution for this error or any lead whatsoever that will help!!

I have 150 phones,only 11 of them registered correctly and the rest give me the above error. Registration rejected:Security Error.

The phone load is currently SCCP42.8-5-2SR1S.

Your urgent response will be appreciated


I have this problem too.
1 vote
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
mazinahsan Sat, 07/31/2010 - 03:57

I was having the same error.

CUCM, CAPF and CTL service was running which i turned off. After deleting the Phones when i tried to re-register the phones they started to give me this error. "Registeration Rejected : Security Error" . I also switched the tftp from Publisher to a subscriber server.

Solution : I manually added each phone to the system since they were few phones. You can Use BAT to add the phones if you too many phone having the same problem.

Hope that helps

If any one figure out why it happened please share it here.



Mazin Muhammad


This Discussion