3750 Switch Module xmodem help

Unanswered Question

I have a 3750 switch module in a 3825 router chassie. I have lost the IOS on the switch module. The router IOS is fine and work. I can only connect to the switch module using the service module gig 2/0 session command. I have tried to xmodem the IOS to the switch using the xmodem commands (THIS DOES NOT WORK).  I know that my session into the switch is "quazi" IP base and my xmodem is serial base using the router console port.  How do I get a serial connection (my IOS for the switch) over to the switch when my connection to the switch is "IP" I am assuming. I know there has be to way.


thanks

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Leo Laohoo Thu, 03/25/2010 - 03:56
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    The Hall of Fame designation is a lifetime achievement award based on significant overall achievements in the community. 

  • Cisco Designated VIP,

    2017 LAN, Wireless

I have never seen this before!  I can only think of contacting the TAC and get the module RMA-ed.

Giuseppe Larosa Thu, 03/25/2010 - 05:49
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Jimmy,


you are probably referring to


http://www.cisco.com/en/US/docs/ios/12_3t/12_3t14/feature/guide/miragenm.html#wp1768057



this can be a useful tip for other people having the same issue.


Moving the IOS image into the router flash could be guessed as the only logical step to do.


To be noted that in a multilayer device like C6500 to move images to service modules ip addresses like 127.0.0.x are used.


So my guess was some form of TFTP from router to flash to module but in this case there is an xmodem: filesystem to be used as destination.


Hope to help

Giuseppe

Actions

This Discussion