How to set the date/time on SPA504g?

Unanswered Question
Mar 25th, 2010

I have about 9 SPA504g phones with an SPA9000 and SPA400.  I can't seem to get the date/times on these phones to stay in sync.  I set the DNS and ntp fields, and I manually set the date/time.  But the times wander either fast/slow, and they don't seem to ever get the ntp time.  I have an open ticket at Cisco support, but they have no info on this.  Are there any suggestions?  Thanks.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
josruiz Fri, 03/26/2010 - 08:37

Can you please post your case # so we can verify what is going on or call us again to further assist you with this issue... 1866-606-1866 US/Canada

William Paulsen Fri, 03/26/2010 - 19:05

I fixed this problem myself (although this occurred to be while talking to tech support):

In the SPA504G/Voice/System tab, in the "System Configuration" section at the top of the page, the "SPCP Auto-detect" switch must be set to "no".  In my case the default setting was "yes".  As soon as I did this and hit Submit, the phone shows the correct time.  Even after power cycles.

And the Cisco tech support person confirmed that the setting on his test bench was also set to "no".  I'm not sure why the default is "yes", but it would have been good if there were reference .html pages to check these kinds of settings.

dieswaytoofast Wed, 04/28/2010 - 19:17

Anybody else seen this?

I've got pretty much the same issues on a 504g (7.4.4), but setting SPCP to 'No' doesnt really make a difference.

As far as I can tell, the display constantly stays on GMT...

dieswaytoofast Sat, 05/01/2010 - 04:42

Turns out the culprit is DHCP option 2, which is a Time Offset from GMT.

Sooo, how do I get the phone to *not* use DHCP option 2, and instead to use its configured values for Time_Zone, Daylignt_Saving_Time_rule, etc.?

knvalerio Thu, 11/10/2011 - 09:57

I was actually able to set the correct Date/Time on this phone. I'm using firmware 7.4.9c.

To do this go to your phone settings "via IP on your browser" hit Admin Login, Voice, Regional, and in the Miscellaneous part put in the date "11/10" and the time "1/02" Submit Changes and that's it.

Unfortunately I didn't find a way to do this on multiple phones at the same time...

Patrick Born Thu, 11/10/2011 - 10:24


The phone's time is controlled by the following provisioning parameters:






   Patrick Born | Technical Marketing Engineer (TME) – SPA SIP Endpoints
                    Use this reference document to locate SPA phone resources

knvalerio Thu, 11/10/2011 - 12:19

Thank you for the reply Patrick, you're right it works but it didn't account for the DST.


This Discussion