OSPF Routing Protocol

Unanswered Question
Mar 25th, 2010

Hi,

I configured the OSPF as shown on the diagram in the attachment.


Senorio 1: All the ports on the switch initally on default VLAN and there was no problem in OSPF neigbour formation.

Senorio 2: I confiured the 2 different netwrok on 2 different VLAN. I though the OSPF Neibour will fail because there is no routing between the VLAN. But the neibour formation was successful. i even reload the routers.

My question is how did the routing protocols were excanged between the 2 Broadcast domain (i.e. Between 2 VLAN) when there is no routing between the 2 broadcast domain.

Regards

Logesh

v\:* {behavior:url(#default#VML);} o\:* {behavior:url(#default#VML);} w\:* {behavior:url(#default#VML);} .shape {behavior:url(#default#VML);} /* Style Definitions */ table.MsoNormalTable {mso-style-name:"Table Normal"; mso-tstyle-rowband-size:0; mso-tstyle-colband-size:0; mso-style-noshow:yes; mso-style-priority:99; mso-style-qformat:yes; mso-style-parent:""; mso-padding-alt:0in 5.4pt 0in 5.4pt; mso-para-margin-top:0in; mso-para-margin-right:0in; mso-para-margin-bottom:10.0pt; mso-para-margin-left:0in; line-height:115%; mso-pagination:widow-orphan; font-size:11.0pt; font-family:"Calibri","sans-serif"; mso-ascii-font-family:Calibri; mso-ascii-theme-font:minor-latin; mso-fareast-font-family:"Times New Roman"; mso-fareast-theme-font:minor-fareast; mso-hansi-font-family:Calibri; mso-hansi-theme-font:minor-latin;}

Attachment: 
I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Jon Marshall Thu, 03/25/2010 - 17:01

Logesh

Can't read your attachments. Could you just post the configs + a jpg/png of the setup.

Jon

lmanavalan Thu, 03/25/2010 - 17:25

Hi,

Please find the diagram in the attachment and below is the configuration

R1: Configuration

interface FastEthernet0/0
ip address 172.30.49.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 10.1.14.1 255.255.255.252
duplex auto
speed auto
shutdown
!
router ospf 1
log-adjacency-changes
network 172.30.49.0 0.0.0.255 area 0
network 10.1.14.0 0.0.0.3 area 0


R4: Configuration

!
interface FastEthernet0/0
ip address 172.30.50.4 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 10.1.14.2 255.255.255.252
duplex auto
speed auto
!
router ospf 1
log-adjacency-changes
network 172.30.50.0 0.0.0.255 area 0
network 10.1.14.2 0.0.0.0 area 0
!

R3: Configuration

!
interface FastEthernet0/0
ip address 172.30.50.3 255.255.255.0
duplex auto
speed auto
!
router ospf 1
log-adjacency-changes
network 172.30.50.0 0.0.0.255 area 0
!

R2: Configuration

!
interface FastEthernet0/0
ip address 172.30.50.2 255.255.255.0
duplex auto
speed auto
!
router ospf 1
log-adjacency-changes
network 172.30.50.0 0.0.0.255 area 0
!

Senorio 1: Switch configuration

hostname Switch
!
!
!
interface FastEthernet0/1
description toR4
!
interface FastEthernet0/2
description toR3
!
interface FastEthernet0/3
  description toR2
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
  description toR4
!
interface FastEthernet0/24
  description toR1

!
interface Vlan1
no ip address
shutdown
!


Senorio 2: Switch configuration

hostname Switch
!
!
!
interface FastEthernet0/1
description toR4
switchport access vlan2
!
interface FastEthernet0/2
description toR3
switchport access vlan2
!
interface FastEthernet0/3
  description toR2
  switchport access vlan2
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
  description toR4
  switchport access vlan3
!
interface FastEthernet0/24
  description toR1
  switchport access vlan3
!
interface Vlan 2
ip address 10.1.1.1 255.255.255.0
!
interface Vlan 3
ip address 10.2.2.2 255.255.255.0
!

Regards

Logesh

Attachment: 
Jon Marshall Thu, 03/25/2010 - 17:37

Thanks for that.

Can you post "sh ip ospf neighbors" from all routers.

Jon

Tharak Abraham Thu, 03/25/2010 - 22:01

Logesh,

Did you use vlan SVI's on the switch and advertise the IP in OSPF ?

Please do a sh ip ospf neigh on the routers and paste it here..

lmanavalan Thu, 03/25/2010 - 23:14

sh ip ospf neighbor

R1#sh ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface
172.30.50.4       0   FULL/  -        00:00:33    10.1.14.2       FastEthernet0/1


R4#sh ip os neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface
172.30.50.2       1   FULL/DROTHER    00:00:39    172.30.50.2     FastEthernet0/0
172.30.50.3       1   FULL/BDR        00:00:34    172.30.50.3     FastEthernet0/0
172.30.49.1       0   FULL/  -        00:00:34    10.1.14.1       FastEthernet0/1

R2#sh ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface
172.30.50.3       1   FULL/BDR        00:00:35    172.30.50.3     FastEthernet0/0
172.30.50.4       1   FULL/DR         00:00:35    172.30.50.4     FastEthernet0/0

R3#sh ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface
172.30.50.2       1   FULL/DROTHER    00:00:31    172.30.50.2     FastEthernet0/0
172.30.50.4       1   FULL/DR         00:00:36    172.30.50.4     FastEthernet0/0

Actions

This Discussion