With MGCP/FXO all Phones can call out but with H.323 only Specific Phones can call outside & gives busy tone

Answered Question
Mar 26th, 2010

Hi,

I am using 4FXOs with H.323. Only four specific IP Phones can make outside calls and when i try to call outside call from remaining IP Phones it gives busy tone. All the IP Phones were were working fine with MGCP but since i had changed to H.323 this issue is coming. Please check the gateway configuration below and let me know what could be the possible issue:

sh run
Building configuration...


Current configuration : 3976 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname TS_VOIP_GATEWAY
!
boot-start-marker
boot-end-marker
!
! card type command needed for slot/vwic-slot 0/2
!
no aaa new-model
dot11 syslog
!
!
ip cef
!
!
no ip domain lookup
multilink bundle-name authenticated
!
trunk group  FXO1
!
!
trunk group  1
max-calls any 4
description trunk group for FXO Ports
hunt-scheme round-robin
!
voice-card 0
no dspfarm
!
voice class h323 1
h225 timeout tcp establish 3
!
archive
log config
  hidekeys
!
--More--                           interface FastEthernet0/0
ip address 192.168.80.254 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 172.16.1.2
ip route 0.0.0.0 0.0.0.0 192.168.80.200
ip route 10.50.50.100 255.255.255.252 172.172.172.2
ip route 91.103.144.0 255.255.255.0 172.172.172.2
ip route 172.31.1.0 255.255.255.0 168.187.117.230
ip route 172.31.180.0 255.255.255.0 168.187.117.230
ip route 172.31.220.0 255.255.255.0 168.187.117.230
ip route 192.1.1.0 255.255.255.0 168.187.117.230
ip route 192.168.3.0 255.255.255.0 172.16.1.2
ip route 192.168.5.0 255.255.255.0 172.16.1.6
ip route 192.168.7.0 255.255.255.0 172.16.1.10
--More--                           ip route 192.168.8.0 255.255.255.0 172.16.1.14
ip route 192.168.9.0 255.255.255.0 172.16.1.18
ip route 192.168.10.0 255.255.255.0 172.16.1.22
ip route 192.168.11.0 255.255.255.0 172.16.1.26
!
!
ip http server
no ip http secure-server
!
control-plane
!
!
!
voice-port 0/0/0
supervisory disconnect dualtone mid-call
output attenuation -3
cptone KW
timeouts interdigit 2
timeouts call-disconnect 5
timeouts wait-release 5
connection plar 4001
caller-id enable
!
voice-port 0/0/1
compand-type a-law
cptone KW
timeouts interdigit 2
connection plar opx 5555
description *Transfer To Magda*
--More--                            caller-id enable
!
voice-port 0/0/2
compand-type a-law
cptone KW
timeouts interdigit 2
connection plar opx 7397
description *Operator no*
caller-id enable
!
voice-port 0/0/3
compand-type a-law
cptone KW
timeouts interdigit 2
connection plar opx 7858
description *Transfer To Magda*
caller-id enable
!
!
!
!
!
dial-peer voice 7337 voip
--More--                            destination-pattern 4001
voice-class h323 1
session target ipv4:192.168.80.10
dtmf-relay h245-alphanumeric
codec g711ulaw
no vad
!
dial-peer voice 5555 voip
destination-pattern 5555
voice-class h323 1
session target ipv4:192.168.80.10
dtmf-relay h245-alphanumeric
codec g711ulaw
no vad
!
dial-peer voice 7858 voip
destination-pattern 7858
voice-class h323 1
session target ipv4:192.168.80.10
dtmf-relay h245-alphanumeric
codec g711ulaw
no vad
!
dial-peer voice 7397 voip
destination-pattern 7397
voice-class h323 1
session target ipv4:192.168.80.10
dtmf-relay h245-alphanumeric
codec g711ulaw
no vad
!
dial-peer voice 1 pots
destination-pattern [2-9].......
port 0/0/0
!
dial-peer voice 2 pots
destination-pattern [2-9].......
port 0/0/1
!
dial-peer voice 3 pots
destination-pattern [2-9].......
port 0/0/2
!
dial-peer voice 4 pots
destination-pattern [2-9].......
port 0/0/3
--More--                           !
!
!
line con 0
password cisco
login
line aux 0
line vty 0 4
password cisco
login
line vty 5 15
password cisco
login
!
scheduler allocate 20000 1000
!
end

TS_VOIP_GATEWAY#                        sh ver
Cisco IOS Software, 2800 Software (C2800NM-SPSERVICESK9-M), Version 12.4(15)T10, RELEASE SOFTWARE (fc3)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2009 by Cisco Systems, Inc.
Compiled Mon 14-Sep-09 14:01 by prod_rel_team

ROM: System Bootstrap, Version 12.4(13r)T11, RELEASE SOFTWARE (fc1)

TS_VOIP_GATEWAY uptime is 10 hours, 30 minutes
System returned to ROM by reload at 20:49:18 UTC Thu Mar 25 2010
System image file is "flash:c2800nm-spservicesk9-mz.124-15.T10.bin"


This product contains cryptographic features and is subject to United
States and local country laws governing import, export, transfer and
use. Delivery of Cisco cryptographic products does not imply
third-party authority to import, export, distribute or use encryption.
Importers, exporters, distributors and users are responsible for
compliance with U.S. and local country laws. By using this product you
agree to comply with applicable laws and regulations. If you are unable
to comply with U.S. and local laws, return this product immediately.

A summary of U.S. laws governing Cisco cryptographic products may be found at:
--More--                           http://www.cisco.com/wwl/export/crypto/tool/stqrg.html

If you require further assistance please contact us by sending email to
[email protected] 2811 (revision 53.51) with 249856K/12288K bytes of memory.
Processor board ID FHK1344F19K
2 FastEthernet interfaces
1 Channelized (E1 or T1)/PRI port
4 Voice FXO interfaces
DRAM configuration is 64 bits wide with parity enabled.
239K bytes of non-volatile configuration memory.
126000K bytes of ATA CompactFlash (Read/Write)

Cisco

Configuration register is 0x2102

TS_VOIP_GATEWAY#sh bv      voice port summ
                                          IN       OUT
PORT           CH   SIG-TYPE   ADMIN OPER STATUS   STATUS   EC
============== == ============ ===== ==== ======== ======== ==
0/0/0          --  fxo-ls      up    dorm idle     on-hook  y
0/0/1          --  fxo-ls      up    dorm idle     on-hook  y
0/0/2          --  fxo-ls      up    dorm idle     on-hook  y
0/0/3          --  fxo-ls      up    dorm idle     on-hook  y

PWR FAILOVER PORT        PSTN FAILOVER PORT
=================        ==================

I have this problem too.
0 votes
Correct Answer by Volodymyr Morskyy about 6 years 8 months ago

Also wrong incoming dial-peer may be matched(obviously are matched 5555, 4001, 7858 and 7397) What are the directory numbers of the phones which can make a call?

Try to add dial-peer:(in case other phones' DNs have 4 digits)

dial-peer voice 100 voip
destination-pattern ....
voice-class h323 1
session target ipv4:192.168.80.10
dtmf-relay h245-alphanumeric
codec g711ulaw
no vad
!

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Brandon Buffin Fri, 03/26/2010 - 07:26

Check the Calling Search Space between the working and non-working phones. Are they the same? Phones will need a Calling Search Space that has access to a Partition assigned to a Route Pattern that can send calls to the H.323 gateway.

Hope this helps.

Brandon

Correct Answer
Volodymyr Morskyy Fri, 03/26/2010 - 09:23

Also wrong incoming dial-peer may be matched(obviously are matched 5555, 4001, 7858 and 7397) What are the directory numbers of the phones which can make a call?

Try to add dial-peer:(in case other phones' DNs have 4 digits)

dial-peer voice 100 voip
destination-pattern ....
voice-class h323 1
session target ipv4:192.168.80.10
dtmf-relay h245-alphanumeric
codec g711ulaw
no vad
!

Actions

This Discussion