WebVPN (SSL) Smart Tunnel not working to Excel.exe

Unanswered Question
Mar 26th, 2010


I have a WebVPN profile setup which has Smart Tunnel enabled for Adobe Acrobat reader and Microsoft Excel. The web application we use through WebVPN can export to Adobe reader okay, but won't export to Excel (no errors, it just doesn't work. Excel doesn't even open). We've tried Office 2003 and 2007, and the ASA is running 8.2(2). I'm not totally sure, but I think when I tested this at the end of last year it worked fine, the only difference being our ASA was running 8.0(4).

I can't find anything in the release notes for 8.3(3) which specifically reference this issue, although it's likely that I'll upgrade the ASA's next week anyway.

Has anyone else has this issue? Any help would be appreciated.



I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
jimsiff Sun, 03/28/2010 - 00:41

Are you requiring a MD5 or SHA1 hash for the Excel executable?  If so, do the hashes match the version being used by the client?  Are you requiring full path name?  If so, is Excel installed in the same plath?

tonymitchell Mon, 03/29/2010 - 03:27

Hi Jim,

Thanks for your reply. We're not using hash, and the process name is simply "excel.exe" which should be okay for the version of Office we have installed. I'm not sure we'd need the whole path, as I thought it's just looking at the process list for the executable?

The weird thing is that Adobe reader works fine, and I'm sure Excel did until the ASA upgrade to 8.2(2).



jimsiff Mon, 03/29/2010 - 08:52

Hi Tony,

Just a thought... You might verify that case sensitivity isn't causing a problem with Smart Tunnel process matching.  When I checked my PC with Office 2007, the process name is EXCEL.EXE rather than excel.exe.

Good luck,


tonymitchell Thu, 04/15/2010 - 07:20

Thanks Jim for your input, but unfortunately I'm still stuck without Smart Tunnel access to Excel. I've just tried changing the process name to match the correct case, but it's still not working. I've also tried enabling all file server access (as it was locked down), but again with no luck.

My next tactic will be to use a spare ASA we have and roll back to 8.0.4 and see if it's a firmware issue.

Any additional help would be appreciated.




This Discussion

Related Content