EIGRP Default Route Redistribution

Unanswered Question
Mar 28th, 2010

I have 2 routers.  Each router is connected to the same

ISP but have unique paths and networks to the ISP.  Each router receives a  default route from the ISP via EIGRP.  I am running HSRP on "inside" of my Internet routers.  The routers are name active and standby.  Each router has a 3rd interface which connects each router together.  I would like to load share outbound traffic heading to the Internet.  Currently, outbound traffic goes to the active router (HSRP) and passes to the ISP.  The standby router is not used.  Using the 3rd interface and a second EIGRP routing process, I would like the standby router to redistribute the a defualt route to the active router.  Thus the active router will have 2 equally weighted default routes and utilitize each (load share).  Adjusting the delay, I have been able to have routing shift from one router to the other.  I have not been able to load share (half the traffic leave the active router directly to the ISP and the other half pass to the standby router then the ISP).

My configurations

active router information

router eigrp 304
redistribute connected
redistribute static
network 1x.1x.1x.0 0.0.0.3
distribute-list cpa2dir_out out GigabitEthernet0/2
distribute-list default_route in GigabitEthernet0/2
no auto-summary
!
router eigrp 100
network 192.168.100.164 0.0.0.3
distribute-list default_route in GigabitEthernet0/3
auto-summary

choke7204#show ip eigrp topology 0.0.0.0
IP-EIGRP (AS 304): Topology entry for 0.0.0.0/0
  State is Passive, Query origin flag is 1, 0 Successor(s), FD is 4294967295
  Routing Descriptor Blocks:
  1x.1x.1x.1x (GigabitEthernet0/2), from 1x.1x.1x.1x, Send flag is 0x0
      Composite metric is (30720/28160), Route is External
      Vector metric:
        Minimum bandwidth is 100000 Kbit
        Total delay is 200 microseconds
        Reliability is 255/255
        Load is 4/255
        Minimum MTU is 1500
        Hop count is 1
      External data:
        Originating router is 1x.1x.2x.2x
        AS number of route is 1761
        External protocol is OSPF, external metric is 1
        Administrator tag is 1761 (0x000006E1)
        Exterior flag is set
IP-EIGRP (AS 100): Topology entry for 0.0.0.0/0
  State is Passive, Query origin flag is 1, 1 Successor(s), FD is 30720
  Routing Descriptor Blocks:
  192.168.100.166 (GigabitEthernet0/3), from 192.168.100.166, Send flag is 0x0
      Composite metric is (30720/30464), Route is External
      Vector metric:
        Minimum bandwidth is 100000 Kbit
        Total delay is 200 microseconds
        Reliability is 255/255
        Load is 1/255
        Minimum MTU is 1500
        Hop count is 1
      External data:
        Originating router is 2x.6x.1x.1x
        AS number of route is 304
        External protocol is EIGRP, external metric is 30720
        Administrator tag is 1761 (0x000006E1)
        Exterior flag is set

choke7204#show ip route 0.0.0.0
Routing entry for 0.0.0.0/0, supernet
  Known via "eigrp 100", distance 170, metric 30720, candidate default path
  Tag 1761, type external
  Redistributing via eigrp 100
  Last update from 192.168.100.166 on GigabitEthernet0/3, 00:34:16 ago
  Routing Descriptor Blocks:
  * 192.168.100.166, from 192.168.100.166, 00:34:16 ago, via GigabitEthernet0/3
      Route metric is 30720, traffic share count is 1
      Total delay is 200 microseconds, minimum bandwidth is 100000 Kbit
      Reliability 255/255, minimum MTU 1500 bytes
      Loading 1/255, Hops 1
      Route tag 1761


standby router information

router eigrp 304
redistribute connected
redistribute static
network 1x.1x.1x.4x 0.0.0.3
distribute-list cpa2dir_out out GigabitEthernet0/2
distribute-list default_route in GigabitEthernet0/2
no auto-summary
!
router eigrp 100
redistribute eigrp 304 metric 100000 19 255 1 1500
network 192.168.100.164 0.0.0.3
distribute-list default_route out GigabitEthernet0/3
auto-summary

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (1 ratings)
Loading.
Jon Marshall Sun, 03/28/2010 - 05:51

What device sends traffic to these routers ?

It would be a lot easier and less complex if you simply used the device behnd the routers to load-balance as it would see 2 equal cost paths ?

If the device is simply a L2 switch then you could use GLBP instead of HSRP to load-balance.

Perhaps you could clarify the topology behind the routers ?

Jon

rmeans Sun, 03/28/2010 - 05:56

I have multiple devices behind the 2 routers.  ASA firewalls and other Cisco routers.  Several of the devices are not under my administrative control (one reason we have kept HSRP).

Jon Marshall Sun, 03/28/2010 - 06:15

rmeans wrote:

I have multiple devices behind the 2 routers.  ASA firewalls and other Cisco routers.  Several of the devices are not under my administrative control (one reason we have kept HSRP).

So not everything behind the routers has to go through the ASA firewalls ?

Running GLBP does not require you to have administrative control but it would not load-balance equally necessarily.

Could you explain the logic of having a 2nd EIGRP process on the 2 routers ?

What are the reported distances from both ISPs ?

I'm sure you are aware that you can actually do unequal cost load-balancing with EIGRP but i appreciate you may not want this.

EIGRP together with HSRP is not really suited to this type of thing. If you have multiple exit points and you want to influence outbound traffic BGP is much better. Again i appreciate that you may not have the choice to use anything but EIGRP but any solution is going to be a bit of a kludge because you are trying to force traffic to take a suboptimal path ie. instead of going straight out the ISP you want half of it to take a longer way out via the standby router. That's the main issue you have ie. mixing a routing protocol with a redundant gateway protocol (HSRP). You are then trying to modify what HSRP has been designed to do.

I'm not criticising, just trying to make clear that this is not a clean solution.

Jon

rmeans Sun, 03/28/2010 - 06:29

Reading about GLBP now.  So far it looks good.  I will let you know.

Thanks

rmeans Sun, 03/28/2010 - 07:48

I tried adding GLBP but was not successful.  The configuration should be pretty easy.  I removed HSRP and added "glbp 10 ip x.x.x.x" to each router interface.  After clearing the arp cache, traffic began passing with the primary router.  I was not able to get the standby router out of initalize mode.  I probably missed something in my quick read.  The maintenance window is now closed.  I will have more time to read.

Actions

This Discussion