Help setting up Cisco Network Assistant

Unanswered Question
Mar 29th, 2010
User Badges:

Hey Guys,

Let me start off by saying I am a newbie to Cisco. I have some very basic knowledge on how the IOS works.


That being said - I am looking to deploy Cisco Network Assistant to manage 5 Cisco 2960 switches.


Each switch was pretty much unwrapped from box and installed, no configurations made. Each has the default VLAN 1. Each switch is connected to one another as well.


I've attached a basic pic showing how they are all connected.


After doing some research, the application is stating the switches each need to have their own IP in order to be remotely managed over the CDP protocol.


My question is - how do I set up each switch with an IP address so that it can be managed by the Network Assistant PC? I tried to assign an IP to VLAN1 on one of the switches, but was unable to ping it after doing so.


Each VLAN is hosting the same subnet of 192.168.16.0/24 so there is no routing needed.


Any help is greatly appreciated.

Attachment: 
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
robmccam1 Mon, 03/29/2010 - 16:48
User Badges:

You said you are a newbie.  I am going to give you a command by command.  This should allow you to cull off anything that you already know.  Some of these things I do here are for later on, but start with good habits.



Connect up your blue (rollout) cable to switch 1.  I am going to assume these are 2960-24TT's.  I will also setup a connection between the switches.  All switches connect to switch three, rather than daisy chain.


type

switch>enable

switch#conf t

switch(config)#host sw1

sw1(config)#interface vlan 1

sw1(config-int)#ip address 192.168.16.1 255.255.255.0

sw1(config-int)#exit

sw1(config)#interface fa 0/1

sw1(config-int)#switchport mode trunk

sw1(config-int)#description "Uplink to switch 3 fa 0/1"

This sets up a trunk connection to the other switches.  The switch will do this automatically, but it is best to define it, if for nothing else of remembering what you did the next time you connect.

sw1(config-int)#exit

sw1(config-int)#exit

sw1(config)#exit

sw1#write memory


Now take an ethernet cable and connect port fa 0/1 on switch 1 to port fa 0/1 on switch 3.



Connect up switch 2

switch>enable

switch#conf t

switch(config)#host sw2

sw2(config)#interface vlan 1

sw2(config-int)#ip address 192.168.16.2 255.255.255.0

sw2(config-int)#exit

sw2(config)#interface fa 0/1

sw2(config-int)#switchport mode trunk

sw2(config-int)#description "Uplink to switch 3 fa 0/2"

sw2(config-int)#exit

sw2(config)#exit

sw2#write memory


Now take an ethernet cable and connect port fa 0/1 on switch 2 to port fa 0/2 on switch 3.


Connect up switch 3

switch>enable

switch#conf t

switch(config)#host sw3

sw3(config)#interface vlan 1

sw3(config-int)#ip address 192.168.16.3 255.255.255.0

sw3(config-int)#exit

sw3(config)#interface range fa 0/1 - 5

Notice the command is interface range.  This is how you can change several ports at once.

sw3(config-int)#switchport mode trunk

sw3(config-int)#description "Uplink from switches"

sw3(config-int)#exit

sw3(config)#interface fa 0/6

sw3(config-int)#switchport mode access

sw3(config-int)#spanning-tree portfast

sw3(config-int)#exit

sw3(config)#exit

sw3#ping 192.168.16.1

sw3#ping 192.168.16.2

This should return a ping on both of the last two commands.  If not, you haven't connected up something right.  The ping will come back as
"!!!!!" if it is right, and "....." if it is wrong.

sw3#write memory



Connect up switch 4

switch>enable

switch#conf t

switch(config)#host sw4

sw4(config)#interface vlan 1

sw4(config-int)#ip address 192.168.16.4 255.255.255.0

sw4(config-int)#exit

sw4(config)#interface fa 0/1

sw4(config-int)#switchport mode trunk

sw4(config-int)#description "Uplink to switch 3 fa 0/4"

sw4(config-int)#exit

sw4(config)#exit

sw4#write memory


Connect up switch 5

switch>enable

switch#conf t

switch(config)#host sw5

sw5(config)#interface vlan 1

sw5(config-int)#ip address 192.168.16.4 255.255.255.0

sw5(config-int)#exit

sw5(config)#interface fa 0/1

sw5(config-int)#switchport mode trunk

sw5(config-int)#description "Uplink to switch 3 fa 0/2"

sw5(config-int)#exit

sw5(config)#exit

sw5#write memory


On your client machine set the IP to 192.168.16.10 255.255.255.0.  Connect your client machine to fa 0/6 on switch 3.  You could use any switch port, but this one has the spanning-tree portfast, so it will work faster.


From your machine, bring up a command prompt and see if you can ping 192.168.16.1 - 5.  If so, open your Cisco Network Assistant and go to connect.  It should work.


Hope this helps.

Nick Luckner Mon, 03/29/2010 - 16:58
User Badges:

Wow - thank you so much for this response! I really do appreciate it.


Before I posted, I tried to configure VLAN1 with an IP. Below is what I did:


switch>enable

switch#conf t

sw1(config)#interface vlan 1

sw1(config-int)#ip address 192.168.16.1 255.255.255.0

sw1(config-int)#exit


I was plugged into the switch VIA ethernet and had my laptop configured with a static IP. I was unable to ping 192.168.16.1. Is that because I did not complete all the commands you have listed below? I will try what you provided tomorrow when I get back into the office.


Also - these switches are live so these changes I am making will not affect anything connected, correct?


switch>enable

switch#conf t

switch(config)#host sw1

sw1(config)#interface vlan 1

sw1(config-int)#ip address 192.168.16.1 255.255.255.0

sw1(config-int)#exit

sw1(config)#interface fa 0/1

sw1(config-int)#switchport mode trunk

sw1(config-int)#description "Uplink to switch 3 fa 0/1"

This sets up a trunk connection to the other switches.  The switch will do this automatically, but it is best to define it, if for nothing else of remembering what you did the next time you connect.

sw1(config-int)#exit

sw1(config-int)#exit

sw1(config)#exit

sw1#write memory

robmccam1 Tue, 03/30/2010 - 05:24
User Badges:

Ok, before you go on, you may want to work on offline switches.

At a command prompt type >show vlan

It should return:


VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa0/2, Fa0/3, Fa0/4, Fa0/5, Fa0/6, Fa0/7,Fa0/8,

                                                         Fa0/9, Fa0/10, Fa0/11, Fa0/12, Fa0/13, Fa0/14,

                                                         Fa0/15....

If the port you are using is not in vlan1 then you will not be able to ping.

If your IP address is not set to a number 192.168.16.6 - 255, you will not connect.  Additionally, if your subnet mask is not 255.255.255.0 you will not have connection.

If all ports are in vlan1 then it should ping. Provided your laptop is in the same subnet.

Nick Luckner Tue, 03/30/2010 - 13:55
User Badges:

I got it to work on my test switch. I cannot get it to work on my live switch - ping responses do not work on the switch or on laptop... can you see why?


I gave it IP  ip address 192.168.16.49 255.255.0.0

My laptop is using 192.168.16.249 255.255.0.0


I used this same scenerio on my test switch - I just modified your code.


Here is the running-config


R507#show running-config                       
Building configuration...                       

Current configuration : 1205 bytes                                 
!
version 12.2           
no service pad             
service timestamps debug uptime                              
service timestamps log uptime                            
no service password-encryption                             
!
hostname R507            
!
!
no aaa new       
ip subnet-zero             
!
!
!
!
no file verify auto                  
spanning-tree mode pvst                      
spanning-tree extend system-id                             
!
vlan internal allocation policy ascending                                        
!
interface FastEthernet0/1                        
!
interface FastEthernet0/2                        
!
interface FastEthernet0/3                        
!
interface FastEthernet0/4                        
!
interface FastEthernet0/5                        
!
interface FastEthernet0/6                        
!
interface FastEthernet0/7                        
!
interface FastEthernet0/8                        
!
interface FastEthernet0/9                        
!
interface FastEthernet0/10                         
!
interface FastEthernet0/11                         
!
interface FastEthernet0/12                         
!
interface FastEthernet0/13                         
!
interface FastEther                
!
interface FastEthernet0/15                         
!
interface FastEthernet0/16                         
!
interface FastEthernet0/17                         
!
interface FastEthernet0/18                         
!
interface FastEthernet0/19                         
!
interface FastEthernet0/20                         
!
interface FastEthernet0/21                         
!
interface FastEthernet0/22                         
!
interface FastEthernet0/23                         
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
ip address 192.168.16.49 255.255.0.0
no ip route-cache
shutdown
!
ip http server
!
control-plane
!
!
line con 0
line vty 5 15
!
end 

Re: Help setting up Cisco Network Assistant

robmccam1 Tue, 03/30/2010 - 15:24
User Badges:

All you need to do is type


R507>enable

R507#config t

R507(config)#interface vlan 1

R507(config-int)#no shutdown

R507(config-int)#exit

R507(config)#exit

R507#write mem


The interface for VLAN1 is turned off.

Actions

This Discussion