PTMServer Issue

Unanswered Question
Mar 29th, 2010
User Badges:

Hi Everyone,


I'm getting the error message below when I click on "Polling and Threshold":


"Could not retrieve data since the PTMServer process is down. Please restart the process and perform this operation again".


I have already restarted the process under CS>Server>Processes, restarted Daemon Manager, and even restarted the whole server but I still get the same message. I noticed that the status is "Program started-no mngt msg" which I think is not the desired status, instead it should be "Running Normally".


Anyone who has idea on this?


Thanks.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Joe Clarke Mon, 03/29/2010 - 22:19
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

Exactly what version of DFM is running on this server?

mylacapanzana Fri, 04/02/2010 - 05:41
User Badges:

Yes that is actually my plan as well. I am just hoping if there is other workaround.


Thanks.

mylacapanzana Tue, 04/06/2010 - 01:00
User Badges:

Actually I have already restarted the daemon manager but we have same problem.


Thanks again.

Joe Clarke Tue, 04/06/2010 - 09:30
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

Restarting Daemon Manager won't help.  You need to stop, and keep stopped the DfmServer and DfmServer1 processes.  Right after starting Daemon Manager, do:


pdterm DfmServer DfmServer1


As long as they are down, the server should remain stable, but nothing in DFM will work.

mylacapanzana Tue, 04/06/2010 - 18:47
User Badges:

but polling and threshold is under DFM right? why will i stop DFMServer then?

Joe Clarke Tue, 04/06/2010 - 18:54
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

The solution is to upgrade to DFM 3.0.5.  That is the ONLY solution.  If you do not want to do that, your only other recourse is to stop DFM.  That will restore overall server stability, but it will mean you can no longer use DFM.


--


Please support CSC Helps Haiti


https://supportforums.cisco.com/docs/DOC-8895

https://supportforums.cisco.com

mylacapanzana Sat, 04/10/2010 - 21:08
User Badges:

Okay. Thanks. I think I will consider uograding DFM.


Thanks a lot.

leonardomachado Wed, 01/30/2013 - 03:13
User Badges:

I am using LMS 4.2 and still have the same problem



Monitor > Threshold Settings > Fault > Threshold Settings



Could not retrieve current data since the PTMServer process is down.

Please restart the process and perform this operation again.



PTMServer log shows (every 2 seconds!!)


30/Jan/2013 09:13:45:607 ERROR main com.cisco.nm.xms.ctm.client.CTMClientProxy getProxy  - URN_NOT_FOUND : urn "ogs_server_urn" : Not found !!

a.ulanicki Tue, 05/21/2013 - 03:45
User Badges:

Same with LMS 4.0 and 4.0.1 (Windows2008 Standard 64bit). It's a common problem, but is there any working fix for this?

anis_cisco Wed, 02/19/2014 - 12:44
User Badges:

Did any one fixed this issue ?


We are facing same.


Regards,

Vinod Arya Wed, 02/19/2014 - 17:15
User Badges:
  • Cisco Employee,

Anis,


You are responding to a 3-4 year old thread. You should start a new discussion to get help. share details with screenshot of error, what LMS version you have etc.


-Thanks

Vinod

anis_cisco Wed, 02/19/2014 - 21:12
User Badges:

Hi Vinod


We have LMS 4.2

Following are the screen shot


Regards,


image001.jpg

image002.jpg

a.ulanicki Wed, 02/19/2014 - 22:57
User Badges:

Hi,


For LMS 4.0.1 probelm was resolved by contacting Cisco TAC - one file was rolled out (PortDetailsXml.class in  CSCOpx\campus\lib\classpath\com\cisco\nm\ani\server\core).


Regards

Vinod Arya Thu, 02/20/2014 - 00:41
User Badges:
  • Cisco Employee,

Not sure how your issue got resolved with removing that file. It is not related to Fault management module of LMS in any way. It is created with Data collecttion process and helps in topology and end host collection.


Most of the time PTMServer issues are with the misconfigured notification or polling and threshold parameters which are hard to find.


Majorly the action taken is to re-initialize the DB for fault management portion. It does not have much data to loose, but it has notification custom templates which will be lost, along with 31 days of fault history.


In case you want to proceed with DB re-initialize, you can follow this :


1.       Stop the daemon manager : net stop crmdmgtd (win)| /etc/init.d/dmgtd stop (unix/lnx)


2.       Issue the following commands :


NMSROOT\bin\perl.exe NMSROOT\bin\dbRestoreOrig.pl dsn=dfmInv dmprefix=INV

NMSROOT \bin\perl.exe NMSROOT\bin\dbRestoreOrig.pl dsn=dfmEpm dmprefix=EPM

NMSROOT \bin\perl.exe NMSROOT\bin\dbRestoreOrig.pl dsn=dfmFh dmprefix=FH


3.       Start daemon manager : net start crmdmgtd (win)| /etc/init.d/dmgtd start (unix/lnx)


Refer :

https://supportforums.cisco.com/docs/DOC-8796


If relectant to proceed with it for now, share the PTMServer.log for me to check if it has anything which can be worked upon.


-Thanks

Vinod

Actions

This Discussion

Related Content