Discrepancy message Link Duplex Mismatch

Unanswered Question
Mar 29th, 2010

I got a lot of Discrepancy messages that operation team said that are wrong messages. one of them is below :

[sc11601.stc.com.sa,FastEthernet7/1],[rc11601.stc.com.sa,FastEthernet12/0/1]

!
interface FastEthernet7/1
description P2P.RC11601.SC11601 -> RC11601 FE12/0/1
ip vrf forwarding COM/IS
ip address 172.20.2.62 255.255.255.252
ip accounting output-packets
ip ospf network point-to-point
speed 100
duplex full
wrr-queue bandwidth 70 30
wrr-queue queue-limit 60 20
wrr-queue cos-map 1 2 0 1
wrr-queue cos-map 2 2 2 3 6 7
mls qos trust dscp
end

--------------

SC11601#sh interfaces FastEthernet7/1
FastEthernet7/1 is up, line protocol is up (connected)
  Hardware is C6k 100Mb 802.3, address is 00d0.00ec.7400 (bia 00d0.00ec.7400)
  Description: P2P.RC11601.SC11601 -> RC11601 FE12/0/1
  Internet address is 172.20.2.62/30
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 98/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 100Mb/s
  input flow-control is off, output flow-control is unsupported
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:00, output 00:00:00, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/123 (size/max/drops/flushes); Total output drops: 62970
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 38682000 bits/sec, 18397 packets/sec
  5 minute output rate 179000 bits/sec, 166 packets/sec
  L2 Switched: ucast: 11975833 pkt, 1479635171 bytes - mcast: 14194902 pkt, 3811719114 bytes
  L3 in Switched: ucast: 429215085703 pkt, 94830171248319 bytes - mcast: 0 pkt, 0 bytes mcast
  L3 out Switched: ucast: 6824514014 pkt, 1288372109867 bytes mcast: 0 pkt, 0 bytes
     430025276460 packets input, 94920777016321 bytes, 0 no buffer
     Received 14799648 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 input packets with dribble condition detected
     7696316854 packets output, 1389443700164 bytes, 0 underruns
     0 output errors, 0 collisions, 2 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out
SC11601#

other interface:

interface FastEthernet12/0/1
description P2P.RC11601.SC11601
ip vrf forwarding COM/IS
ip address 172.20.2.61 255.255.255.252
no ip directed-broadcast
ip accounting output-packets
ip route-cache flow
ip ospf network point-to-point
load-interval 30
full-duplex
service-policy input Set-Experimental-COM/IS
service-policy output HSBB-Policy
end

RC11601#sh interfaces FastEthernet12/0/1
FastEthernet12/0/1 is up, line protocol is up
  Hardware is cyBus FastEthernet Interface, address is 0010.0d59.0981 (bia 0010.0d59.0981)
  Description: P2P.RC11601.SC11601
  Internet address is 172.20.2.61/30
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec, rely 255/255, load 85/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 100Mb/s, 100BaseTX/FX
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:00, output 00:00:00, output hang never
  Last clearing of "show interface" counters 2w6d
  Input queue: 0/75/6/0 (size/max/drops/flushes); Total output drops: 238552
  Queueing strategy: VIP-based fair queuing
  30 second input rate 167000 bits/sec, 148 packets/sec
  30 second output rate 33621000 bits/sec, 17158 packets/sec
     266182338 packets input, 34247141843 bytes, 0 no buffer
     Received 693431 broadcasts, 0 runts, 0 giants, 1 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog, 0 multicast
     0 input packets with dribble condition detected
     27319889810 packets output, 6807897544306 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Michel Hegeraat Tue, 03/30/2010 - 11:58

The speed 100 is missing from the second interface

Theoretically that interface could negotiate between 10 and 100 mbit.

Fix both at 100 FD  (my view) or put both in auto (cisco's view)

Cheers,

Michel

albatli1977 Tue, 03/30/2010 - 22:36

Please find below the sh verison of two devices:

SC11601#sh ver
Cisco Internetwork Operating System Software
IOS (tm) s72033_rp Software (s72033_rp-JK9O3SV-M), Version 12.2(17d)SXB,  RELEASE SOFTWARE (fc2)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2004 by cisco Systems, Inc.
Compiled Fri 05-Mar-04 04:59 by hqluong
Image text-base: 0x40020FBC, data-base: 0x42300000

ROM: System Bootstrap, Version 12.2(14r)S9, RELEASE SOFTWARE (fc1)
BOOTLDR: s72033_rp Software (s72033_rp-JK9O3SV-M), Version 12.2(17d)SXB,  RELEASE SOFTWARE (fc2)

SC11601 uptime is 1 year, 7 weeks, 4 days, 21 hours, 7 minutes
Time since SC11601 switched to active is 1 year, 7 weeks, 4 days, 21 hours, 9 minutes
System returned to ROM by power-on (SP by power-on)
System restarted at 11:23:10 KSA Thu Feb 5 2009
System image file is "sup-bootflash:s72033-jk9o3sv-mz.122-17d.SXB.bin"


This product contains cryptographic features and is subject to United
States and local country laws governing import, export, transfer and
use. Delivery of Cisco cryptographic products does not imply
third-party authority to import, export, distribute or use encryption.
Importers, exporters, distributors and users are responsible for
compliance with U.S. and local country laws. By using this product you
agree to comply with applicable laws and regulations. If you are unable
to comply with U.S. and local laws, return this product immediately.

A summary of U.S. laws governing Cisco cryptographic products may be found at:
http://www.cisco.com/wwl/export/crypto/tool/stqrg.html

If you require further assistance please contact us by sending email to
[email protected].

cisco WS-C6509 (R7000) processor (revision 2.0) with 458752K/65536K bytes of memory.
Processor board ID SCA041008ZF
SR71000 CPU at 600Mhz, Implementation 0x504, Rev 1.2, 512KB L2 Cache
Last reset from power-on
Bridging software.
X.25 software, Version 3.0.0.
SuperLAT software (copyright 1990 by Meridian Technology Corp).
TN3270 Emulation software.
121 Virtual Ethernet/IEEE 802.3  interface(s)
48 FastEthernet/IEEE 802.3 interface(s)
52 Gigabit Ethernet/IEEE 802.3 interface(s)
1917K bytes of non-volatile configuration memory.
8192K bytes of packet buffer memory.

65536K bytes of Flash internal SIMM (Sector size 512K).
Standby is up
Standby has 458752K/65536K bytes of memory.

Configuration register is 0x2102

SC11601#

---------------------------------------

RC11601#sh ver
Cisco Internetwork Operating System Software
IOS (tm) RSP Software (RSP-PV-M), Version 12.0(28)S3, RELEASE SOFTWARE (fc1)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2005 by cisco Systems, Inc.
Compiled Tue 19-Apr-05 15:59 by kellythw
Image text-base: 0x4001106C, data-base: 0x413C2000

ROM: System Bootstrap, Version 12.0(10r)S1, RELEASE SOFTWARE (fc1)
BOOTLDR: RSP Software (RSP-PV-M), Version 12.0(28)S3, RELEASE SOFTWARE (fc1)

RC11601 uptime is 1 year, 7 weeks, 4 days, 19 hours, 50 minutes
Uptime for this control processor is 1 year, 7 weeks, 4 days, 19 hours, 44 minutes
System returned to ROM by reload at 12:43:07 wat Thu Feb 5 2009
System restarted at 12:44:52 KSA Thu Feb 5 2009
System image file is "slot0:rsp-pv-mz.120-28.S3.bin"

cisco RSP8 (R7000) processor with 262144K/8216K bytes of memory.
R7000 CPU at 250Mhz, Implementation 39, Rev 2.1, 256KB L2, 2048KB L3 Cache
Last reset from power-on
G.703/E1 software, Version 1.0.
G.703/JT2 software, Version 1.0.
Channelized E1, Version 1.0.
X.25 software, Version 3.0.0.
Primary Rate ISDN software, Version 1.1.
Chassis Interface.
4 FSIP controllers (32 Serial).
5 VIP6-80 RM7000B controllers (6 FastEthernet)(24 E1)(3 POS).
1 VIP4-80 RM7000 controller (1 GigabitEthernet)(0 E1).
6 FastEthernet/IEEE 802.3 interface(s)
1 GigabitEthernet/IEEE 802.3 interface(s)
56 Serial network interface(s)
3 Packet over SONET network interface(s)
2043K bytes of non-volatile configuration memory.

32768K bytes of Flash PCMCIA card at slot 0 (Sector size 128K).
16384K bytes of Flash internal SIMM (Sector size 256K).
No slave installed in slot 7.
Configuration register is 0x2102

RC11601#

albatli1977 Fri, 04/02/2010 - 21:27

Please find below the output of snmpwalk and ifindex of FastEthernet12/0/1 is 65

momsrv02:/ # snmpwalk rc11601 1.3.6.1.2.1.10.7.2.1.19
transmission.dot3.dot3StatsTable.dot3StatsEntry.dot3StatsDuplexStatus.1 : INTEGER: unknown
transmission.dot3.dot3StatsTable.dot3StatsEntry.dot3StatsDuplexStatus.34 : INTEGER: halfDuplex
transmission.dot3.dot3StatsTable.dot3StatsEntry.dot3StatsDuplexStatus.35 : INTEGER: halfDuplex
transmission.dot3.dot3StatsTable.dot3StatsEntry.dot3StatsDuplexStatus.44 : INTEGER: halfDuplex
transmission.dot3.dot3StatsTable.dot3StatsEntry.dot3StatsDuplexStatus.45 : INTEGER: halfDuplex
transmission.dot3.dot3StatsTable.dot3StatsEntry.dot3StatsDuplexStatus.64 : INTEGER: halfDuplex
transmission.dot3.dot3StatsTable.dot3StatsEntry.dot3StatsDuplexStatus.65 : INTEGER: halfDuplex

momsrv02:/ #

Joe Clarke Sat, 04/03/2010 - 11:38

Post the SNMP Walk of ifDescr.  It looks as though either the router is reporting the wrong value (i.e. half-duplex instead of full), or the router is reporting an unknown duplex value.  In either case, the problem lies with the device as opposed to Campus.  I have a 7507 running 12.3(20a), and it is reporting a proper duplex for one of its GigabitEthernet interfaces.

--

Please support CSC Helps Haiti

https://supportforums.cisco.com/docs/DOC-8895

https://supportforums.cisco.com

albatli1977 Mon, 04/05/2010 - 00:57

momsrv02:/ # snmpwalk rc11601 1.3.6.1.2.1.2.2.1.2
interfaces.ifTable.ifEntry.ifDescr.1 : DISPLAY STRING- (ascii):  GigabitEthernet1/0/0
interfaces.ifTable.ifEntry.ifDescr.2 : DISPLAY STRING- (ascii):  Serial2/0
interfaces.ifTable.ifEntry.ifDescr.3 : DISPLAY STRING- (ascii):  Serial2/1
interfaces.ifTable.ifEntry.ifDescr.4 : DISPLAY STRING- (ascii):  Serial2/2
interfaces.ifTable.ifEntry.ifDescr.5 : DISPLAY STRING- (ascii):  Serial2/3
interfaces.ifTable.ifEntry.ifDescr.6 : DISPLAY STRING- (ascii):  Serial2/4
interfaces.ifTable.ifEntry.ifDescr.7 : DISPLAY STRING- (ascii):  Serial2/5
interfaces.ifTable.ifEntry.ifDescr.8 : DISPLAY STRING- (ascii):  Serial2/6
interfaces.ifTable.ifEntry.ifDescr.9 : DISPLAY STRING- (ascii):  Serial2/7
interfaces.ifTable.ifEntry.ifDescr.10 : DISPLAY STRING- (ascii):  Serial3/0
interfaces.ifTable.ifEntry.ifDescr.11 : DISPLAY STRING- (ascii):  Serial3/1
interfaces.ifTable.ifEntry.ifDescr.12 : DISPLAY STRING- (ascii):  Serial3/2
interfaces.ifTable.ifEntry.ifDescr.13 : DISPLAY STRING- (ascii):  Serial3/3
interfaces.ifTable.ifEntry.ifDescr.14 : DISPLAY STRING- (ascii):  Serial3/4
interfaces.ifTable.ifEntry.ifDescr.15 : DISPLAY STRING- (ascii):  Serial3/5
interfaces.ifTable.ifEntry.ifDescr.16 : DISPLAY STRING- (ascii):  Serial3/6
interfaces.ifTable.ifEntry.ifDescr.17 : DISPLAY STRING- (ascii):  Serial3/7
interfaces.ifTable.ifEntry.ifDescr.18 : DISPLAY STRING- (ascii):  Serial4/0
interfaces.ifTable.ifEntry.ifDescr.19 : DISPLAY STRING- (ascii):  Serial4/1
interfaces.ifTable.ifEntry.ifDescr.20 : DISPLAY STRING- (ascii):  Serial4/2
interfaces.ifTable.ifEntry.ifDescr.21 : DISPLAY STRING- (ascii):  Serial4/3
interfaces.ifTable.ifEntry.ifDescr.22 : DISPLAY STRING- (ascii):  Serial4/4
interfaces.ifTable.ifEntry.ifDescr.23 : DISPLAY STRING- (ascii):  Serial4/5
interfaces.ifTable.ifEntry.ifDescr.24 : DISPLAY STRING- (ascii):  Serial4/6
interfaces.ifTable.ifEntry.ifDescr.25 : DISPLAY STRING- (ascii):  Serial4/7
interfaces.ifTable.ifEntry.ifDescr.26 : DISPLAY STRING- (ascii):  Serial5/0
interfaces.ifTable.ifEntry.ifDescr.27 : DISPLAY STRING- (ascii):  Serial5/1
interfaces.ifTable.ifEntry.ifDescr.28 : DISPLAY STRING- (ascii):  Serial5/2
interfaces.ifTable.ifEntry.ifDescr.29 : DISPLAY STRING- (ascii):  Serial5/3
interfaces.ifTable.ifEntry.ifDescr.30 : DISPLAY STRING- (ascii):  Serial5/4
interfaces.ifTable.ifEntry.ifDescr.31 : DISPLAY STRING- (ascii):  Serial5/5
interfaces.ifTable.ifEntry.ifDescr.32 : DISPLAY STRING- (ascii):  Serial5/6
interfaces.ifTable.ifEntry.ifDescr.33 : DISPLAY STRING- (ascii):  Serial5/7
interfaces.ifTable.ifEntry.ifDescr.34 : DISPLAY STRING- (ascii):  FastEthernet8/0/0
interfaces.ifTable.ifEntry.ifDescr.35 : DISPLAY STRING- (ascii):  FastEthernet8/0/1
interfaces.ifTable.ifEntry.ifDescr.36 : DISPLAY STRING- (ascii):  E1 8/1/0
interfaces.ifTable.ifEntry.ifDescr.37 : DISPLAY STRING- (ascii):  E1 8/1/1
interfaces.ifTable.ifEntry.ifDescr.38 : DISPLAY STRING- (ascii):  E1 8/1/2
interfaces.ifTable.ifEntry.ifDescr.39 : DISPLAY STRING- (ascii):  E1 8/1/3
interfaces.ifTable.ifEntry.ifDescr.40 : DISPLAY STRING- (ascii):  E1 8/1/4
interfaces.ifTable.ifEntry.ifDescr.41 : DISPLAY STRING- (ascii):  E1 8/1/5
interfaces.ifTable.ifEntry.ifDescr.42 : DISPLAY STRING- (ascii):  E1 8/1/6
interfaces.ifTable.ifEntry.ifDescr.43 : DISPLAY STRING- (ascii):  E1 8/1/7
interfaces.ifTable.ifEntry.ifDescr.44 : DISPLAY STRING- (ascii):  FastEthernet9/0/0
interfaces.ifTable.ifEntry.ifDescr.45 : DISPLAY STRING- (ascii):  FastEthernet9/0/1
interfaces.ifTable.ifEntry.ifDescr.46 : DISPLAY STRING- (ascii):  POS9/1/0
interfaces.ifTable.ifEntry.ifDescr.47 : DISPLAY STRING- (ascii):  E1 10/0/0
interfaces.ifTable.ifEntry.ifDescr.48 : DISPLAY STRING- (ascii):  E1 10/0/1
interfaces.ifTable.ifEntry.ifDescr.49 : DISPLAY STRING- (ascii):  E1 10/0/2
interfaces.ifTable.ifEntry.ifDescr.50 : DISPLAY STRING- (ascii):  E1 10/0/3
interfaces.ifTable.ifEntry.ifDescr.51 : DISPLAY STRING- (ascii):  E1 10/0/4
interfaces.ifTable.ifEntry.ifDescr.52 : DISPLAY STRING- (ascii):  E1 10/0/5
interfaces.ifTable.ifEntry.ifDescr.53 : DISPLAY STRING- (ascii):  E1 10/0/6
interfaces.ifTable.ifEntry.ifDescr.54 : DISPLAY STRING- (ascii):  E1 10/0/7
interfaces.ifTable.ifEntry.ifDescr.55 : DISPLAY STRING- (ascii):  POS10/1/0
interfaces.ifTable.ifEntry.ifDescr.56 : DISPLAY STRING- (ascii):  E1 11/1/0
interfaces.ifTable.ifEntry.ifDescr.57 : DISPLAY STRING- (ascii):  E1 11/1/1
interfaces.ifTable.ifEntry.ifDescr.58 : DISPLAY STRING- (ascii):  E1 11/1/2
interfaces.ifTable.ifEntry.ifDescr.59 : DISPLAY STRING- (ascii):  E1 11/1/3
interfaces.ifTable.ifEntry.ifDescr.60 : DISPLAY STRING- (ascii):  E1 11/1/4
interfaces.ifTable.ifEntry.ifDescr.61 : DISPLAY STRING- (ascii):  E1 11/1/5
interfaces.ifTable.ifEntry.ifDescr.62 : DISPLAY STRING- (ascii):  E1 11/1/6
interfaces.ifTable.ifEntry.ifDescr.63 : DISPLAY STRING- (ascii):  E1 11/1/7
interfaces.ifTable.ifEntry.ifDescr.64 : DISPLAY STRING- (ascii):  FastEthernet12/0/0
interfaces.ifTable.ifEntry.ifDescr.65 : DISPLAY STRING- (ascii):  FastEthernet12/0/1
interfaces.ifTable.ifEntry.ifDescr.66 : DISPLAY STRING- (ascii):  POS12/1/0
interfaces.ifTable.ifEntry.ifDescr.67 : DISPLAY STRING- (ascii):  Null0
interfaces.ifTable.ifEntry.ifDescr.68 : DISPLAY STRING- (ascii):  Loopback1
interfaces.ifTable.ifEntry.ifDescr.69 : DISPLAY STRING- (ascii):  Serial8/1/0:0
interfaces.ifTable.ifEntry.ifDescr.70 : DISPLAY STRING- (ascii):  Serial8/1/1:0
interfaces.ifTable.ifEntry.ifDescr.71 : DISPLAY STRING- (ascii):  Serial8/1/2:0
interfaces.ifTable.ifEntry.ifDescr.72 : DISPLAY STRING- (ascii):  Serial8/1/3:0
interfaces.ifTable.ifEntry.ifDescr.73 : DISPLAY STRING- (ascii):  Serial8/1/4:0
interfaces.ifTable.ifEntry.ifDescr.74 : DISPLAY STRING- (ascii):  Serial8/1/5:0
interfaces.ifTable.ifEntry.ifDescr.75 : DISPLAY STRING- (ascii):  Serial8/1/6:0
interfaces.ifTable.ifEntry.ifDescr.76 : DISPLAY STRING- (ascii):  Serial8/1/7:0
interfaces.ifTable.ifEntry.ifDescr.77 : DISPLAY STRING- (ascii):  Serial10/0/0:0
interfaces.ifTable.ifEntry.ifDescr.78 : DISPLAY STRING- (ascii):  Serial10/0/1:0
interfaces.ifTable.ifEntry.ifDescr.79 : DISPLAY STRING- (ascii):  Serial10/0/2:0
interfaces.ifTable.ifEntry.ifDescr.80 : DISPLAY STRING- (ascii):  Serial10/0/3:0
interfaces.ifTable.ifEntry.ifDescr.81 : DISPLAY STRING- (ascii):  Serial10/0/4:0
interfaces.ifTable.ifEntry.ifDescr.82 : DISPLAY STRING- (ascii):  Serial10/0/5:0
interfaces.ifTable.ifEntry.ifDescr.83 : DISPLAY STRING- (ascii):  Serial10/0/6:0
interfaces.ifTable.ifEntry.ifDescr.84 : DISPLAY STRING- (ascii):  Serial10/0/7:0
interfaces.ifTable.ifEntry.ifDescr.85 : DISPLAY STRING- (ascii):  Serial11/1/0:0
interfaces.ifTable.ifEntry.ifDescr.86 : DISPLAY STRING- (ascii):  Serial11/1/1:0
interfaces.ifTable.ifEntry.ifDescr.87 : DISPLAY STRING- (ascii):  Serial11/1/2:0
interfaces.ifTable.ifEntry.ifDescr.88 : DISPLAY STRING- (ascii):  Serial11/1/3:0
interfaces.ifTable.ifEntry.ifDescr.89 : DISPLAY STRING- (ascii):  Serial11/1/4:0
interfaces.ifTable.ifEntry.ifDescr.90 : DISPLAY STRING- (ascii):  Serial11/1/5:0
interfaces.ifTable.ifEntry.ifDescr.91 : DISPLAY STRING- (ascii):  Serial11/1/6:0
interfaces.ifTable.ifEntry.ifDescr.92 : DISPLAY STRING- (ascii):  Serial11/1/7:0
interfaces.ifTable.ifEntry.ifDescr.93 : DISPLAY STRING- (ascii):  Loopback0
interfaces.ifTable.ifEntry.ifDescr.94 : DISPLAY STRING- (ascii):  GigabitEthernet1/0/0-mpls layer
interfaces.ifTable.ifEntry.ifDescr.95 : DISPLAY STRING- (ascii):  POS9/1/0-mpls layer
momsrv02:/ #

Actions

This Discussion