incoming Qos for Dialer interface

Answered Question
Mar 30th, 2010
User Badges:

Hello,


i have an cisco 1802 with IOS 12.4(15)T12.


i configured CBWFQ for the outgoing direction of the dialer 0 interface and everything works fine.


but i have also a problem with too much traffic coming in on dialer 0 so i tried to configure a policing for http downlods, but it doesn't work.

the configuration looks like that:


class-map match-any QOS_HTTP_IN
match access-group name QOS_HTTP_IN


policy-map QOS_DSL_IN
class QOS_HTTP_IN
police 2048000
class class-default


interface Dialer0
description $internet connection over ADSL$
bandwidth 123
bandwidth receive 1234
ip address negotiated
ip mtu 1452
ip nat outside
ip virtual-reassembly
zone-member security out-zone
encapsulation ppp
dialer pool 1
dialer-group 1
no cdp enable
ppp authentication pap callin
ppp pap sent-username ....
max-reserved-bandwidth 99
service-policy input QOS_DSL_IN
service-policy output QOS_DSL_OUT


Router#show policy-map int dialer 0 input
Dialer0


  Service-policy input: QOS_DSL_IN


    Class-map: QOS_HTTP_IN (match-any)
      0 packets, 0 bytes
      5 minute offered rate 0 bps, drop rate 0 bps
      Match: access-group name QOS_HTTP_IN
        0 packets, 0 bytes
        5 minute rate 0 bps
      police:
          cir 2048000 bps, bc 64000 bytes
        conformed 0 packets, 0 bytes; actions:
          transmit
        exceeded 0 packets, 0 bytes; actions:
          drop
        conformed 0 bps, exceed 0 bps


    Class-map: class-default (match-any)
      100 packets, 4000 bytes
      5 minute offered rate 0 bps, drop rate 0 bps
      Match: any


and as you see there are just "100" packets seen on the incoming direction and i cleared the counters 30 minutes ago, so there must be several thousand packets for class-default.


i looked in several documentations, even in the QOS 2.3 stundent guide.


The "Cisco IOS Quality of Service Solutions Configuration Guide, Release 12.4" writes under "Using Multilink PPP over Dialer Interface Links"  a sample configuration which contains a service-policy input command on an dialer interface, so i think this should be supported??


Another idea was to put this service-policy input to the Fastethernet 0 interface, where the ADSL modem is connected, but the service-policy also only matches some packets, this could be because PPPoE is no IP and therefore isn't seen.


My last idea is to put it in the vlan interface as incoming, but i think this is not the right place for a Qos policy...


any ideas how i can handle this?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 3.5 (4 ratings)
Loading.
Correct Answer

The last time I checked - you cannot apply a QoS policy on an inbound WAN interface. Just because the IOS give you the option - does not mean it will work.


If you have to much traffic coming from another site - then apply the QoS policy on the ISDN outbound direction from that site..


HTH>

Andrew

DialerString_2 Tue, 03/30/2010 - 09:35
User Badges:
  • Bronze, 100 points or more

You may be able to class the bandwidth going outbound

on the LAN interface.

rafael_rung Tue, 03/30/2010 - 11:57
User Badges:


Hey, Thank you for the quick answers.


@AndrewPrince: well your right not everything works that is avaliable within the IOS. but this doe's i updatet to IOS 15.1.1 and it works.
i now have several other things that don't work any more(firewall rules and so on), but the input policing for the dialer interface works. i didn't get it to work with an access-list, but it works with nbar classification.


to put the Qos policy in the outside direction on the other side isn't possible as i have no access to my isp's routers


@dialerstring: thanks for the hint but it didn't work because of two things:
1. the port has just a Layer2 configuration (is accessible via the vlan interface)
2. i need one policer for all incoming http traffic, if i do it on the port i have 8 policers

DialerString_2 Tue, 03/30/2010 - 12:46
User Badges:
  • Bronze, 100 points or more

Sorry I couldn't help but let us know what you decide in end!

rafael_rung Wed, 03/31/2010 - 01:38
User Badges:

@DialerString: i just did that if you look the post above.

rafael_rung Wed, 03/31/2010 - 01:42
User Badges:

@Andrew Prince: As mentioned above i'm using a cisco 1802 router.

Actions

This Discussion

Related Content