PHONES NOT downloading firmware or REGISTERING IN CALL Manager express

Answered Question
Mar 30th, 2010

I reset a 7941 phone with the factory default sequence keys * 123456789*0# now it will not register or even show activity of downloading firmware.  Any ideas on what i should be looking at?

I have this problem too.
0 votes
Correct Answer by Aaron Harrison about 6 years 8 months ago

Hi

You have the compressed .tar of the 7941 firmware on your flash.

This needs extracting, and serving up via TFTP.

Use:

Archive tar /xtract flash:cmterm-7941_7961-sccp.8-2-2SR1.tar flash:

This will extract several files. Note the names of each file, then enable them to be served like so:

Tftp-server flash:cmterm41.default.loads

You will need one command for each file, and if any are missed it will not work.

When it's done, you can do 'debug tftp-server events' to see if files are being attempted that are not found.

Aaron

Please rate helpful posts...

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
abwurtele Tue, 03/30/2010 - 18:06

Hello,

Can you please post your config?  Make sure that after you do a factory reset on a phone, that you are using DHCP and you have option 150 defined.  Also verify you have the load files in flash, you have the tftp server defined as well as you have the load defined for that phone under the CME config.  Are you using SIP or SCCP?  For Example:

tftp-server flash:P00308000400.bin
tftp-server flash:P00308000400.loads
tftp-server flash:P00308000400.sb2

For SCCP:

telephony-service
load 7960-7940 P00308000400

For SIP:

voice register global

load 7960-7940 P00308000400
tftp-path flash:

ip dhcp pool ITS
   network 10.3.82.0 255.255.255.0
   option 150 ip 10.3.82.2
   default-router 10.3.82.2

Anthony

babatunde_sanda Fri, 04/02/2010 - 13:56

Sorry it took a while.  Below is the config.  I went ahead and plugged another phone from my CUCM cluster in the location and that worked.  But I didn't reset it though.  Will try that later.

clock timezone pst -8
clock summer-time PDT recurring
no ip dhcp use vrf connected
ip dhcp excluded-address 172.16.100.1 172.16.100.149
ip dhcp excluded-address 172.16.100.201 172.16.100.254
ip dhcp excluded-address 172.16.101.1 172.16.101.149
ip dhcp excluded-address 172.16.101.201 172.16.101.254
ip dhcp excluded-address 172.16.106.1 172.16.106.149
ip dhcp excluded-address 172.16.106.201 172.16.106.254
ip dhcp excluded-address 172.16.110.1
ip dhcp excluded-address 172.16.110.252 172.16.110.254
ip dhcp excluded-address 172.16.111.1
ip dhcp excluded-address 172.16.111.253 172.116.111.254
!
ip dhcp pool LAN_Data
   network 172.16.100.0 255.255.255.0
   default-router 172.16.100.1

ip dhcp pool Voice
   network 172.16.106.0 255.255.255.0
   default-router 172.16.106.1
   option 150 ip 172.16.253.254

interface GigabitEthernet1/0.20
description - Voice Vlan Sub Interface
encapsulation dot1Q 20
ip address 172.16.106.1 255.255.255.0

!
interface GigabitEthernet1/0.100
description Data Vlan Sub Interface
encapsulation dot1Q 100
ip address 172.16.100.1 255.255.255.0


!
!
voice service voip
allow-connections h323 to h323
allow-connections h323 to sip
allow-connections sip to h323
allow-connections sip to sip
supplementary-service h450.12
no supplementary-service sip moved-temporarily
no supplementary-service sip refer
redirect ip2ip
h323
sip
  registrar server expires max 3600 min 3600
  redirect contact order best-match
  no call service stop

voice class codec 1
codec preference 1 g711ulaw
!
voice register global
max-dn 500
max-pool 336
!


!
interface Loopback0
description - CCME / H323-Gateway
ip address 172.16.253.254 255.255.255.0
h323-gateway voip interface
h323-gateway voip bind srcaddr 172.16.253.254
!


tftp-server flash:P00405000700.sbn
tftp-server flash:P00405000700.bin


!
telephony-service
video
load 7960-7940 P00308000400
load 7941 P00405000700
max-ephones 20
max-dn 50
ip source-address 172.16.253.254 port 2000
service phone videoCapability 1
system message Irvine PD Mobile Comm
time-zone 5
dialplan-pattern 1 94933622.. extension-length 4
keepalive 45
voicemail 8000
max-conferences 12 gain -6
moh music-on-hold.au
dn-webedit
time-webedit
transfer-system full-consult
transfer-pattern 9.T blind
secondary-dialtone 9
create cnf-files version-stamp 7960 Apr 01 2010 13:12:54
!


------------------ show flash: all ------------------

-#- --length-- -----date/time------ path
1     51286900 Dec 17 2007 05:22:04 -08:00 c3825-advipservicesk9-mz.124-15.T1.bin
2         1826 Dec 3 2007 12:01:14 -08:00 sdmconfig-38xx.cfg
3      6036480 Dec 3 2007 12:01:36 -08:00 sdm.tar
4       861696 Dec 3 2007 12:01:46 -08:00 es.tar
5      1164288 Dec 3 2007 12:02:02 -08:00 common.tar
6         1038 Dec 3 2007 12:02:12 -08:00 home.shtml
7       113152 Dec 3 2007 12:02:24 -08:00 home.tar
8      1697952 Dec 3 2007 12:02:36 -08:00 securedesktop-ios-3.1.1.45-k9.pkg
9       416354 Dec 3 2007 12:02:46 -08:00 sslclient-win-1.1.3.173.pkg
10      969728 Dec 7 2007 14:53:14 -08:00 P00308000400.tar
11      349794 Dec 7 2007 14:53:34 -08:00 P00405000700.bin
12      350198 Dec 7 2007 14:53:52 -08:00 P00405000700.sbn
13     1908762 Dec 7 2007 14:54:12 -08:00 P00503010100.bin
14      808960 Dec 7 2007 15:55:04 -08:00 cme-gui-4.1.0.1.tar
15      496521 Dec 7 2007 14:58:50 -08:00 music-on-hold.au
16      326144 Dec 7 2007 14:59:10 -08:00 ringtone.tar
17     5776896 Dec 7 2007 15:56:20 -08:00 cmterm-7941_7961-sccp.8-2-2SR1.tar
18      622592 Dec 7 2007 15:53:12 -08:00 7970-backgrounds.tar
19      113152 Dec 7 2007 15:53:58 -08:00 app-cme-did-2.0.0.0.tar
20      281506 Dec 7 2007 15:54:10 -08:00 ATA030100SCCP040211A.zup
21     1054720 Dec 7 2007 15:54:28 -08:00 cme-bacd-2.1.2.2.tar
22     5730816 Dec 7 2007 15:55:30 -08:00 cmterm-7911_7906-sccp.8-2-2SR1.tar
23     5723648 Dec 7 2007 15:55:52 -08:00 cmterm-7931-sccp.8-2-2SR1.tar
24     6266880 Dec 7 2007 15:56:42 -08:00 cmterm-7942_7962-sccp.8-3-2.tar
25     6381056 Dec 7 2007 15:57:04 -08:00 cmterm-7945_7965-sccp.8-3-2.tar
26     1723770 Dec 21 2007 09:43:12 -08:00 APPS-1.0.5.SBN
27     1045952 Dec 7 2007 15:57:54 -08:00 cmterm_7920.4.0-02-00.bin
28     1706643 Dec 7 2007 15:58:12 -08:00 cmterm_7936.3-3-5-0.bin
29     1755410 Dec 7 2007 15:58:28 -08:00 cmterm_7936.3-3-12-0.bin
30     9625600 Dec 7 2007 16:01:52 -08:00 CP7921G-1.0.1.tar
31      331483 Dec 7 2007 16:24:20 -08:00 CP7902080001SCCP051117A.sbin
32      338840 Dec 7 2007 16:24:44 -08:00 CP7905080001SCCP051117A.sbin
33      338424 Dec 7 2007 16:24:56 -08:00 CP7905080001SCCP051117A.zup
34      340631 Dec 7 2007 16:25:40 -08:00 CP7912080001SCCP051117A.sbin
35       49169 Dec 7 2007 16:26:10 -08:00 S00104000100.sbn
36       49599 Dec 7 2007 16:26:24 -08:00 S00105000200.sbn
37         660 Dec 11 2007 14:01:04 -08:00 vlan.dat
38        4627 Dec 17 2007 14:36:16 -08:00 admin_user.html
39      653758 Dec 17 2007 14:36:18 -08:00 admin_user.js
40        1029 Dec 17 2007 14:36:18 -08:00 CiscoLogo.gif
41         618 Dec 17 2007 14:36:18 -08:00 CME_GUI_README.TXT
42         953 Dec 17 2007 14:36:18 -08:00 Delete.gif
43       16344 Dec 17 2007 14:36:18 -08:00 dom.js
44         864 Dec 17 2007 14:36:20 -08:00 downarrow.gif
45        6146 Dec 17 2007 14:36:20 -08:00 ephone_admin.html
46        4658 Dec 17 2007 14:36:20 -08:00 logohome.gif
47        3724 Dec 17 2007 14:36:20 -08:00 normal_user.html
48       80033 Dec 17 2007 14:36:22 -08:00 normal_user.js
49        1347 Dec 17 2007 14:36:22 -08:00 Plus.gif
50         843 Dec 17 2007 14:36:22 -08:00 sxiconad.gif
51         174 Dec 17 2007 14:36:22 -08:00 Tab.gif
52        2410 Dec 17 2007 14:36:24 -08:00 telephony_service.html
53         870 Dec 17 2007 14:36:24 -08:00 uparrow.gif
54        9968 Dec 17 2007 14:36:24 -08:00 xml-test.html
55        3412 Dec 17 2007 14:36:24 -08:00 xml.template
56     1309153 Dec 21 2007 09:22:00 -08:00 WLAN-1.0.5.SBN
57     2196478 Dec 21 2007 09:22:48 -08:00 TNUXR-1.0.5.SBN
58      893981 Dec 21 2007 09:25:14 -08:00 TNUX-1.0.5.SBN
59     2078210 Dec 21 2007 09:26:02 -08:00 SYS-1.0.5.SBN
60         871 Dec 21 2007 09:27:24 -08:00 CP7921G-1.0.5.LOADS
61       16427 May 15 2008 16:33:34 -07:00 SDM_Backup
62       19946 Nov 3 2009 14:05:44 -08:00 good-startup-config
63       20000 Nov 3 2009 14:06:26 -08:00 new-running-config

Correct Answer
Aaron Harrison Sat, 04/03/2010 - 01:55

Hi

You have the compressed .tar of the 7941 firmware on your flash.

This needs extracting, and serving up via TFTP.

Use:

Archive tar /xtract flash:cmterm-7941_7961-sccp.8-2-2SR1.tar flash:

This will extract several files. Note the names of each file, then enable them to be served like so:

Tftp-server flash:cmterm41.default.loads

You will need one command for each file, and if any are missed it will not work.

When it's done, you can do 'debug tftp-server events' to see if files are being attempted that are not found.

Aaron

Please rate helpful posts...

Actions

This Discussion