LMS2.6 EDS cannot connect to EDS Atom Service

Answered Question
Mar 30th, 2010

Hi,


Having problems restarting one of our CiscoWorks servers since doing a Microsoft Patching session last night. (I am not suggesting that this is the sole reason for this. It could be coincidence)


On our master server, which runs CS and RM, I cannot get the following services to run: CTMJrmServer, ChangeAudit, SyslogAnalyser, and the jrm service is always in the Waiting to initialise state.


Looking at the log files, I notice the following in the EDS.log (even though it says it is running normally).


[Wed Mar 31 16:16:03 NZST 2010] Manager initComplete
[Wed Mar 31 16:16:53 NZST 2010] Logger initComplete
[Wed Mar 31 16:16:53 NZST 2010] Compiler available
[Wed Mar 31 16:17:44 NZST 2010] Loader initComplete
[Wed Mar 31 16:18:37 NZST 2010] Atom initComplete
31 March 2010 16:18:56 EDS HP1813 Error EDSCL0002: Cannot connect to EDS class loader with error org.omg.CORBA.OBJECT_NOT_EXIST:
  Could not locate the following Object:
  repository id : IDL:loader/LoaderObject:1.0
    object name : EDSClassLoader
  minor code: 0  completed: No.
31 March 2010 16:19:29 EDS HP1813 Error EDSAT0001: Cannot connect to EDS Atom Service.
31 March 2010 16:19:45 EDS HP1813 Error EDSAT0001: Cannot connect to EDS Atom Service.
Error getting atom locale
31 March 2010 16:20:02 EDS HP1813 Error EDSAT0001: Cannot connect to EDS Atom Service.
31 March 2010 16:20:35 EDS HP1813 Error EDSAT0001: Cannot connect to EDS Atom Service.
Error getting atom locale
31 March 2010 16:20:52 EDS HP1813 Error EDSAT0001: Cannot connect to EDS Atom Service.
31 March 2010 16:21:08 EDS HP1813 Error EDSAT0001: Cannot connect to EDS Atom Service.
Error getting atom locale
[Wed Mar 31 16:22:14 NZST 2010] Factory initComplete
31 March 2010 16:22:14 EDS HP1813 Error EDSAT0001: Cannot connect to EDS Atom Service.
[Wed Mar 31 16:23:20 NZST 2010] Filter Repository initComplete
31 March 2010 16:23:20 EDS HP1813 Error EDSAT0001: Cannot connect to EDS Atom Service.
[Wed Mar 31 16:24:27 NZST 2010] Event Repository initComplete
31 March 2010 16:24:27 EDS HP1813 Error EDSAT0001: Cannot connect to EDS Atom Service.
31 March 2010 16:25:13 EDS HP1813 Error EDSAT0001: Cannot connect to EDS Atom Service.
31 March 2010 16:26:00 EDS HP1813 Error EDSAT0001: Cannot connect to EDS Atom Service.
31 March 2010 16:26:46 EDS HP1813 Error EDSAT0001: Cannot connect to EDS Atom Service.
31 March 2010 16:27:33 EDS HP1813 Error EDSAT0001: Cannot connect to EDS Atom Service.
31 March 2010 16:28:19 EDS HP1813 Error EDSAT0001: Cannot connect to EDS Atom Service.
31 March 2010 16:29:06 EDS HP1813 Error EDSAT0001: Cannot connect to EDS Atom Service.


I am hoping that a) this is the casue of my problems, and b) that it is easily fixed - providied I know how to!


Does anyone have any ideas on this?


Regards

Jeff

Correct Answer by Joe Clarke about 6 years 11 months ago

This is what I thought.  Your services are set to Automatic when they must be set to Manual.  Change the startup type for the following services back to Manual, then reboot:


CiscoWorks RME NG database engine

CiscoWorks Tomcat Servlet Engine

CiscoWorks VisiBroker Smart Agent

CiscoWorks Web Server

CWCS Cmf database engine


Typically, the Daemon Manager service is setup to Automatic and not Manual.  However, if you're okay with starting it manually, you can leave it how it is.


--


Please support CSC Helps Haiti


https://supportforums.cisco.com/docs/DOC-8895

https://supportforums.cisco.com

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Jeff Law Tue, 03/30/2010 - 22:08

Sorry, forgot to add that the following is appearing in the jrm.log, which is why I went looking at the EDS.log


[Wed Mar 31 17:04:35 NZST 2010] ERROR: CORBAREGISTRY:Unable to connect to ManagerControl object.  Reason: org.omg.CORBA.OBJECT_NOT_EXIST:
  Could not locate the following Object:
  repository id : IDL:manager/ManagerControl:1.0
    object name : ManagerControl
      host name : HP1813
  minor code: 0  completed: No
1270011875148 31 March 2010 17:04:35 jrm HP1813 Error EDSSY0012: Cannot connect to EDS.
org.omg.CORBA.OBJECT_NOT_EXIST:
  Could not locate the following Object:
  repository id : IDL:manager/ManagerControl:1.0
    object name : ManagerControl
      host name : HP1813
  minor code: 0  completed: No
at com.inprise.vbroker.orb.LocatorBidder.getBid(LocatorBidder.java:32)
at com.inprise.vbroker.ProtocolEngine.ManagerImpl.startBidding(ManagerImpl.java:167)
at com.inprise.vbroker.ProtocolEngine.ManagerImpl.getConnector(ManagerImpl.java:157)
at com.inprise.vbroker.orb.DelegateImpl._bind(DelegateImpl.java:205)
at com.inprise.vbroker.orb.DelegateImpl.bind(DelegateImpl.java:167)
at com.inprise.vbroker.CORBA.portable.ObjectImpl._bind(ObjectImpl.java:59)
at com.inprise.vbroker.orb.ORB.bind(ORB.java:1213)
at com.cisco.nm.cmf.eds.manager.ManagerControlHelper.bind(ManagerControlHelper.java:58)
at com.cisco.nm.cmf.eds.manager.CorbaRegistry.connect(CorbaRegistry.java:352)
at com.cisco.nm.cmf.eds.manager.CorbaRegistry.reconnect(CorbaRegistry.java:364)
at com.cisco.nm.cmf.eds.system.EventSource.run(EventSource.java:448)
at java.lang.Thread.run(Thread.java:479)

[Wed Mar 31 17:06:11 NZST 2010] ERROR: CORBAREGISTRY:Unable to connect to ManagerControl object.  Reason: org.omg.CORBA.OBJECT_NOT_EXIST:
  Could not locate the following Object:
  repository id : IDL:manager/ManagerControl:1.0
    object name : ManagerControl
      host name : HP1813
  minor code: 0  completed: No
1270011971162 31 March 2010 17:06:11 jrm HP1813 Error EDSSY0012: Cannot connect to EDS.

Correct Answer
Joe Clarke Wed, 03/31/2010 - 21:57

This is what I thought.  Your services are set to Automatic when they must be set to Manual.  Change the startup type for the following services back to Manual, then reboot:


CiscoWorks RME NG database engine

CiscoWorks Tomcat Servlet Engine

CiscoWorks VisiBroker Smart Agent

CiscoWorks Web Server

CWCS Cmf database engine


Typically, the Daemon Manager service is setup to Automatic and not Manual.  However, if you're okay with starting it manually, you can leave it how it is.


--


Please support CSC Helps Haiti


https://supportforums.cisco.com/docs/DOC-8895

https://supportforums.cisco.com

Jeff Law Fri, 04/02/2010 - 14:29

Thanks Joe. Changed services to manual, and all is now working fine - on

all servers.

Jeff Law Wed, 03/31/2010 - 20:30

I have noticed that the other two "slave" servers we have running also have the same error meesages occuring in the EDS.log file.


I am presuming that once the master is fixed, the others will start working as well.

Actions

This Discussion