Problem with multicast over GRE

Answered Question
Mar 31st, 2010

Hi,

I have stucked on a problem with my configuration of multicast routing.

The topology is as simple as it it can be: R1 <-> R2 <-> R3 <-> R4 <-> R5 <-> R6

The links are either FR or Eth (i n my opinion it doesn't make any difference).

I launched OSPF (all links and loopbacks in area 0) and PIM sparse-dense mode (all links and loopbacks)

With Auto RP R6 is RP candidate and R5 is the mapping agent.

Everything worked great (R1 joined group 224.67.67.67 and ping from R6 was successful) until i changed the topology a little bit:

1. I blocked PIM neighbor relationship on R3 towards R2

2. I configured a GRE tunnel R1 <-> R3 (between loopbacks with pim sparse-dense and OSPF)

From there ping from R6 to the 224.67.67.67 is not successful any more.

Any suggestions?

Thanks

I have this problem too.
0 votes
Correct Answer by Edison Ortiz about 6 years 8 months ago

Remove the mroute that I recommended for R3, leave it just on R1 and clear the mroute table in all routers.

Try again..

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4.5 (2 ratings)
Loading.
Edison Ortiz Wed, 03/31/2010 - 14:53

You are experiencing a RPF failure as the unicast routing will take the mcast traffic via the regular interface not the GRE.

To solve this issue you must configure mroutes on R1 and R3.

You can setup host mroutes or a all hosts mroute with the command:

ip mroute 0.0.0.0 0.0.0.0 tunnel x

on both R1 and R3.

Regards

Edison

______

Each time you rate a CSC   discussion   we'll donate $1 to the American Red Cross Haiti fund up to a   maximum   donation of $10,000 USD.

https://supportforums.cisco.com/docs/DOC-8895

j_tomasik Thu, 04/01/2010 - 06:04

Hi,

Thank you for a quick reply.

Unfortunately the solution works only partially - the ping works now not only from R3 but also from R4. However it still doesn't work from R5 and R6.

In the debug ip packet on R1 I can't see my ICMP packet sent from R4/R5 to the multicast group. I can see only reply (only to R5)

Regards

Edison Ortiz Thu, 04/01/2010 - 06:23

Do you have any other connections from R5 and R6 towards R1?

Let's see the show ip mroute table from the affected routers (R1, R5, R6).

j_tomasik Thu, 04/01/2010 - 08:24

Hello,

Here are the outputs. R4 is RP mapping agent, R6 is the RP for group 224.26.26.26, R1 joined the group 224.26.26.26 via ip igmp join-group command on the loopback interface.

And the answer to your question is no - R4 has three connections : to R3(FR p2p), to R5(FR p2p) and to another stub router, and R6 has only one connection - to R5 (Eth - no any other PIM/OSPF neighbors on the segment)

Regards

Edison Ortiz Thu, 04/01/2010 - 10:21

R1 is sending the join out of all available PIM interfaces and I don't see the mcast group
associated with the RP, see the RP 0.0.0.0 and the flag is dense.

(*, 224.26.26.26), 02:37:40/stopped, RP 0.0.0.0, flags: DCL
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    Serial0/0.701, Forward/Sparse-Dense, 02:36:23/00:00:00
    Tunnel0, Forward/Sparse-Dense, 02:37:40/00:00:00
    Loopback0, Forward/Sparse-Dense, 02:37:40/00:00:00


R1 is receiving flows from the following sources; 10.1.13.3, 10.1.100.5 and 10.31.31.3

(10.1.13.3, 224.26.26.26), 00:00:36/00:02:23, flags: L
  Incoming interface: Tunnel0, RPF nbr 10.31.31.3, Mroute
  Outgoing interface list:
    Loopback0, Forward/Sparse-Dense, 00:00:37/00:00:00
    Serial0/0.701, Forward/Sparse-Dense, 00:00:37/00:00:00

(10.1.100.5, 224.26.26.26), 00:00:25/00:02:35, flags: LT
  Incoming interface: Tunnel0, RPF nbr 10.31.31.3, Mroute
  Outgoing interface list:
    Loopback0, Forward/Sparse-Dense, 00:00:25/00:00:00
    Serial0/0.701, Forward/Sparse-Dense, 00:00:25/00:00:00
         
(10.31.31.3, 224.26.26.26), 00:00:38/00:02:24, flags: LT
  Incoming interface: Tunnel0, RPF nbr 10.31.31.3
  Outgoing interface list:
    Loopback0, Forward/Sparse-Dense, 00:00:38/00:00:00
    Serial0/0.701, Forward/Sparse-Dense, 00:00:38/00:00:00

R3 received the join message from R1 but it also lacks RP information.
The group is running on Dense mode so it seems you have an auto-rp problem.

(*, 224.26.26.26), 00:04:27/00:02:08, RP 0.0.0.0, flags: D
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    Tunnel0, Forward/Sparse-Dense, 00:04:27/00:00:00
    Serial0/1/1.305, Forward/Sparse-Dense, 00:04:27/00:00:00


Did you configure 'auto-rp listener' in all routers?
Can you provide the output from 'show ip pim rp-mappings'?

j_tomasik Thu, 04/01/2010 - 11:50

I didn't configure #ip pim autorp listener, as all interfaces are in sparse-dense-mode.

I tried to configure it(listener) despite that but it didn't help.

The RP mappings are as follows

RP (R6):

ip pim send-rp-announce Loopback0 scope 6 group-list 1

access-list 1 permit 224.6.6.6
access-list 1 permit 224.26.26.26

R4 (mapping agent):

ip pim send-rp-discovery Loopback0 scope 5

ip pim rp-announce-filter rp-list 6 group-list 66

access-list 6 permit 6.6.6.6

access-list 66 permit 224.6.6.6
access-list 66 permit 224.26.26.26

Output from rp mappings on R4:

This system is an RP-mapping agent (Loopback0)


Group(s) 224.6.6.6/32
  RP 6.6.6.6 (?), v2v1
    Info source: 6.6.6.6 (?), elected via Auto-RP
         Uptime: 1d07h, expires: 00:00:22
Group(s) 224.26.26.26/32
  RP 6.6.6.6 (?), v2v1
    Info source: 6.6.6.6 (?), elected via Auto-RP
         Uptime: 1d07h, expires: 00:00:23

On R3 there are no RP mappings

Correct Answer
Edison Ortiz Thu, 04/01/2010 - 12:01

Remove the mroute that I recommended for R3, leave it just on R1 and clear the mroute table in all routers.

Try again..

j_tomasik Thu, 04/01/2010 - 12:42

Thank you very much!

It worked:

#ip mroute ... only on R1 and that's it

The mappings appeared on every router after removing the #ip mroute .. from R3 - could you explain this behaviour.

What is funny when I made a change and cleared ip mroute it worked only on R5 (and not on R6).

Only after several tries of clearing ip mroute it worked.

I think it's because I didn't clear it simultaneously on all routers.

Is it important where I start clearing mroutes? (starting from RP mapping agent?  from RP? or from the router at the end of the path?)

Edison Ortiz Thu, 04/01/2010 - 12:54

R3 was having the tunnel 0 as the incoming interface for all sources.
That was wrong and removing the mroute fixes that isssue.
R3 is now using the unicast routing for the sources which are coming from routers other than R1.

mroutes clearing can be quite tricky. If often takes a couple of clearing for the mcast traffic to flow properly.

Thanks for the rating and glad to be of help

Regards

Edison

Actions

This Discussion