UCCX 7 wav files and languages

Unanswered Question
Mar 31st, 2010

I'm in the midst of trying to configure IPIVR 7.0 for IPCC, and to get the basic config working I wanted to write a simple play prompt script on the IVR, should be asy I thought. However, all I get is the automated 'system problems' WAV file played and not my prompt. I end up with the following error in the MIVR log file:

118348: Mar 31 19:46:35.724 BST %MIVR-LIB_MEDIA-3-PROMPT_ERROR_IGNORED:Prompt error ignored: Exception=com.cisco.prompt.UndefinedPromptException: user prompt 'C:\Progra~1\wfavvid\Prompts\user\en\C:\Program Files\wfavvid\Prompts\user\en_GB\HPwelcome.wav'
118349: Mar 31 19:46:35.724 BST %MIVR-LIB_MEDIA-3-EXCEPTION:com.cisco.prompt.UndefinedPromptException: user prompt 'C:\Progra~1\wfavvid\Prompts\user\en\C:\Program Files\wfavvid\Prompts\user\en_GB\HPwelcome.wav'

The WAV file is pulled from my 3.5 system and plays fine there.

I think this is somehow wrapped up with the way I have the languages set up and the directory structure but I'm failing it to work it out. Can anybody point me in the right direction please as this is now getting very frustrating!

I also have the ICM subsystem in PARTIAL_SERVICE but I assume this is not related, it was running fully at one point. What's the best log file and log parameters to enable to see what's going on here?

Thanks


jed

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Aaron Harrison Wed, 03/31/2010 - 12:04

Hi

No ICM experience, but lots of UCCX. By default UCCX/IPIVR ignore prompt errors, and you are seeing that in your log:

Prompt error ignored

I would see if there are any other 'EXCEPTION' log entries after that...

Regards

Aaron

jedellerby Wed, 03/31/2010 - 13:03

Thanks Aaron, that's useful to know then. Is it something I can fix too ... an error in my script?

The other errors I have seen on occasions, possibly regulalry, are:

140827: Mar 31 18:35:21.994 BST %MIVR-LIB_MEDIA-3-PROMPT_ERROR_IGNOREDrompt error ignored: Exception=com.cisco.prompt.UndefinedPromptException: Local media channel might be released, the codec is 0; nested exception is:

com.cisco.audio.WrongAudioFormatException: Unsupported payload type: 0

WrongAudioFormatException

This doesn't looks too promising .. is this more likely my error? I'm not sure how consistent this error is yet as I have played witha lot of settings today so the picture isn't crystal clear just yet. This is for a WAV file that was either fine in 3.5 or I copied from the system repository and renamed as a test.

Jed

 

Aaron Harrison Wed, 03/31/2010 - 13:08

Hi

That looks more of a problem - I've seen badly formatted audio files knock out UCCX systems before now. IF the prompt isn't there, or you mess up the languages, then you'll normally skip over the prompt (you get an undefinedPromptException). This usually gets you silence on a new system or MoH if you wind up in a queue...

Is it possible that the file you uploaded is either g729, and this is a g711 system, or vice versa? It doesn't appear to like the file 'WrongAudioFormatException'

Maybe grab one of the system prompts from c:\program files\wfavvid\prompts\whatever it is and upload over it as a test...

Aaron

jedellerby Wed, 03/31/2010 - 14:21

No, very little chance of that being the case.

I tried taking the AA scipt, adding it to my scripts under a new name and it played fine. I then changed the script to point to one of my WAV files instead of a system announcement and I then get problems. I'll have to double check if that instance aslo led to the bad audio.

I'm struggling to understand why the system should come up with bad prompt anyhow as the audio is there and registered from what I can tell. Can I specificy the full directorty path in the script, or do I have to specifiy it relative to the language?

What's the best options to enable on tracing so it's not too noisy but would still catch errors?

Thanks

Jed

Aaron Harrison Wed, 03/31/2010 - 14:24

Hi

By default anything that causes Cisco Lady to be upset will appear in the logs.

Take it from me, if it finds the prompt and doesn't like it it will fail.

If you have pointed the working AA script at your audio, and it errors, the problem is your audio...

If you mess up the path, or point at a file, the worst is you miss it and it skips.

Aaron

jedellerby Fri, 04/02/2010 - 06:52

Well I fixed the issue, buit not in the way I expected. I deleted all the scripts from the repository and then just copied over one valid script (AA) into my repository, and that worked. I then started pointing at one of the customer WAV files and that worked. I then pulled in one of the original custom scripts pointing at all the various custom WAV files and they worked.

So, the fix seemed to be to just clean out the scripts and start again.

Thanks for your input, always helpful to know somebody has an idea of what they are doing!

Cheers

Jed

Actions

This Discussion