AP 1100

Answered Question
Mar 31st, 2010

I have inherited some AP 1100 and would like to update the software.  I have downloaded the latest available from the Cisco website but can't seem to get the unit to take the software.  I initial tried the system software -> software upgrade, but that isn't updating the unit.  I'm pretty unfamiliar with tftp, but from reading the group have found the one recommended by Cisco and installed it.

My system software is currently at 12.3(2)JA2 and I would like to take it to 12.3.8-JED.

Am I missing something on why it won't take the upgrade via the GUI?  If not, can someone explain a bit of installing the .tar file via the CLI.

Thanks for any help that you may be able to provide.

Will

Correct Answer by Leo Laohoo about 6 years 10 months ago

Whew!  I'm happy to see your issue has been fixed.

May I ask if you can tick this post as "Answered"?  Thanks.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Leo Laohoo Wed, 03/31/2010 - 16:58

Can you provide the output of the "sh version" and the complete filename of the new IOS you are trying to upload?

wkerns@geistmfg.com Wed, 03/31/2010 - 18:51

Thanks for checking this out.  I actually was able to connect to the system via telnet and I attempted to do the upgrade via the CLI.  I used the following command:

archive download-sw /overwrite tftp:\\10.0.0.28\c1100-k9w7-tar.123-8.JED.tar

It attempts to run, but then gives me the error: not enough free space in "flash:/"

Clean up and try again.

How does one clean up the device.

Again thanks for any help that you can provide.

Will

Leo Laohoo Wed, 03/31/2010 - 19:34

Can you post the output of the "dir" command please?  I want to make sure that there's enough flash space before you do anything else.  How big is the new IOS you are trying to upload?

wkerns@geistmfg.com Wed, 03/31/2010 - 19:38

The new file 4.5 megs

here is the dir listing


    3  drwx         320   Jan 1 1970 00:05:48 +00:00  c1100-k9w7-mx.123-2.JA2
  143  -rwx        1849   Mar 1 2002 00:04:46 +00:00  config.txt
  144  -rwx           5   Mar 1 2002 00:04:46 +00:00  private-config
  145  -rwx          80   Jan 1 1970 00:00:26 +00:00  env_vars
  146  -rwx          76   Mar 1 2002 00:04:46 +00:00  private-multiple-fs
  149  -rwx     3543040   Mar 1 2002 01:09:55 +00:00  -sw

Will

Leo Laohoo Wed, 03/31/2010 - 19:50

1.  The "dir" command will tell what is your size of your flash and how much is available.  You've concatinated your output.  Can you post the complete output?
2.  Can you please post the complete output for the command "dir flash:c1100-k9w7-mx.123-2.JA2"?

wkerns@geistmfg.com Wed, 03/31/2010 - 19:56

when I run dir I get the above information.  When I run show file system, I get this:


     Size(b)     Free(b)      Type         Flags        Prefixes
*    7741440        1024     flash          rw         flash:
           -                -        opaque        rw        bs:
     7741440        1024     unknown     rw        zflash:
           -                -        opaque        rw        system:
       32768       30862     nvram          rw        nvram:
           -           -             network       rw          tftp:
           -           -             opaque        rw        null:
           -           -            opaque        ro        xmodem:
           -           -             opaque       ro        ymodem:
           -           -             network       rw        rcp:
           -           -             network       rw        ftp:
           -           -             network       ro        http:
           -           -             network       rw        scp:
           -           -             network       ro        https:

Hope that helps you out.

Will

wkerns@geistmfg.com Wed, 03/31/2010 - 19:59

Here is the second part of that question

Directory of flash:/c1100-k9w7-mx.123-2.JA2/

    4  drwx          64   Jan 1 1970 00:01:36 +00:00  html
  139  -rwx     3311069   Jan 1 1970 00:05:37 +00:00  c1100-k9w7-mx.123-2.JA2
  140  -rwx      131328   Jan 1 1970 00:05:42 +00:00  5001.img
  141  -rwx      131328   Jan 1 1970 00:05:48 +00:00  5101.img
  142  -rwx         274   Jan 1 1970 00:05:48 +00:00  info

7741440 bytes total (1024 bytes free)

wkerns@geistmfg.com Thu, 04/01/2010 - 06:26

Followed the commands to the tee, unfortunately when I run the second command about

half way through the upload I get an error:  not enough space on device

When I run a show file system, I still have 7741440 bytes used and 512 free in the flash portion and

I have 7741440 bytes used and 512 free in the zflash.  Not certain what is causing troubles or how to clear

out any more space.

Will

Leo Laohoo Thu, 04/01/2010 - 15:26

My deepest apologies.  Try this command "delete /f /r flash:-sw" and do the "arch" command again.

wkerns@geistmfg.com Thu, 04/01/2010 - 18:45

I have tried the new command, but it does not appear to delete anything.  If I run the command and confirm that I want to delete -sw, it goes back to the prompt.  If I then run a dir, I still see that it appears.  When I try to do the arch command, I still get an error about not enough space.

Will

Leo Laohoo Thu, 04/01/2010 - 22:33

Backup the config.text file somewhere or copy and paste your config into a notepad.  Can you try the command "format flash:"?  This command will wipe everything.

wkerns@geistmfg.com Fri, 04/02/2010 - 10:14

I made a backup of my cofiguration and uploaded to my tftp server.  Shortly after I intiated the format flash:  the system became non-responsive.  I restarted the system to try to recover as you might guess the system is not responding.  There is a light sequence two bottom flashing green light for about 15 seconds, then 2 red lights and one green lights.  Is there anything that I can do to recover this unit?

wkerns@geistmfg.com Wed, 04/07/2010 - 07:32

Sorry about the delay, I was out of the office.  I was able to try the system reset from the instructions you sent, but I've not been able to get the unit to respond.  Holding the reset button in for about 20 seconds I was able to get the status light to change to red.  From there the other two lights turn green and all three are steady.  I have let the unit set for an hour before restarting the unit, but then it goes into the same sequence of flashing lights as before.  I have been trying to connect the unit via a network cable, should I try a different type of connection?  Thanks for all your help on this unit.

Will

Leo Laohoo Wed, 04/07/2010 - 17:31

The cable from the AP to the TFTP server should be a straight-through cable.  Do you have a TFTP application running?

wkerns@geistmfg.com Thu, 04/08/2010 - 10:39

I was able to get back to the office to try and get the unit going before I leave town.  I reread all the instructions and noticed that my .default name was off slightly.  After correcting that, I was able to get the unit to start talking.  I have now completed the update and my unit is online and working.  Thanks, for all your help.  I can't tell you how much I greatly appreciate it.  Thanks again.

OLD MESSAGE ***  I'm currently using a straight thru cable.  I'm currently using tfrp32 and have assigned the ip address of 10.0.0.28 to my internal nic.  Let me try again tonight or tomorrow morning and let you know.  I will be out of the office for the rest of the day.

Will

Correct Answer
Leo Laohoo Thu, 04/08/2010 - 15:28

Whew!  I'm happy to see your issue has been fixed.

May I ask if you can tick this post as "Answered"?  Thanks.

Actions

This Discussion