Blinking agent state in CAD supervisor desktop UCCX

Unanswered Question
Apr 1st, 2010
User Badges:

Hello,


I'm experiencing a problem with a UCCX configuration. Some of agents in a defined team sometime blink in the supervisor console (the agent appear and deseapear like if the agent console is launched then closed, launched then closed). On dektop agent side, the state is stable (no loggued-out or disconnected).


I've not find any answer in troobleshooting and user guides.


Did somebody have already experienced a similar issue ?


Thanks in advance.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (3 ratings)
Loading.
TouchbaseParam Thu, 04/01/2010 - 00:57
User Badges:

Please check the Proxy setting of Agent's PC and Supervisor PC.


Cheers,

Parm

Aaron Harrison Thu, 04/01/2010 - 01:05
User Badges:
  • Super Bronze, 10000 points or more
  • Community Spotlight Award,

    Member's Choice, May 2015

Hi


It's often that security software on your client PC is preventing unsolicited connections from the UCCX server to your Supervisor PC.


Try turning any such software off and retesting (including Windows Firewall if that’s all you have).


Aaron

plafontan Thu, 04/01/2010 - 01:38
User Badges:

Thanks for your answers. I will ask the customer to check this parametert. I will report her the result I

will obtain.

Jonathan Schulenberg Fri, 04/02/2010 - 07:49
User Badges:
  • Super Bronze, 10000 points or more
  • Cisco Designated VIP,

    2017 IP Telephony

Here's the specific ports that need to be allowed:


/* Style Definitions */ table.MsoNormalTable {mso-style-name:"Table Normal"; mso-tstyle-rowband-size:0; mso-tstyle-colband-size:0; mso-style-noshow:yes; mso-style-priority:99; mso-style-parent:""; mso-padding-alt:0in 5.4pt 0in 5.4pt; mso-para-margin:0in; mso-para-margin-bottom:.0001pt; mso-pagination:widow-orphan; font-size:10.0pt; font-family:"Times New Roman","serif";}

  • Supervisor Desktop
    • TCP 59021 from the CCX server(s)
    • TCP 59000 to the CCX server(s)
  • Agent Desktop
    • TCP 59020 from the CCX server(s)
    • TCP 59000 to the CCX server(s)



Once the ports are open on the PC firewall, you can test this by opening a Windows command prompt and typing telnet . Here are a few examples:

From the CCX server try: telnet 59021. From the supervisor PC try: telnet 59000. If you receive a ‘Connect failed’ error message, a firewall is blocking the connection.

plafontan Tue, 04/06/2010 - 23:46
User Badges:

I have to wait the next occurence of this issue to test your methode, but the document you've shared is very interesting. Thanks for that.

cbelcher Thu, 05/03/2012 - 09:34
User Badges:

That fixed it for me.  I went to the agents workstation and found 4 instances of agent.exe.  Exited CAD and killed all 4 instances of the agent.exe process.  Restarted CAD and problem solved.  They (Cisco bug ID: CSCtd75811) reference a SplkStd.dll that can be applied to the workstation for a permanant fix.  Haven't tried that yet.

luis-solorzano Fri, 06/08/2012 - 15:10
User Badges:

I have the same problem, so I turn off the antivirus and it work very well, but   I can't do telnet to the UCCX port 59000 from CAD and CSD.

I experienced a similar issue with UCCE version 8.01.  The agents would "blink" in between ready and reserved.  Resetting the PG user in CM would "fix" the issue.  After many hours of troubleshooting this and other problems, we finally figured out that the "blinking agent" was actually getting sent more than one call, and would clear out the queues in a matter of seconds once this agent logged in and went ready.  Upgrading to version 8.01(a) fixed the issue.

Actions

This Discussion