Cisco 3600 to Cable Modem

Answered Question
Apr 1st, 2010

I just got a Cisco 3600 router and was attempting to set it up to my cable modem. I feel a little like a noob asking for help with something as simple as this but I am stuck. I followed Cisco's guide and another guide to check my router's config and the dhcp config. It pulled a good ip from my ISP but would not go beyond that. So I hooked it up behind my working private Belkin router (to troubleshoot and so i don't have to switch back and forth) and I can log into it so I know it can reach its gateway, however it still cannot route to the internet or ping the ISP's IP. I am sure it is something simple so thanks in advance!

Terry

Network setup to clarify

Comcast Modem

Belkin Router WAN IP - 76.*.*.*

                     LAN IP - 192.168.77.1

Cisco Router  FA0/0 IP - 192.168.77.6

                     FA 0/1 IP - 10.77.77.1

Laptop           IP Address - 10.77.77.2

BlitzRouter#show run
Building configuration...

Current configuration : 1479 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname BlitzRouter
!
!
ip subnet-zero
!
!
no ip domain-lookup
ip dhcp excluded-address 10.77.77.1
!
ip dhcp pool HOME_PCS
   import all
   network 10.77.77.0 255.255.255.0
   default-router 10.77.77.1
!
call rsvp-sync
!
!
!
!
!
partition flash 2 16 16
!
!
!
!
interface FastEthernet0/0
ip address dhcp
ip nat outside
duplex auto
speed auto
!
interface Serial0/0
no ip address
shutdown
clockrate 2000000
!
interface FastEthernet0/1
ip address 10.77.77.1 255.255.255.0
ip nat inside
duplex auto
speed auto
!
interface Serial0/1
no ip address
shutdown
clockrate 2000000
!
interface Serial0/2
no ip address
shutdown
clockrate 2000000
!
interface Serial0/3
no ip address
shutdown
clockrate 2000000
!
interface ATM1/0
no ip address
shutdown
no atm ilmi-keepalive
no scrambling-payload
!
interface ATM1/1
no ip address
shutdown
no atm ilmi-keepalive
no scrambling-payload
!
interface ATM1/2
no ip address
shutdown
no atm ilmi-keepalive
no scrambling-payload
!
interface ATM1/3
no ip address
shutdown
no atm ilmi-keepalive
no scrambling-payload
!
ip nat inside source list 101 interface FastEthernet0/0 overload
ip classless
ip route 0.0.0.0 0.0.0.0 FastEthernet0/0
no ip http server
!
access-list 101 permit ip 10.77.77.0 0.0.0.255 any
!
dial-peer cor custom
!
!
!
!
line con 0
logging synchronous
line aux 0
line vty 0 4
login
!
end

I have this problem too.
0 votes
Correct Answer by Neeraj Arora about 6 years 9 months ago

Terry,

Instead of using "ip route 0.0.0.0 0.0.0.0 FastEthernet0/0" change it to "ip route 0.0.0.0 0.0.0.0 192.168.77.1"

Then check sitting on the router and ping the ISP gateway ip, if it works, you can test with an extended ping using the source ip as 10.77.77.1

Hope it helps.

Neeraj

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (3 ratings)
Loading.
Correct Answer
Neeraj Arora Thu, 04/01/2010 - 00:42

Terry,

Instead of using "ip route 0.0.0.0 0.0.0.0 FastEthernet0/0" change it to "ip route 0.0.0.0 0.0.0.0 192.168.77.1"

Then check sitting on the router and ping the ISP gateway ip, if it works, you can test with an extended ping using the source ip as 10.77.77.1

Hope it helps.

Neeraj

TerryLHoward Thu, 04/01/2010 - 01:37

Thanks Neeraj!

I got it working behind my private router and just swaped it and got it working on my home network. My question now is why was that static route needed and why was it said to point there if it was suppose to be the gateway of the next hop? Thanks again for the help!

Terry

Neeraj Arora Thu, 04/01/2010 - 01:46

A route with Exit interface involves ARP in a big way. Everytime that router

tries to send any traffic using that route, it will ARP for it and unless &

untill the next hop (or a device in that shared segment) respond back (using

Proxy-arp functionality), things will not work well.

So as a best practice, use Next hop ip in static routes, wherever possible.

This will eliminate the extensive use of ARP as well as will put less load

on the device, as some processing is required for all the ARP queries and

responses.

Ganesh Hariharan Thu, 04/01/2010 - 01:37


Thanks Neeraj!

I got it working behind my private router and just swaped it and got it working on my home network. My question now is why was that static route needed and why was it said to point there if it was suppose to be the gateway of the next hop? Thanks again for the help!

Terry

Hi Terry,

A static route is required in routing device because to route traffic across the network. Static routes are commonly used on routers to accomplish this and it is point to point link and for packet which are coming on your router will not know unless you specify the gateway ip address where to send the packet for the destination address.

Hope to help !!

Ganesh.H

Cisco are currently donating money to the Haiti earthquake appeal for every rating so please consider rating all helpful posts.

Actions

This Discussion

Related Content