Compatibility SRST and CUCM 7 ?

Answered Question
Apr 1st, 2010
User Badges:

Hello everybody,


I plan to migrate a CUCM Cluster 4 to 7, the customer have 10 remote sites which have 2801 GW IOS 12.4 registred with H323 protocol.


I want to know please if i must migrate IOS of GWs before the migration of the CUCM cluser ? my question is about the compatibily of SRST in the IOS 12.4 with the CUCM 7.


Regards,

Mohamed

Correct Answer by Rob Huffman about 7 years 3 months ago

Hi Mohamed,



SRST 4.3 and later


Table 60 Cisco Unified Survivable Remote Site Telephony Compatibility with Cisco Unified Communications Manager Release 3.x through Release 8.x


http://www.cisco.com/en/US/docs/voice_ip_comm/cucm/compat/ccmcompmatr.html#wp56839




To find your IOS version support check here (CME version = SRST version)


Cisco Unified CME and Cisco IOS Software Version Compatibility Matrix


http://www.cisco.com/en/US/docs/voice_ip_comm/cucme/requirements/guide/33matrix.htm



Cheers!

Rob



Please support CSC Helps Haiti


https://supportforums.cisco.com/docs/DOC-8895


https://supportforums.cisco.com/docs/DOC-8727

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4.3 (3 ratings)
Loading.
Correct Answer
Rob Huffman Thu, 04/01/2010 - 11:35
User Badges:
  • Super Red, 40000 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 IP Telephony, Unified Communications

Hi Mohamed,



SRST 4.3 and later


Table 60 Cisco Unified Survivable Remote Site Telephony Compatibility with Cisco Unified Communications Manager Release 3.x through Release 8.x


http://www.cisco.com/en/US/docs/voice_ip_comm/cucm/compat/ccmcompmatr.html#wp56839




To find your IOS version support check here (CME version = SRST version)


Cisco Unified CME and Cisco IOS Software Version Compatibility Matrix


http://www.cisco.com/en/US/docs/voice_ip_comm/cucme/requirements/guide/33matrix.htm



Cheers!

Rob



Please support CSC Helps Haiti


https://supportforums.cisco.com/docs/DOC-8895


https://supportforums.cisco.com/docs/DOC-8727

mmendonca Wed, 05/05/2010 - 06:31
User Badges:

I'm confused the link that is provided:


http://www.cisco.com/en/US/docs/voice_ip_comm/cucm/compat/ccmcompmatr.html#wp56839


Shows that SRST 7.1 is only compatible under CUCM 8.x


Yet if you check this link


http://tools.cisco.com/ITDIT/vtgsca/VTGServlet


Then click on the link for release 7.1. then click on the 7.1(2) references it shows 7.1/IOS 12.4(24)T1 as being compatible.


Can anyone shed some light on this?

Rob Huffman Wed, 05/05/2010 - 06:54
User Badges:
  • Super Red, 40000 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 IP Telephony, Unified Communications

Hi there,


In the first link here is the related info for SRST 7.1 (it is compatible under CUCM 7.x as well)


****Cisco Unified Survivable Remote Site Telephony (SRST) does not depend upon Cisco Unified Communications Manager,

but does support specific phone loads****



Table 64


SRST version 7.1
   
Cisco Unified Communications Manager Version


7.1

3.22,  3.32,  4.02,  4.1(3)4,  5.03,  5.13,  6.03,  6.13,  7.0



SRST version 8.0
    
Cisco Unified Communications Manager Version


8.0

3.22,  3.32,  4.02,  4.1(3)4,  5.03,  5.13,  6.03,  6.13,  7.0, 7.1, 8.0




Cisco Unified SRST 7.1 Supported Firmware, Platforms, Memory, and Voice Products


http://www.cisco.com/en/US/docs/voice_ip_comm/cusrst/requirements/guide/srs71spc.html




Cisco Unified SRST 8.0 Supported Firmware, Platforms, Memory, and Voice Products


http://cco.cisco.com/en/US/docs/voice_ip_comm/cusrst/requirements/guide/srs80spc.html




The second link you posted shows "tested-in" versions



Cheers!

Rob



Please support CSC Helps Haiti


https://supportforums.cisco.com/docs/DOC-8895


https://supportforums.cisco.com/docs/DOC-8727

mmendonca Wed, 05/05/2010 - 07:16
User Badges:

Thanks for the quick reply.  With all due respect Rob I have a couple of questions:


The table that you listed for SRST 7.1 shows only CUCM 7.0 listed.  It shows specific versions 6.03 and 6.13.  The second table for SRST 8.0 shows CUCM versions 7.0 and 7.1.   Is it safe to conclude that SRST 7.1 isn't compatible with CUCM 7.1?


Also you say that the second link shows "tested-in" versions.  The page states that it is the "Cisco Unified Communications Compatibility Tool".  I don't see anywhere on the page where it states that the versions are "tested-in".  What it does say is:


The table below identifies the compatible software release version(s) for each product element in this Cisco Unified Communications release.

Individual products may show subsequent maintenance release versions that are designed for compatibility with this Unified Communications System Release and these versions may or may not have been tested at a system level.


Again I don't mean to challenge you Rob.  Just looking to get this straight.


Rob Huffman Wed, 05/05/2010 - 07:25
User Badges:
  • Super Red, 40000 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 IP Telephony, Unified Communications

Hey there (??)


No worries at all


This is a discussion Forum after all, plus I've been known to be wrong about many things (daily)


I think the key thing to remember is this clip;


"Cisco Unified Survivable Remote Site Telephony (SRST) does not depend upon Cisco Unified Communications Manager"


Here is the "tested-in" reference;


http://tools.cisco.com/ITDIT/vtgsca/VTGServlet


The Cisco Unified Communications System securely integrates voice, video, and other collaborative data applications into intelligent network communications solutions. This system, which includes IP telephony, voice messaging, rich-media conferencing, IP video broadcasting, and customer contact solutions, takes full advantage the power, resiliency, and flexibility of an IP network. The elements of this system were designed, developed, documented and tested as part of a comprehensive, end-to-end Unified Communications System.


Individual products may show subsequent maintenance release versions that are designed for compatibility with this Unified Communications System Release and these versions may or may not have been tested at a system level.



So, SRST 7.1 would be supported with CUCM 7.1(x) versions from everything I know

and have tested.



Cheers!

Rob

mmendonca Wed, 05/05/2010 - 10:16
User Badges:

Either way when upgrading the default phone load files changes.  SRST 7.1 lists SCCP41.8-4-1-23 as supported for the 7941/61G phone.  So with CUCM 7.1 or 8.x the default phone loads would be different  therefore SRST 7.1 wouldn't support those versions? Correct?


This goes back to another discussion that I started about compatibility.


https://supportforums.cisco.com/thread/2013029?tstart=0


What exactly is meant by Compatibility?  Supported?  It's very confusing how these terms are used.  Then you throw in tested and its cousins earliest, inititial and subsequent. GEEZ!!!

mmendonca Thu, 05/06/2010 - 12:53
User Badges:

Hello,


Sorry tried to attach as a spreadsheet it didn't like file type so I pasted it in below..


Thanks

Mark

mmendonca Thu, 05/06/2010 - 12:57
User Badges:

Hello,


I've pasted in an Upgrade Matrix spreadsheet that I've compiled.  Listed are all the fun items I'm trying to figure out.    Compatibility, Device Defaults, Support (where I could find it) etc.  I've included my current CUCM version along with 8.0(x), 7.1(3) and 7.1(2).  Also included hardware that we use.  I've listed the links that I used at the bottom of the spread sheet.


Please take a look and post any comments or links that I could use to fill in the blanks.


Thanks

Mark




Cisco Unified Communications Manager6.1.3000-1 Current InstalledEarliest 8.0(1) Initial 8.0(2)a7.1(3)7.1.(2)
MCS-7835-H2-IPC1n/aSupported direct upgradeSupported Direct UpgradeSupported Direct Upgrade
Unity Connection Current Version7.12ES9.21900-97.1(2)7.1(2)7.1(2)
Compatibilty7.1(2)Initial 8.0(2) earliest 8.0(1)Initial 7.1(3) Earliest 7.0Initial 7.1(2a) Earliest 7.0
7914 Expansion 14 Keys Default Load / Version*S00105000400cmterm-7914-sccp.5.0.4.cop.sgn cmterm-7914-sccp.5.0.4.cop.sgncmterm-7914-sccp.5.0.4.cop.sgn
Compatibilty????
7915 Expansion 12 keysDefault Load / Version*B015-1-0-2cmterm-7915.1-0-4.cop.sgn cmterm-7915.1-0-3.cop.sgncmterm-7915.1-0-3.cop.sgn
Compatibilty????
7915 Expansion 24 keysDefault Load / Version*B015-1-0-2cmterm-7915.1-0-4.cop.sgn cmterm-7915.1-0-3.cop.sgncmterm-7915.1-0-3.cop.sgn
Compatibilty????
7916 Expansion 12 keysDefault Load / Version*B016-1-0-2SR1cmterm-7916.1-0-4.cop.sgn cmterm-7916.1-0-3.cop.sgncmterm-7916.1-0-3.cop.sgn
Compatibilty????
7916 Expansion 24 KeysDefault Load / Version*B016-1-0-2SR1cmterm-7916.1-0-4.cop.sgn cmterm-7916.1-0-3.cop.sgncmterm-7916.1-0-3.cop.sgn
Compatibilty????
7912 phonesDefault Load / Version*CP7912080003SCCP070409A/8.0.3(070409A)cmterm-7912-sccp.8.0.3.cop.sgncmterm-7912-sccp.8.0.3.cop.sgncmterm-7912-sccp.8.0.3.cop.sgn
Compatibiltysubsequent 8.0(4)/SCCP Initial 8.0(3)/SCCP subsequent 8.0(4)/SCCP Initial 8.0(3)/SCCP Initial 8.0(3)/SCCP Initial 8.0(3)/SCCP
7940G phoneDefault Load / Version*P00308000900/8.0(9.0)cmterm-7940_7960-sccp.8.1.2.cop.sgncmterm-7940_7960-sccp.8.1.1.cop.sgncmterm-7940_7960-sccp.8.1.1.cop.sgn
CompatibiltySubsequent 8.1(1) Initial 8.0(7) Earliest 8.0(5)initial 8.1(2)/SCCPInitial 8.1(1)/SCCPInitial 8.1(1)/SCCP Earliest 8.0(2)/SCCP
7960G phoneDefault Load / Version*P00308000900/8.0(9.0)cmterm-7940_7960-sccp.8.1.2.cop.sgncmterm-7940_7960-sccp.8.1.1.cop.sgncmterm-7940_7960-sccp.8.1.1.cop.sgn
CompatibiltySubsequent 8.1(1) Initial 8.0(7) Earliest 8.0(5)initial 8.1(2)/SCCPInitial 8.1(1)/SCCPInitial 8.1(1)/SCCP Earliest 8.0(2)/SCCP
7941G phoneDefault Load / Version*jar41sccp.8-4-1-23.sbn/SCCP41.8-4-2Scmterm-7941_7961-sccp.9-0-2SR1.cop.sgncmterm-7941_7961-sccp.8-5-2SR1.cop.sgncmterm-7941_7961-sccp.8-5-2.cop.sgn
CompatibiltySubsequent 8.5(2) Initial 8.3(3)  Earliest 8.3(1) Initial 9.0(2)SR1 subsequent 9.0(2)SR2Initial 8.5.3 Earliest 8.4.1Initial 8.5(2) Earliest 8.4(1)
7961G phoneDefault Load / Version*jar41sccp.8-4-1-23.sbn/SCCP41.8-4-2Scmterm-7941_7961-sccp.9-0-2SR1.cop.sgncmterm-7941_7961-sccp.8-5-2SR1.cop.sgncmterm-7941_7961-sccp.8-5-2.cop.sgn
CompatibiltySubsequent 8.5(2) Initial 8.3(3)  Earliest 8.3(1) Initial 9.0(2)SR1 subsequent 9.0(2)SR2Initial 8.5.3 Earliest 8.4.1Initial 8.5(2) Earliest 8.4(1)
7962G phoneDefault Load / Version*jar42sccp.8-4-1-23.sbn/SCCP42.8-4-2Scmterm-7942_7962-sccp.9-0-2SR1.cop.sgncmterm-7942_7962-sccp.8-5-2SR1.cop.sgncmterm-7942_7962-sccp.8-5-2.cop.sgn
CompatibiltySubsequent 8.5(2) Initial 8.3(3)  Earliest 8.3(1) Initial 9.0(2)SR1 subsequent 9.0(2)SR2Initial 8.5.3 Earliest 8.4.1Initial 8.5(2) Earliest 8.4(1)
7920 Wireless PhonesDefault Load / Version*cmterm-7920-3-0-2-sccp.cop.sgncmterm-7920-3-0-2-sccp.cop.sgncmterm-7920-3-0-2-sccp.cop.sgncmterm-7920-3-0-2-sccp.cop.sgn
CompatibiltyInitial 3.0(2)?Initial 3.0(2)Initial 3.0(2)
IP CommunicatorCompatibiltyInitial 2.1(1) Subsequent 2.1(4)Initial 7.0(3) Initial 7.0(3) Earliest 2.1(3)Initial 7.0(2) Earliest 2.1(3)
Access Points 12xxCompatibiltyInitial 12.3(8)JA Initial  12.4(21a)JA2 Initial 12.3(8).JA2 Earliest 12.3(8)JAInitail 12.4(18)JA1 Earliest 12.3(8)JA
2800 Integrated Services Routers IOSCompatibility?Initial 15.1(1)T Initial 15.0(1)M Earliest 12.4(20)T Initial 12.4(24)T1 Earliest 12.4(20)T
3800 Integrated Services Routers IOSCompatibility?Initial 15.1(1)T Initial 15.0(1)M Earliest 12.4(20)T Initial 12.4(24)T1 Earliest 12.4(20)T
VG224 Analog Voice Gateway?Initial 15.1(1)T Initial 15.0(1)M Earliest 12.4(20)T Initial 12.4(24)T1 Earliest 12.4(20)T
SRST/IOS7.1/IOS 15.0(1)M18.0 / IOS 15.1(1)T7.2/IOS 15.(0)1M7.1/IOS 12.4(24)T1
SRST 7914 Expansion 14 Keys SupportedS00105000300S00105000400?S00105000300
SRST 7915 Expansion 14 Keys SupportedB015-1-0-3**B015-1-0-3**?B015-1-0-3**
SRST 7915 Expansion 24 Keys SupportedB015-1-0-3**B015-1-0-3**?B015-1-0-3**
SRST 7916 Expansion 14 Keys SupportedB016-1-0-3**B016-1-0-3**?B016-1-0-3**
SRST 7916 Expansion 24 Keys SupportedB016-1-0-3**B016-1-0-3**?B016-1-0-3**
SRST supported 7940G imageP00308000900P00308000900?P00308000900
SRST supported 7960G imageP00308000900P00308000900?P00308000900
SRST supported 7941G imageSCCP41.8-4-1-23SCCP41.8-5-3S?SCCP41.8-4-1-23
SRST supported 7961G imageSCCP41.8-4-1-23SCCP41.8-5-3S?SCCP41.8-4-1-23
SRST supported 7962G imageSCCP42.8-4-1-23SCCP42.8-5-3S?SCCP42.8-4-1-23
* Version not included in default load page
** To support 7915/7916 extenstion modules, the IP phones need to have firmware 8-3-5 onward (CSCsl88522), the fix will be available with 8-4-1 firmware.
Links Used:
Server Compatibility to Versionhttp://www.cisco.com/en/US/prod/collateral/voicesw/ps6790/ps5748/ps378/prod_brochure0900aecd8062a4f9.html
Unity Connection Supported CUCM versionshttp://www.cisco.com/en/US/docs/voice_ip_comm/connection/compatibility/matrix/cucsccpmtx.html#wp62025
Default Load/Versionhttp://www.cisco.com/en/US/docs/voice_ip_comm/cucm/compat/ccmcompmatr.html#wp43813
Cisco Unified Communications Compatiblity Tool

http://tools.cisco.com/ITDIT/vtgsca/VTGServlet


Backward Compatibility Link:


http://www.cisco.com/en/US/docs/voice_ip_comm/uc_system/UC7.0.1/ipt_system_inst_upg/preptu.html#wp1150960


I've updated the table and I've added another link on backward compatibility.  Try to figure it out!

Rob Huffman Thu, 04/01/2010 - 12:04
User Badges:
  • Super Red, 40000 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 IP Telephony, Unified Communications

Hi Mohamed,


You are most welcome my friend


Glad to of some small help.


Cheers!

Rob

mmendonca Fri, 05/07/2010 - 06:31
User Badges:

This keeps getting better... First I was told by TAC that SRST isn't supported for CUCM 8.0(x).  Which checked out if you look at the compatibility link for 8.x:



http://tools.cisco.com/ITDIT/vtgsca/VTGServlet


SRST 8.0(1)GD/IOS 15.1(1)T is listed.  The phone load listed as supported for this version is SCCP41.8-5-3S.  Which isn't listed as 'Compatible' with CUCM 8.0(x).


Then the TAC Engineer wrote back with the following:




I also discussed this issue with Call-Manager Team, and my Lead here.

SRST would work for CUCM ver 8.1, but, however it is in testing phase.

The Min Phone load required for the same: SCCP41.8-5-3S

From the Call-Manager ver 8.X matrix, the phone load required is : cmterm-7941_7961-sccp.9-0-2SR1.cop.sgn

This should work, as the phone load that you are running on Call-Manager is on a higher version that what is required for SRST8.X, and it is also backward compatible.


Hence another term to deal with 'backward compatible'.  Can I assume this is the case in all instances?  That if a certian rev is listed as 'supported' or

'compatible' that all previous versions are 'backward compatible'  I think not.


I wish sometimes that I could speak directly with the team leads.


Mark

Actions

This Discussion