Adding a Switch to the UC520

Unanswered Question
Apr 1st, 2010

Can I use any smart switch like the SLM2024 with the UC520?  Is there any configuration issues I would need to be aware of.  As far as I can see it does VLAN and QoS so is there a need to get the ESW line.

Thanks.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Darren DeCroock Thu, 04/01/2010 - 13:39

Yes, you can use a smart switch with the UC520, but everything would have to be configured seperately. (VLANs, QoS...)  CCA will not be able to make changes to that switch.  The ESW line is what is recommended for the UC500 product line, which can be configured directly from CCA.

Thank you,

Darren

paullevine Mon, 09/13/2010 - 19:13

Were you able to get the slm2024 (or any "Small Business" switch) to work with the UC 520?  I have a new srw2024p and can't get the Cisco 7941 phones to get their IP addresses from the voice vlan coming from the UC520.  I'd be most grateful for any help.

ciscojoe837 Wed, 09/15/2010 - 05:05

Hi Paul,

Yes I did get it to work.  I didn't use this model but the concept should be the same. 

Set port 1/8 on the UC to Switch

Config voice VLAN on the SLM: Voice, VLAN ID: 100

Assign ports to the 100 VLAN

Now the default VLAN is already understood so you shouldn't need to define the default VLAN.  It's 1. 

I can WebEx into your system and look at it for you if you want.

Joe

Steven DiStefano Wed, 09/15/2010 - 20:47

Te echo what Darren said and perhaps to help be clear, we do not support other switches on the UC500 at this time (only CE5xx and ESW).

paullevine Wed, 09/15/2010 - 21:02

Thanks, everybody, for your responses.  We got it working.  Since the "Small Business" switches don't do CDP, we just had to set the phones' IPs and VLAN ID statically, and they're working like a charm.  Unsupported--understood.  But at $1,000 less per switch than ESW540, it'll meet our very small business' immediate needs.

Clarification: I'm connecting the SRW2024P to the UC520's expansion port, not one of its 8 switch ports, and that's why the connected phones won't find the VLAN and get IPs dynamically.  I guess if I had just connected through one of the UC's switch ports in the first place, we would never have met

;-)

Thx again.

speakeasy51 Thu, 09/16/2010 - 06:18

You should use UC520's expansion port which is a 'trunk' port. It propagates all 'allowed' vlans.

UC520#sh run int fa0/1/8
Building configuration...

Current configuration : 93 bytes
!
interface FastEthernet0/1/8
switchport mode trunk
macro description cisco-switch
!
end


UC520#sh parser macro name cisco-switch
Macro name : cisco-switch
Macro type : default interface
# macro keywords $native_vlan
# Access Uplink to Distribution
# Do not apply to EtherChannel/Port Group
switchport trunk encapsulation dot1q

# Define unique Native VLAN on trunk ports
# Recommended value for native vlan should not be 1
switchport trunk native vlan $native_vlan

# Update the allowed VLAN range such that it
# includes data, voice and native VLANs
switchport trunk allowed vlan ALL

# Hardcode trunk
switchport mode trunk

UC520#sh run int fa0/1/7
Building configuration...

Current configuration : 120 bytes
!
interface FastEthernet0/1/7
switchport voice vlan 100
macro description cisco-phone
spanning-tree portfast
!
end

UC520#sh parser macro name cisco-phone
Macro name : cisco-phone
Macro type : default interface
# Cisco IP phone + desktop template

# macro keywords $access_vlan $voice_vlan

# VoIP enabled interface - Enable data VLAN
# and voice VLAN
# Recommended value for access vlan should not be 1
switchport access vlan $access_vlan
switchport mode access

# Update the Voice VLAN value which should be
# different from data VLAN
# Recommended value for voice vlan should not be 1
switchport voice vlan $voice_vlan

# Configure port as an edge network port
spanning-tree portfast

Actions

This Discussion