4948 Running Configuration

Answered Question
Apr 2nd, 2010

Hello !


If anyone over here can post a running configuration sample of Cisco 4948 Switch.


I need to know the interface numbering, specifically of the SFP ports.



Thanks


Zeeshan Sanaullah

Correct Answer by allan.thomas about 6 years 10 months ago

Hi Zeeshan,


The interface number is as follows, these are simply configured as host ports with speed and duplex fixed or left to auto.  Whereas Gigabit1/45-1/48 would typically be your SFP Trunk uplinks to your distribution or core layer using single interface or bundled as port-channel:-


!

vlan 2
name Vlan2
!
vlan 3
name Vlan3

!

vlan 4

name Vlan4
!
vlan 5
name Vlan5

!

vlan 6
  name Vlan6

!

vlan 7
  name Vlan7

!

vlan 8
  name Vlan8

!

vlan 9
  name Vlan9

!

vlan 10
  name Vlan10

!

interface GigabitEthernet1/1

switchport access vlan <??>
speed 1000
duplex full
spanning-tree portfast
spanning-tree bpduguard enable
.

.

interface GigabitEthernet1/44
switchport access vlan <??>
speed 1000
duplex full
spanning-tree portfast
spanning-tree bpduguard enable>

.

.

interface GigabitEthernet1/45
  description Link to Core Switch A
  switchport trunk encapsulation dot1q
  switchport trunk native vlan 1
  switchport trunk allowed vlan 2-10
  switchport mode trunk
  channel-group 1 mode desirable non-silent
!
interface GigabitEthernet1/46
  description Link to Core Switch A
  switchport trunk encapsulation dot1q
  switchport trunk native vlan 1
  switchport trunk allowed vlan 2-10
  switchport mode trunk
channel-group 1 mode desirable non-silent
!
interface GigabitEthernet1/47
  description Link to Core Switch B
  switchport trunk encapsulation dot1q
  switchport trunk native vlan 1
  switchport trunk allowed vlan 2-10
  switchport mode trunk
channel-group 2 mode desirable non-silent
!
interface GigabitEthernet1/48
  description Link to Core Switch B
  switchport trunk encapsulation dot1q
  switchport trunk native vlan 1
  switchport trunk allowed vlan 2-10
  switchport mode trunk
channel-group 2 mode desirable non-silent
!

interface Vlan10
ip address 192.168.1.1 255.255.255.0
!
ip default-gateway 192.168.1.254

!

Regards

Allan.


Hope this helps, pls rate helpful posts.

Correct Answer by allan.thomas about 6 years 11 months ago

Hi Zeeshan,


Hopefully this is the information that you are looking for.  Essentially there are 52 physical interfaces on the 4948, however the last 8 interfaces are still numbered the same gigabit 1/45 - 1/48 and are simply configured as either RJ45 or SFP.  Please take a look at the following guide, you will see that you simply have to specify the media-type under the interface:-


"The interface configuration mode command media-type sfp|rj45 can be used to configure the media  type for these ports in the switch software and determines whether the  SFP or the RJ-45 connector is used. The default is SFP."  Taken from this link:-


http://www.cisco.com/en/US/docs/switches/lan/catalyst4900/4948/05modcfg.html


Regards

Allan.


Hope this helps, pls rate helpful posts.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (3 ratings)
Loading.
Correct Answer
allan.thomas Fri, 04/02/2010 - 03:42

Hi Zeeshan,


Hopefully this is the information that you are looking for.  Essentially there are 52 physical interfaces on the 4948, however the last 8 interfaces are still numbered the same gigabit 1/45 - 1/48 and are simply configured as either RJ45 or SFP.  Please take a look at the following guide, you will see that you simply have to specify the media-type under the interface:-


"The interface configuration mode command media-type sfp|rj45 can be used to configure the media  type for these ports in the switch software and determines whether the  SFP or the RJ-45 connector is used. The default is SFP."  Taken from this link:-


http://www.cisco.com/en/US/docs/switches/lan/catalyst4900/4948/05modcfg.html


Regards

Allan.


Hope this helps, pls rate helpful posts.

Muhammad Zeesha... Fri, 04/02/2010 - 04:40

Allan,


Thanks. I got what I was looking for. One more thing about interface numbering.


Is it Interface Gigabitethernet 0/1 or Gigabitethernet 1/1 for ports on 4948.


Actually I need to develop Configuration templates for this switch but does not physically have the switch right now. If you have this switch then please post a sample running configuration



Thanks


Zeeshan Sanaullah

Correct Answer
allan.thomas Fri, 04/02/2010 - 05:01

Hi Zeeshan,


The interface number is as follows, these are simply configured as host ports with speed and duplex fixed or left to auto.  Whereas Gigabit1/45-1/48 would typically be your SFP Trunk uplinks to your distribution or core layer using single interface or bundled as port-channel:-


!

vlan 2
name Vlan2
!
vlan 3
name Vlan3

!

vlan 4

name Vlan4
!
vlan 5
name Vlan5

!

vlan 6
  name Vlan6

!

vlan 7
  name Vlan7

!

vlan 8
  name Vlan8

!

vlan 9
  name Vlan9

!

vlan 10
  name Vlan10

!

interface GigabitEthernet1/1

switchport access vlan <??>
speed 1000
duplex full
spanning-tree portfast
spanning-tree bpduguard enable
.

.

interface GigabitEthernet1/44
switchport access vlan <??>
speed 1000
duplex full
spanning-tree portfast
spanning-tree bpduguard enable>

.

.

interface GigabitEthernet1/45
  description Link to Core Switch A
  switchport trunk encapsulation dot1q
  switchport trunk native vlan 1
  switchport trunk allowed vlan 2-10
  switchport mode trunk
  channel-group 1 mode desirable non-silent
!
interface GigabitEthernet1/46
  description Link to Core Switch A
  switchport trunk encapsulation dot1q
  switchport trunk native vlan 1
  switchport trunk allowed vlan 2-10
  switchport mode trunk
channel-group 1 mode desirable non-silent
!
interface GigabitEthernet1/47
  description Link to Core Switch B
  switchport trunk encapsulation dot1q
  switchport trunk native vlan 1
  switchport trunk allowed vlan 2-10
  switchport mode trunk
channel-group 2 mode desirable non-silent
!
interface GigabitEthernet1/48
  description Link to Core Switch B
  switchport trunk encapsulation dot1q
  switchport trunk native vlan 1
  switchport trunk allowed vlan 2-10
  switchport mode trunk
channel-group 2 mode desirable non-silent
!

interface Vlan10
ip address 192.168.1.1 255.255.255.0
!
ip default-gateway 192.168.1.254

!

Regards

Allan.


Hope this helps, pls rate helpful posts.

aiwapro09 Thu, 09/19/2013 - 17:47

Are the SFP's numbered this way on the 4948e?  I could not locate a picture with a high enough resolution, to see the numbering on the ports. 

Actions

This Discussion