schinnap Fri, 04/02/2010 - 04:00
User Badges:

The requested memory allocation is not available from the specified memory pool. The router memory has been exhausted or fragmented.


The smart_init is a sw module supposed to estimate the i/o size needed for a hw/sw config. It cuts a portion of the total memory
size and allocates it for the i/o pool, the rest remaining for the processor pool. The traffic pattern this router experiences might be a little bit too
bursty. To avoid that, we might want to disable the smart_init and allocate manually an amount of memory for the i/o pool.


Action plan: please enter at the global config prompt:


2811(config)# memory-size iomem 15


This will disable the smart_init module and will allocate 15% of the total dram to the i/o pool. This will clearly avoid the i/o pool size shortage and
get to the fragmentation we totally dislike.


Once configured, please reload the router to take effect the configuration.
Once done, you'll see this router run fine.

Actions

This Discussion