Inbound Calls Not Working-Interactive I3

Answered Question
Apr 2nd, 2010

Outbound calls work fine, just having trouble with connecting inbound calls to the I3 server.  I have attached my configuration, so if anyone has any ideas, I would greatly appreciate it.


lldcptimain#sh run
Building configuration...


Current configuration : 4166 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname lldcptimain
!
boot-start-marker
boot system flash c2800nm-ipvoicek9-mz.124-22.T4.bin
boot-end-marker
!
card type t1 0 0
logging message-counter syslog
logging buffered 51200 warnings
enable secret 5 $1$FGEF$OH2F1J2DVkONMPY1/ZcEM/
enable password CshYOh9z
!
no aaa new-model
network-clock-participate wic 0
network-clock-select 1 T1 0/0/0
--More--                           !
dot11 syslog
ip source-route
!
!
ip cef
ip dhcp excluded-address 10.173.0.1 10.173.0.3
!
ip dhcp pool 10.173.0.0/24
   network 10.173.0.0 255.255.255.0
   default-router 10.173.0.1
   dns-server 4.2.2.2
   option 160 ascii 10.173.0.2:8088
!
!
ip domain name yourdomain.com
no ipv6 cef
multilink bundle-name authenticated
!
!
!
!
isdn switch-type primary-ni
--More--                           !
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
voice-card 0
dsp services dspfarm
!
!
crypto pki trustpoint TP-self-signed-1270686785
enrollment selfsigned
--More--                            subject-name cn=IOS-Self-Signed-Certificate-1270686785
revocation-check none
rsakeypair TP-self-signed-1270686785
!
!
crypto pki certificate chain TP-self-signed-1270686785
certificate self-signed 01
  30820252 308201BB A0030201 02020101 300D0609 2A864886 F70D0101 04050030
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 31323730 36383637 3835301E 170D3039 30343130 32313434
  30355A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D31 32373036
  38363738 3530819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
  8100C0A2 0F7E8F3A 806A6FCE 493F6AAE 42A11B77 00FA1A92 232A7AD4 A20FE6F0
  BCCF0AEB D5B35D60 D2C5BCEF D3DA5EAB BAE1B191 18864262 0077927F 6EDF0EB3
  31208C0E 97412BDE F0A197AC 9E3266F1 DBD30AE3 5142EE2F 17FA4A5B 7F5BF454
  BCFE2FA0 6D8FF908 F8636E30 329C5CB6 FB35B27F 5FF299F4 5F642660 6BD2F58B
  5A8D0203 010001A3 7A307830 0F060355 1D130101 FF040530 030101FF 30250603
  551D1104 1E301C82 1A6C6C64 63707469 6D61696E 2E796F75 72646F6D 61696E2E
  636F6D30 1F060355 1D230418 30168014 77DC25FA 0CCB3FD5 2C76E570 2C7FDD73
  E7028FF5 301D0603 551D0E04 16041477 DC25FA0C CB3FD52C 76E5702C 7FDD73E7
  028FF530 0D06092A 864886F7 0D010104 05000381 81005A50 EF04FBCA 8183C0D7
  8868A368 435CD697 AF0C2C97 C7F41169 3467B771 6A33703C 355BC548 1D0D4065
--More--                             D45FBA83 935E85C5 B44A1B06 91E0ACB8 64A935AE A7CF8BB7 94E83400 0C5466C0
  EC501C6A E7A86987 8FE5A509 139B0382 43C13668 CE0A9F0D 25553DB5 17FD21DD
  C70A4F37 F6D5E43F 1A6A1491 0A5175C6 415DD1F6 883C
   quit
!
!
username pti password 0 PTIadmin09!@
username ptiadmin password 0 [email protected]
archive
log config
  hidekeys
!
!
controller T1 0/0/0
cablelength long 0db
pri-group timeslots 1-24
!
controller T1 0/0/1
cablelength long 0db
!
!
!
!
--More--                           !
interface GigabitEthernet0/0
description Main_EIS Connection_To_Time_Warner
ip address 10.173.0.3 255.255.255.0
duplex auto
speed auto
!
interface GigabitEthernet0/1
description To_PTI_LAYER3_SWITCH_PTI-LLDC-SW1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0/0:23
no ip address
encapsulation hdlc
isdn switch-type primary-ni
isdn incoming-voice voice
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 10.173.0.1
!
--More--                           ip http server
ip http access-class 23
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
!
access-list 23 permit any
!
!
!
!
control-plane
!
!
!
voice-port 0/0/0:23
!
voice-port 0/1/0
!
voice-port 0/1/1
!
voice-port 0/1/2
--More--                           !
voice-port 0/1/3
!
ccm-manager fax protocol cisco
!
!
!
!
dial-peer voice 101 pots
destination-pattern 9T
port 0/0/0:23
forward-digits 10
!
dial-peer voice 102 voip
session protocol sipv2
session target ipv4:10.173.0.2:5060
incoming called-number .
codec g711ulaw
no vad
!
dial-peer voice 112 voip
!
!
sip-ua
sip-server ipv4:10.173.0.2:5060
!
!
line con 0
line aux 0
line vty 0 4
access-class 23 in
privilege level 15
login local
transport input telnet ssh
line vty 5 15
access-class 23 in
privilege level 15
login local
transport input telnet ssh
!
scheduler allocate 20000 1000
end

lldcptimain#

I have this problem too.
0 votes
Correct Answer by Aaron Harrison about 6 years 8 months ago

Hi

Firstly, I don't know what an Interactive I3 server is, or what specific requirements it has... do you need to authenticate to it? Does the target of the SIP INVITE need to be in a particular format? Etc...

For a starter, try inserting this command into dial-peer 102 to send whatever numbers you are getting inbound on the PRI to the SIP server.... might be worth doing a 'debug isdn q931' to see what 'called' number the service provider is sending in first:

Destination-pattern 54...

(replacing 54... with whatever expression matches the numbers you want to sent to the server 10.173.0.2)

Aaron

Please rate helpful posts..

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Correct Answer
Aaron Harrison Sat, 04/03/2010 - 02:01

Hi

Firstly, I don't know what an Interactive I3 server is, or what specific requirements it has... do you need to authenticate to it? Does the target of the SIP INVITE need to be in a particular format? Etc...

For a starter, try inserting this command into dial-peer 102 to send whatever numbers you are getting inbound on the PRI to the SIP server.... might be worth doing a 'debug isdn q931' to see what 'called' number the service provider is sending in first:

Destination-pattern 54...

(replacing 54... with whatever expression matches the numbers you want to sent to the server 10.173.0.2)

Aaron

Please rate helpful posts..

Adrian Saavedra Sat, 04/03/2010 - 12:07

Hi,

Hmmm, althought I don't know what is interactive-I3, I guess he's referring to a MCS 78XX-I3 server. I saw that outbound calls are working with an H.323 dial peer. Why not also use H.323 dialpeer to route inbound calls towards the CallManager?

Follow Aaron's suggestion of debugging isdn q931 to see what you're receiving in the PRI. Depending on that, then you can configure appropiately the destination pattern in your dialpeer towards the CallManager. For this, you can follow this links for guidance:

http://www.ciscosystems.org/en/US/products/sw/voicesw/ps556/products_configuration_example09186a0080094852.shtml

http://www.cisco.com/en/US/tech/tk652/tk653/technologies_tech_note09186a00801c43f6.shtml

http://www.cisco.com/en/US/tech/tk652/tk653/technologies_tech_note09186a00801142f8.shtml

Just an idea my friend

Hope to help, if it does please rate.

Best regards,

-- Adrián.

Actions

This Discussion